summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-03-01 19:57:11 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-03-01 19:57:11 +0000
commit96f2d21bc20027bc525af221bf8ff6bd139e56fd (patch)
tree53289023f5361e87fd09640bbd3213014660e9ce /net-p2p/bittorrent
parentarm/s390/sh stable (diff)
downloadgentoo-2-96f2d21bc20027bc525af221bf8ff6bd139e56fd.tar.gz
gentoo-2-96f2d21bc20027bc525af221bf8ff6bd139e56fd.tar.bz2
gentoo-2-96f2d21bc20027bc525af221bf8ff6bd139e56fd.zip
Version bump, bug #211863
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-p2p/bittorrent')
-rw-r--r--net-p2p/bittorrent/ChangeLog7
-rw-r--r--net-p2p/bittorrent/bittorrent-5.2.0.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/net-p2p/bittorrent/ChangeLog b/net-p2p/bittorrent/ChangeLog
index 9366e71cc672..1ca14597025f 100644
--- a/net-p2p/bittorrent/ChangeLog
+++ b/net-p2p/bittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/bittorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.129 2008/02/29 20:28:34 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.130 2008/03/01 19:57:11 armin76 Exp $
+
+*bittorrent-5.2.0 (01 Mar 2008)
+
+ 01 Mar 2008; Raúl Porcel <armin76@gentoo.org> +bittorrent-5.2.0.ebuild:
+ Version bump, bug #211863
29 Feb 2008; Carsten Lohrke <carlo@gentoo.org> bittorrent-5.0.9-r1.ebuild:
Remove icon extension from desktop entry to match Icon Theme Specification.
diff --git a/net-p2p/bittorrent/bittorrent-5.2.0.ebuild b/net-p2p/bittorrent/bittorrent-5.2.0.ebuild
new file mode 100644
index 000000000000..ad15104e0e4f
--- /dev/null
+++ b/net-p2p/bittorrent/bittorrent-5.2.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-5.2.0.ebuild,v 1.1 2008/03/01 19:57:11 armin76 Exp $
+
+WX_GTK_VER="2.6"
+inherit distutils fdo-mime eutils wxwidgets
+
+MY_P="${P/bittorrent/BitTorrent}"
+#MY_P="${MY_P/}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="tool for distributing files via a distributed network of nodes"
+HOMEPAGE="http://www.bittorrent.com/"
+SRC_URI="http://download.bittorrent.com/dl/${MY_P}.tar.gz"
+
+LICENSE="BitTorrent"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk"
+
+RDEPEND=">=dev-lang/python-2.3
+ gtk? ( =dev-python/wxpython-2.6* )
+ >=dev-python/pycrypto-2.0
+ >=dev-python/twisted-2
+ dev-python/twisted-web
+ net-zope/zopeinterface"
+DEPEND="${RDEPEND}
+ app-arch/gzip
+ >=sys-apps/sed-4.0.5
+ dev-python/dnspython"
+
+DOCS="README.txt TRACKERLESS.txt public.key"
+PYTHON_MODNAME="BitTorrent"
+
+pkg_setup() {
+ if use gtk ; then
+ need-wxwidgets unicode ||
+ die "You must build wxGTK and wxpython with unicode support"
+
+ if ! built_with_use =dev-python/wxpython-2.6* unicode ; then
+ die "You must build wxGTK and wxpython with unicode support"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # path for documentation is in lowercase #109743
+ sed -i -r "s:(dp.*appdir):\1.lower():" BitTorrent/platform.py
+}
+
+src_install() {
+ distutils_src_install
+ use gtk || rm -f "${D}"/usr/bin/bittorrent
+
+ if use gtk ; then
+ doicon images/logo/bittorrent.ico
+ newicon images/logo/bittorrent_icon_32.png bittorrent.png
+ make_desktop_entry "bittorrent" "BitTorrent" bittorrent "Network"
+ echo "MimeType=application/x-bittorrent" \
+ >> "${D}"/usr/share/applications/bittorrent-${PN}.desktop
+ fi
+
+ newinitd "${FILESDIR}"/bittorrent-tracker.initd bittorrent-tracker
+ newconfd "${FILESDIR}"/bittorrent-tracker.confd bittorrent-tracker
+}
+
+pkg_postinst() {
+ einfo "Remember that BitTorrent has changed file naming scheme"
+ einfo "To run BitTorrent just execute /usr/bin/bittorrent"
+ einfo "To run the init.d, please use /etc/init.d/bittorrent-tracker"
+ elog
+ elog "If you are upgrading from bittorrent-4.4.0 you must remove "
+ elog "the ~/.bittorrent dir to make this version work. Remember to "
+ elog "do a backup first!"
+ elog
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+}