summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-10-16 11:54:32 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-10-16 11:54:32 +0000
commite06f7822dd32cdcf9cc04bd11e281057b39ebea5 (patch)
tree480259ff1696d6acaf3758f463a4c6c7c51746b0 /net-p2p/bittorrent
parentVersion bump (diff)
downloadgentoo-2-e06f7822dd32cdcf9cc04bd11e281057b39ebea5.tar.gz
gentoo-2-e06f7822dd32cdcf9cc04bd11e281057b39ebea5.tar.bz2
gentoo-2-e06f7822dd32cdcf9cc04bd11e281057b39ebea5.zip
Version bump wrt #196022
(Portage version: 2.1.3.9)
Diffstat (limited to 'net-p2p/bittorrent')
-rw-r--r--net-p2p/bittorrent/ChangeLog7
-rw-r--r--net-p2p/bittorrent/bittorrent-5.0.9.ebuild83
-rw-r--r--net-p2p/bittorrent/files/digest-bittorrent-5.0.93
3 files changed, 92 insertions, 1 deletions
diff --git a/net-p2p/bittorrent/ChangeLog b/net-p2p/bittorrent/ChangeLog
index 2318f1318420..b0b2f39fa5db 100644
--- a/net-p2p/bittorrent/ChangeLog
+++ b/net-p2p/bittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/bittorrent
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.117 2007/09/29 00:10:25 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.118 2007/10/16 11:54:31 armin76 Exp $
+
+*bittorrent-5.0.9 (16 Oct 2007)
+
+ 16 Oct 2007; Raúl Porcel <armin76@gentoo.org> +bittorrent-5.0.9.ebuild:
+ Version bump wrt #196022
29 Sep 2007; Ryan Hill <dirtyepic@gentoo.org> bittorrent-5.0.7.ebuild:
Lock wxGTK to 2.6.
diff --git a/net-p2p/bittorrent/bittorrent-5.0.9.ebuild b/net-p2p/bittorrent/bittorrent-5.0.9.ebuild
new file mode 100644
index 000000000000..a85454d97865
--- /dev/null
+++ b/net-p2p/bittorrent/bittorrent-5.0.9.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-5.0.9.ebuild,v 1.1 2007/10/16 11:54:31 armin76 Exp $
+
+inherit distutils fdo-mime eutils
+
+MY_P="${P/bittorrent/BitTorrent}"
+#MY_P="${MY_P/}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="tool for distributing files via a distributed network of nodes"
+HOMEPAGE="http://www.bittorrent.com/"
+SRC_URI="http://download.bittorrent.com/dl/${MY_P}.tar.gz"
+
+LICENSE="BitTorrent"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk"
+
+RDEPEND=">=dev-lang/python-2.3
+ gtk? (
+ =dev-python/wxpython-2.6*
+ )
+ >=dev-python/pycrypto-2.0
+ >=dev-python/twisted-2
+ dev-python/twisted-web
+ net-zope/zopeinterface
+ !virtual/bittorrent"
+DEPEND="${RDEPEND}
+ app-arch/gzip
+ >=sys-apps/sed-4.0.5
+ dev-python/dnspython"
+PROVIDE="virtual/bittorrent"
+
+DOCS="README.txt TRACKERLESS.txt public.key"
+PYTHON_MODNAME="BitTorrent"
+
+pkg_setup() {
+ if use gtk ; then
+ if ! built_with_use x11-libs/wxGTK unicode ; then
+ die "You must build wxGTK and wxpython with unicode support"
+ fi
+ if ! built_with_use dev-python/wxpython unicode ; then
+ die "You must build wxGTK and wxpython with unicode support"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # path for documentation is in lowercase #109743
+ sed -i -r "s:(dp.*appdir):\1.lower():" BitTorrent/platform.py
+}
+
+src_install() {
+ distutils_src_install
+ use gtk || rm -f "${D}"/usr/bin/bittorrent
+
+ if use gtk ; then
+ doicon images/logo/bittorrent.ico
+ newicon images/logo/bittorrent_icon_32.png bittorrent.png
+ make_desktop_entry "bittorrent" "BitTorrent" bittorrent.png "Network"
+ echo "MimeType=application/x-bittorrent" \
+ >> "${D}"/usr/share/applications/bittorrent-${PN}.desktop
+ fi
+
+ newinitd "${FILESDIR}"/bittorrent-tracker.initd bittorrent-tracker
+ newconfd "${FILESDIR}"/bittorrent-tracker.confd bittorrent-tracker
+}
+
+pkg_postinst() {
+ einfo "Remember that BitTorrent has changed file naming scheme"
+ einfo "To run BitTorrent just execute /usr/bin/bittorrent"
+ einfo "To run the init.d, please use /etc/init.d/bittorrent-tracker"
+ elog
+ elog "If you are upgrading from bittorrent-4.4.0 you must remove "
+ elog "the ~/.bittorrent dir to make this version work. Remember to "
+ elog "do a backup first!"
+ elog
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+}
diff --git a/net-p2p/bittorrent/files/digest-bittorrent-5.0.9 b/net-p2p/bittorrent/files/digest-bittorrent-5.0.9
new file mode 100644
index 000000000000..51d5f5c0d375
--- /dev/null
+++ b/net-p2p/bittorrent/files/digest-bittorrent-5.0.9
@@ -0,0 +1,3 @@
+MD5 4e97e19329fc80239bb4a1f2a3e62ef7 BitTorrent-5.0.9.tar.gz 2497550
+RMD160 631d88c31ebd2f656477791db18e6a868349a2d5 BitTorrent-5.0.9.tar.gz 2497550
+SHA256 4459f694609328e55f829fe2e1143518e35f471aed7814da7689fee5d422f705 BitTorrent-5.0.9.tar.gz 2497550