summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2008-10-15 00:38:42 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2008-10-15 00:38:42 +0000
commit0f1bc3fa9f88e4244fa3f9b70955dc7d735140ed (patch)
tree787681203179e5adf3b2b450dd0a438f46cff3fa /net-p2p/ktorrent
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-0f1bc3fa9f88e4244fa3f9b70955dc7d735140ed.tar.gz
gentoo-2-0f1bc3fa9f88e4244fa3f9b70955dc7d735140ed.tar.bz2
gentoo-2-0f1bc3fa9f88e4244fa3f9b70955dc7d735140ed.zip
Added ktorrent ebuild from the kde-testing overlay.
Thanks to Tomáš Chvátal <tomas.chvatal@gmail.com> for the bump. (Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'net-p2p/ktorrent')
-rw-r--r--net-p2p/ktorrent/ChangeLog9
-rw-r--r--net-p2p/ktorrent/ktorrent-3.1.3.ebuild52
-rw-r--r--net-p2p/ktorrent/metadata.xml1
3 files changed, 61 insertions, 1 deletions
diff --git a/net-p2p/ktorrent/ChangeLog b/net-p2p/ktorrent/ChangeLog
index 157da198b0b5..668a0d34a10f 100644
--- a/net-p2p/ktorrent/ChangeLog
+++ b/net-p2p/ktorrent/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/ktorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.87 2008/07/17 19:11:48 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.88 2008/10/15 00:38:42 jmbsvicetto Exp $
+
+*ktorrent-3.1.3 (15 Oct 2008)
+
+ 15 Oct 2008; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ metadata.xml, +ktorrent-3.1.3.ebuild:
+ Added ktorrent ebuild from the kde-testing overlay. Thanks to Tomáš
+ Chvátal <tomas.chvatal@gmail.com> for the bump.
17 Jul 2008; Markus Rothe <corsair@gentoo.org> ktorrent-2.2.7.ebuild:
Stable on ppc64; bug #231630
diff --git a/net-p2p/ktorrent/ktorrent-3.1.3.ebuild b/net-p2p/ktorrent/ktorrent-3.1.3.ebuild
new file mode 100644
index 000000000000..8a592b707733
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-3.1.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-3.1.3.ebuild,v 1.1 2008/10/15 00:38:42 jmbsvicetto Exp $
+
+EAPI="2"
+
+NEED_KDE=":4.1"
+KDE_LINGUAS="ar be bg ca da de el en_GB eo es et eu fi fr ga gl hi hu it ja km
+lt lv nb nds nl nn oc pl pt pt_BR ro ru se sk sl sv tr uk zh_CN zh_TW"
+inherit kde4-base
+
+DESCRIPTION="A BitTorrent program for KDE."
+HOMEPAGE="http://ktorrent.org/"
+SRC_URI="http://ktorrent.org/downloads/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4.1"
+IUSE="+bwscheduler +infowidget +ipfilter +logviewer +mediaplayer +scanfolder +search +stats +upnp webinterface zeroconf"
+
+DEPEND="app-crypt/qca:2
+ app-misc/strigi
+ dev-libs/gmp
+ sys-devel/gettext
+ !kdeprefix? ( !net-p2p/ktorrent:0 )"
+RDEPEND="${DEPEND}
+ infowidget? ( >=dev-libs/geoip-1.4.4 )
+ ipfilter? (
+ || ( kde-base/kdebase-kioslaves:${SLOT}
+ kde-base/kdelibs:${SLOT} ) )
+ zeroconf? ( kde-base/kdnssd:${SLOT} )"
+
+src_configure() {
+ local mycmakeargs
+
+ mycmakeargs="${mycmakeargs}
+ -DCMAKE_INSTALL_PREFIX=${PREFIX}
+ -DENABLE_DHT_SUPPORT=ON
+ $(cmake-utils_use_enable bwscheduler BWSCHEDULER_PLUGIN)
+ $(cmake-utils_use_enable infowidget INFOWIDGET_PLUGIN)
+ $(cmake-utils_use_with infowidget SYSTEM_GEOIP)
+ $(cmake-utils_use_enable ipfilter IPFILTER_PLUGIN)
+ $(cmake-utils_use_enable logviewer LOGVIEWER_PLUGIN)
+ $(cmake-utils_use_enable scanfolder SCANFOLDER_PLUGIN)
+ $(cmake-utils_use_enable search SEARCH_PLUGIN)
+ $(cmake-utils_use_enable stats STATS_PLUGIN)
+ $(cmake-utils_use_enable upnp UPNP_PLUGIN)
+ $(cmake-utils_use_enable webinterface WEBINTERFACE_PLUGIN)
+ $(cmake-utils_use_enable zeroconf ZEROCONF_PLUGIN)
+ $(cmake-utils_use_enable mediaplayer MEDIAPLAYER_PLUGIN)"
+ kde4-base_src_configure
+}
diff --git a/net-p2p/ktorrent/metadata.xml b/net-p2p/ktorrent/metadata.xml
index f20859c2669c..f55f61c1b989 100644
--- a/net-p2p/ktorrent/metadata.xml
+++ b/net-p2p/ktorrent/metadata.xml
@@ -12,6 +12,7 @@
<flag name="infowidget">Enable the infowidget plugin</flag>
<flag name="ipfilter">Enable the ipfilter plugin</flag>
<flag name="logviewer">Enable the logviewer plugin</flag>
+ <flag name="mediaplayer">Enable the mediaplayer plugin</flag>
<flag name="scanfolder">Enable the scanfolder plugin</flag>
<flag name="search">Enable the search plugin</flag>
<flag name="stats">Enable the statistics plugin</flag>