summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-07-12 13:44:09 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-07-12 13:44:09 +0000
commit0b4256b18894f3df15cfcb27d4c83f1fea85bea7 (patch)
treed7a56c0b6d7f03ddc47c89e6a2390ef294b50052 /net-p2p
parentVersion bump. (diff)
downloadgentoo-2-0b4256b18894f3df15cfcb27d4c83f1fea85bea7.tar.gz
gentoo-2-0b4256b18894f3df15cfcb27d4c83f1fea85bea7.tar.bz2
gentoo-2-0b4256b18894f3df15cfcb27d4c83f1fea85bea7.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitflu/ChangeLog7
-rw-r--r--net-p2p/bitflu/bitflu-1.52.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/net-p2p/bitflu/ChangeLog b/net-p2p/bitflu/ChangeLog
index e08f23f489c8..7f595aa054a8 100644
--- a/net-p2p/bitflu/ChangeLog
+++ b/net-p2p/bitflu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/bitflu
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitflu/ChangeLog,v 1.23 2015/03/21 21:54:33 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitflu/ChangeLog,v 1.24 2015/07/12 13:44:09 blueness Exp $
+
+*bitflu-1.52 (12 Jul 2015)
+
+ 12 Jul 2015; Anthony G. Basile <blueness@gentoo.org> +bitflu-1.52.ebuild:
+ Version bump.
21 Mar 2015; Justin Lecher <jlec@gentoo.org> -bitflu-1.43.ebuild,
bitflu-1.50.ebuild, bitflu-1.51.ebuild:
diff --git a/net-p2p/bitflu/bitflu-1.52.ebuild b/net-p2p/bitflu/bitflu-1.52.ebuild
new file mode 100644
index 000000000000..9f34493fb306
--- /dev/null
+++ b/net-p2p/bitflu/bitflu-1.52.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitflu/bitflu-1.52.ebuild,v 1.1 2015/07/12 13:44:09 blueness Exp $
+
+EAPI=5
+
+inherit user
+
+DESCRIPTION="BitTorrent client, written in Perl and is designed to run as a daemon"
+HOMEPAGE="http://bitflu.workaround.ch"
+SRC_URI="http://bitflu.workaround.ch/bitflu/${P}.tgz"
+
+LICENSE="Artistic-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-perl/Danga-Socket
+ dev-perl/Sys-Syscall"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup bitflu
+ enewuser bitflu -1 -1 /var/lib/bitflu bitflu
+}
+
+src_compile() { :; }
+
+PLUGINS="/usr/lib/bitflu"
+HOMEDIR="/var/lib/bitflu"
+CONFDIR="/etc/bitflu"
+LOGDIR="/var/log/bitflu"
+
+src_install() {
+ # executable daemon
+ dosbin bitflu.pl
+
+ # plugins
+ insinto "${PLUGINS}"
+ doins -r plugins
+
+ # working dir
+ dodir "${HOMEDIR}"
+ fowners bitflu:bitflu "${HOMEDIR}"
+ fperms 775 "${HOMEDIR}"
+
+ # config file
+ insinto "${CONFDIR}"
+ fowners bitflu:bitflu "${CONFDIR}"
+ fperms 775 "${CONFDIR}"
+ doins "${FILESDIR}"/bitflu.config
+ fowners bitflu:bitflu "${CONFDIR}"/bitflu.config
+ fperms 664 "${CONFDIR}"/bitflu.config
+
+ # log file
+ dodir "${LOGDIR}"
+ fowners bitflu:bitflu "${LOGDIR}"
+ fperms 775 "${LOGDIR}"
+
+ # docs
+ dodoc bitflu.config.example ChangeLog.txt CONTRIBUTING README_IPv6.txt \
+ README.txt Documentation/bitflu-internals.txt
+
+ newinitd "${FILESDIR}"/bitflu.initd bitflu
+}
+
+pkg_postinst() {
+ ewarn "Note: At startup, or at the user's request, ${PN} (re)reads its"
+ ewarn "configuration file and overwrites it with its own sanitized"
+ ewarn "version. A backup is created in the configuration directory,"
+ ewarn "/etc/${PN}, but that file will subseqently be overwritten if"
+ ewarn "a further backup is made. You may want to keep your own backup."
+ ewarn "A prestine example with comments may be found in /usr/share/doc/${P}."
+}