summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2010-07-11 17:40:17 +0000
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2010-07-11 17:40:17 +0000
commit3a2b700da520927e92d3bfebf4336fe24132ce05 (patch)
treef98910d124d3fa5d0c8e068f87ac0bc092696de4 /net-p2p
parentalpha/arm/ia64/s390/sh/sparc stable wrt #325847 (diff)
downloadgentoo-2-3a2b700da520927e92d3bfebf4336fe24132ce05.tar.gz
gentoo-2-3a2b700da520927e92d3bfebf4336fe24132ce05.tar.bz2
gentoo-2-3a2b700da520927e92d3bfebf4336fe24132ce05.zip
Remove dbus useflag, no longer supported upstream (#320809)
Fix doc installation (#298899) (Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/lince/ChangeLog9
-rw-r--r--net-p2p/lince/lince-1.2-r1.ebuild40
2 files changed, 48 insertions, 1 deletions
diff --git a/net-p2p/lince/ChangeLog b/net-p2p/lince/ChangeLog
index 828cef3cb2e1..17c7af45cd91 100644
--- a/net-p2p/lince/ChangeLog
+++ b/net-p2p/lince/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/lince
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/lince/ChangeLog,v 1.19 2010/05/05 21:47:39 sochotnicky Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/lince/ChangeLog,v 1.20 2010/07/11 17:40:17 sochotnicky Exp $
+
+*lince-1.2-r1 (11 Jul 2010)
+
+ 11 Jul 2010; Stanislav Ochotnicky <sochotnicky@gentoo.org>
+ +lince-1.2-r1.ebuild:
+ Remove dbus useflag, no longer supported upstream (#320809)
+ Fix doc installation (#298899)
*lince-1.2 (05 May 2010)
diff --git a/net-p2p/lince/lince-1.2-r1.ebuild b/net-p2p/lince/lince-1.2-r1.ebuild
new file mode 100644
index 000000000000..2c9e40b1961c
--- /dev/null
+++ b/net-p2p/lince/lince-1.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/lince/lince-1.2-r1.ebuild,v 1.1 2010/07/11 17:40:17 sochotnicky Exp $
+
+EAPI=2
+
+inherit eutils autotools
+
+DESCRIPTION="A light, powerful and full-featured gtkmm bittorrent client"
+SRC_URI="mirror://sourceforge/lincetorrent/${P}.tar.gz"
+HOMEPAGE="http://lincetorrent.sourceforge.net"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="dev-cpp/gtkmm:2.4
+ dev-cpp/cairomm
+ >=dev-cpp/glibmm-2.16
+ =net-libs/rb_libtorrent-0.14*
+ >=dev-libs/boost-1.36
+ dev-libs/libxml2
+ sys-devel/gettext
+ x11-libs/libnotify"
+DEPEND="${RDEPEND}
+ dev-util/intltool"
+
+src_prepare () {
+ # Fix doc installation directory (#298899)
+ sed -i "s|/share/doc/lince|/share/doc/lince-${PV}|" Makefile.am
+
+ # Fix double file installation (fails with some coreutils)
+ sed -i 's/nova2.py helpers.py/ helpers.py/' data/search_engine/Makefile.am
+ eautoreconf
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}