summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-19 01:25:33 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-19 01:25:33 +0000
commit722639f0a727375486c3ce6c1f1133ac2b867ae1 (patch)
tree4c343bae3fc636e3d7b92568153f48db82cdd9cf /net-p2p
parentReplace -O2 with -O3 on x86 systems running GCC 4.1. Closes bug #151221. (diff)
downloadgentoo-2-722639f0a727375486c3ce6c1f1133ac2b867ae1.tar.gz
gentoo-2-722639f0a727375486c3ce6c1f1133ac2b867ae1.tar.bz2
gentoo-2-722639f0a727375486c3ce6c1f1133ac2b867ae1.zip
Replace -O2 with -O3 on x86 systems running GCC 4.1. Closes bug #151221.
(Portage version: 2.1.2_pre3-r3)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/rtorrent/ChangeLog8
-rw-r--r--net-p2p/rtorrent/files/digest-rtorrent-0.6.3-r13
-rw-r--r--net-p2p/rtorrent/rtorrent-0.6.3-r1.ebuild52
3 files changed, 62 insertions, 1 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index cdd8279ec244..e6c7febba067 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.61 2006/10/05 15:04:57 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.62 2006/10/19 01:25:33 flameeyes Exp $
+
+*rtorrent-0.6.3-r1 (19 Oct 2006)
+
+ 19 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +rtorrent-0.6.3-r1.ebuild:
+ Replace -O2 with -O3 on x86 systems running GCC 4.1. Closes bug #151221.
*rtorrent-0.6.3 (05 Oct 2006)
diff --git a/net-p2p/rtorrent/files/digest-rtorrent-0.6.3-r1 b/net-p2p/rtorrent/files/digest-rtorrent-0.6.3-r1
new file mode 100644
index 000000000000..c1dbd3912746
--- /dev/null
+++ b/net-p2p/rtorrent/files/digest-rtorrent-0.6.3-r1
@@ -0,0 +1,3 @@
+MD5 80119c01f484a81626ca89d83bfee885 rtorrent-0.6.3.tar.gz 411337
+RMD160 95c6a7d56d88245a4adf8450261cd82c1923f191 rtorrent-0.6.3.tar.gz 411337
+SHA256 ac9b007213e1a124fee3e4ea77c2f7e94e2e9cc9366702a2ec668ebef8907533 rtorrent-0.6.3.tar.gz 411337
diff --git a/net-p2p/rtorrent/rtorrent-0.6.3-r1.ebuild b/net-p2p/rtorrent/rtorrent-0.6.3-r1.ebuild
new file mode 100644
index 000000000000..c97c92212e96
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.6.3-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.6.3-r1.ebuild,v 1.1 2006/10/19 01:25:33 flameeyes Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND=">=net-libs/libtorrent-0.10.1
+ >=dev-libs/libsigc++-2.0
+ >=net-misc/curl-7.12
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ sys-devel/bc"
+
+src_compile() {
+ replace-flags -Os -O2
+
+ if [[ $(tc-arch) = "x86" ]]; then
+ filter-flags -fomit-frame-pointer
+
+ # See bug #151221. It seems only to hit on GCC 4.1 and x86 architecture
+ # it could be safer to fallback to -O1, but with the high use of STL in
+ # rtorrent, that could make it too slow.
+ [[ $(gcc-major-version)$(gcc-minor-version) == "41" ]] && replace-flags -O2 -O3
+ fi
+
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+pkg_postinst() {
+ einfo "rtorrent now supports a configuration file."
+ einfo "A sample configuration file for rtorrent is can be found"
+ einfo "in ${ROOT}usr/share/doc/${PF}/rtorrent.rc.gz."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO doc/rtorrent.rc
+}