summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2008-04-20 14:39:08 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2008-04-20 14:39:08 +0000
commitbbc902f2714b53a642c812f93f9c731ec6f3d726 (patch)
treea69ea3081f20b4403025d7df2be5817fe6e0eea0 /net-p2p
parentFix aspell vs spell USE-flag disparity (diff)
downloadgentoo-2-bbc902f2714b53a642c812f93f9c731ec6f3d726.tar.gz
gentoo-2-bbc902f2714b53a642c812f93f9c731ec6f3d726.tar.bz2
gentoo-2-bbc902f2714b53a642c812f93f9c731ec6f3d726.zip
Version bump.
(Portage version: 2.1.5_rc3)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/azureus/ChangeLog10
-rw-r--r--net-p2p/azureus/azureus-3.0.5.2.ebuild156
-rw-r--r--net-p2p/azureus/files/azureus-3.0.5.2-pre78
-rw-r--r--net-p2p/azureus/files/patches-3.0.5.2/remove-osx-platform.patch12
-rw-r--r--net-p2p/azureus/files/patches-3.0.5.2/use-jdk-cipher-only.patch43
5 files changed, 298 insertions, 1 deletions
diff --git a/net-p2p/azureus/ChangeLog b/net-p2p/azureus/ChangeLog
index 2b25e91f96ef..41bc1b65ccf4 100644
--- a/net-p2p/azureus/ChangeLog
+++ b/net-p2p/azureus/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/azureus
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.65 2008/04/03 19:43:57 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.66 2008/04/20 14:39:07 betelgeuse Exp $
+
+*azureus-3.0.5.2 (20 Apr 2008)
+
+ 20 Apr 2008; Petteri Räty <betelgeuse@gentoo.org>
+ +files/azureus-3.0.5.2-pre,
+ +files/patches-3.0.5.2/remove-osx-platform.patch,
+ +files/patches-3.0.5.2/use-jdk-cipher-only.patch, +azureus-3.0.5.2.ebuild:
+ Version bump.
*azureus-3.0.5.0-r1 (03 Apr 2008)
diff --git a/net-p2p/azureus/azureus-3.0.5.2.ebuild b/net-p2p/azureus/azureus-3.0.5.2.ebuild
new file mode 100644
index 000000000000..1c3f2e7b8ad8
--- /dev/null
+++ b/net-p2p/azureus/azureus-3.0.5.2.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/azureus-3.0.5.2.ebuild,v 1.1 2008/04/20 14:39:07 betelgeuse Exp $
+
+###
+### @Todo The new Azureus gui requires swt built with embedded mozilla support,
+### or azureus will hang at startup. However, you can still start
+### the old GUI which doesn't require it, by using file/restart (which
+### is kind of bug, and maybe I should put that patch, that removes
+### restart from menu, back). It probably could be invoked also by using
+### a different Main class (look for them there are plenty :) so we could
+### have some old-gui flag which would run that one and remove
+### the mozilla dep. Best would be some per-user setting and startup
+### script check for swt mozilla support and die...
+###
+
+EAPI=1
+
+JAVA_PKG_IUSE="source"
+
+inherit eutils fdo-mime java-pkg-2 java-ant-2
+
+DESCRIPTION="BitTorrent client in Java"
+HOMEPAGE="http://azureus.sourceforge.net/"
+SRC_URI="mirror://sourceforge/azureus/Azureus_${PV}_source.zip"
+LICENSE="GPL-2 BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-java/json-simple:0
+ >=dev-java/bcprov-1.35:0
+ >=dev-java/commons-cli-1.0:1
+ >=dev-java/log4j-1.2.8:0
+ >=dev-java/swt-3.4_pre6-r1:3.4
+ !net-p2p/azureus-bin
+ >=virtual/jre-1.5"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-util/desktop-file-utils
+ >=virtual/jdk-1.5"
+
+JAVA_PKG_FILTER_COMPILER="jikes"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ if ! built_with_use --missing false -o dev-java/swt firefox seamonkey xulrunner; then
+ eerror
+ eerror "dev-java/swt:3.4 must be compiled with the firefox, seamonkey or xulrunner USE flag"
+ eerror "(support may vary per swt version) or azureus will hang at startup!"
+ eerror
+ die "recompile dev-java/swt:3.4 with embedded browser"
+ fi
+ java-pkg-2_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}/patches-3.0.5.2/use-jdk-cipher-only.patch"
+ epatch "${FILESDIR}/patches-3.0.5.2/remove-osx-platform.patch"
+
+ ### Remove an unit test we never run
+ #rm -v ./org/gudy/azureus2/ui/console/multiuser/TestUserManager.java || die
+
+ ### Removes OS X files and entries.
+ rm -rv "org/gudy/azureus2/platform/macosx" \
+ "org/gudy/azureus2/ui/swt/osx" || die
+
+ ### Removes Windows files.
+ rm -v ./org/gudy/azureus2/ui/swt/win32/Win32UIEnhancer.java || die
+
+ ### Removes test files.
+ rm -rv "org/gudy/azureus2/ui/swt/test" || die
+
+ ### Removes bouncycastle (we use our own bcprov).
+ rm -rv "org/bouncycastle" || die
+
+ ### Removes bundled json
+ rm -rv "org/json" || die
+
+ mkdir -p build/libs || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="swt-3.4,commons-cli-1,log4j,bcprov,json-simple"
+
+src_install() {
+ java-pkg_dojar dist/*.jar || die "dojar failed"
+ dodoc ChangeLog.txt || die
+
+ java-pkg_dolauncher "${PN}" \
+ --main 'org.gudy.azureus2.${UI}.Main' \
+ -pre "${FILESDIR}/${PN}-3.0.5.2-pre" \
+ --java_args '-Dazureus.install.path=${HOME}/.azureus/ ${JAVA_OPTIONS}'
+
+ # https://bugs.gentoo.org/show_bug.cgi?id=204132
+ java-pkg_register-environment-variable MOZ_PLUGIN_PATH /usr/lib/nsbrowser/plugins
+
+ doicon "${FILESDIR}/azureus.png"
+ domenu "${FILESDIR}/azureus.desktop"
+
+ use source && java-pkg_dosrc "${S}"/{com,edu,org}
+}
+
+pkg_postinst() {
+ ###
+ ### @Todo We should probably deactivate auto-update it by default,
+ ### or even remove the option.
+ ###
+ elog
+ elog "It is not recommended to use the Azureus auto-update feature,"
+ elog "and it might not even work. You should disable auto-update,"
+ elog "in \"Tools\" -> \"Options...\" -> \"Interface\" -> \"Start\"."
+ elog
+
+ elog
+ elog "After running azureus for the first time, configuration"
+ elog "options will be placed in \"~/.azureus/gentoo.config\"."
+ elog "If you need to change some startup options, you should"
+ elog "modify this file, rather than the startup script."
+ elog
+ elog "Using this config file you can start the console UI."
+ elog
+ ewarn "The org.gudy.azureus2.ui.common.Main wrapper is gone in 3.0.5.2"
+ ewarn "so if you use something other than console or swt as the UI"
+ ewarn "option, you will need to adjust the setting. See /usr/bin/azureus"
+ ewarn "on how console and swt are mapped to starter classes. This should"
+ ewarn "a problem with just this release."
+
+ elog
+ elog "If you have problems starting Azureus, try starting it"
+ elog "from the command line to look at debugging output."
+ elog
+
+ elog
+ elog "To switch from classic UI to Vuze use:"
+ elog "Tools -> Options -> Interface -> Start"
+ elog "\t-> Display Azureus UI Chooser"
+ elog "Restart not working properly is a known issue."
+ elog
+
+ ewarn
+ ewarn "Running Azureus as root is not supported."
+ ewarn
+
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/net-p2p/azureus/files/azureus-3.0.5.2-pre b/net-p2p/azureus/files/azureus-3.0.5.2-pre
new file mode 100644
index 000000000000..3a8973016355
--- /dev/null
+++ b/net-p2p/azureus/files/azureus-3.0.5.2-pre
@@ -0,0 +1,78 @@
+#
+# Copyright (c) 2005, Petteri Räty <betelgeuse@gentoo.org>
+# Copyright (c) 2004, Jochen Maes <sejo@gentoo.org>
+# Copyright (c) 2004, Karl Trygve Kalleberg <karltk@gentoo.org>
+# Copyright (c) 2004, Gentoo Foundation
+#
+# Licensed under the GNU General Public License, v2
+
+# The Azureus config dir has moved
+olddotazudir="${HOME}/.Azureus"
+oldgentoocfg="${olddotazudir}/gentoo.config"
+dotazudir="${HOME}/.azureus"
+gentoocfg="${dotazudir}/gentoo.config"
+
+if [[ -f "${oldgentoocfg}" && -f "${gentoocfg}" ]]; then
+ cat > /dev/stderr <<END
+You have gentoo.config files in both
+${dotazudir} and
+${olddotazudir}
+${olddotazudir} is deprecated and you can delete this directory.
+
+END
+fi
+
+create_initial_config() {
+ if [[ ! -e "${dotazudir}" ]] ; then
+ mkdir "${dotazudir}"
+ echo "Creating ${dotazudir}"
+ fi
+
+ [[ ${UI} ]] && UI="swt"
+
+ echo "Creating ${gentoocfg}"
+
+ # Create the config file
+ cat > "${gentoocfg}" <<END
+# User Interface options:
+# console - console based
+# swt - swt (GUI) based
+UI="${UI}"
+
+# Options you want to pass to the java binary
+JAVA_OPTIONS=""
+END
+}
+
+if [[ -f "${gentoocfg}" ]] ; then
+ . "${gentoocfg}"
+ echo "using ${gentoocfg}"
+elif [[ -f "${oldgentoocfg}" ]]; then
+ . "${oldgentoocfg}"
+ echo "using ${oldgentoocfg}"
+else
+ create_initial_config
+fi
+
+if [[ -z "${UI}" && -n "${UI_OPTIONS}" ]]; then
+ echo '${UI_OPTIONS} is no longer supported. ${UI} should be used instead instead' > /dev/stderr
+ echo 'Unsetting ${UI_OPTIONS} and trying to migrate to ${UI}' > /dev/stderr
+ if [[ ${UI_OPTIONS} = *--ui=console* ]]; then
+ UI=console
+ elif [[ ${UI_OPTIONS} = *--ui=swt* ]]; then
+ UI=swt
+ else
+ echo 'Could not make $UI from $UI_OPTIONS' > /dev/stderr
+ fi
+ unset UI_OPTIONS
+fi
+
+if [[ -z "${UI}" ]]; then
+ echo '$UI not set defaulting to swt' > /dev/stderr
+ UI="swt"
+fi
+
+[[ ${UI} == swt ]] && UI=ui.swt
+[[ ${UI} == console ]] && UI=cl
+
+[[ ! -e "${dotazudir}" ]] && create_initial_config
diff --git a/net-p2p/azureus/files/patches-3.0.5.2/remove-osx-platform.patch b/net-p2p/azureus/files/patches-3.0.5.2/remove-osx-platform.patch
new file mode 100644
index 000000000000..35817573280f
--- /dev/null
+++ b/net-p2p/azureus/files/patches-3.0.5.2/remove-osx-platform.patch
@@ -0,0 +1,12 @@
+diff -ur work.old/org/gudy/azureus2/platform/PlatformManagerFactory.java work/org/gudy/azureus2/platform/PlatformManagerFactory.java
+--- work.old/org/gudy/azureus2/platform/PlatformManagerFactory.java 2008-04-20 15:53:14.000000000 +0300
++++ work/org/gudy/azureus2/platform/PlatformManagerFactory.java 2008-04-20 15:53:31.000000000 +0300
+@@ -52,7 +52,7 @@
+
+ }else if( getPlatformType() == PlatformManager.PT_MACOSX ){
+
+- platform_manager = org.gudy.azureus2.platform.macosx.PlatformManagerImpl.getSingleton();
++ //platform_manager = org.gudy.azureus2.platform.macosx.PlatformManagerImpl.getSingleton();
+
+ }else if( getPlatformType() == PlatformManager.PT_UNIX ){
+
diff --git a/net-p2p/azureus/files/patches-3.0.5.2/use-jdk-cipher-only.patch b/net-p2p/azureus/files/patches-3.0.5.2/use-jdk-cipher-only.patch
new file mode 100644
index 000000000000..cfae1d4e973d
--- /dev/null
+++ b/net-p2p/azureus/files/patches-3.0.5.2/use-jdk-cipher-only.patch
@@ -0,0 +1,43 @@
+diff -ur work.old/com/aelitis/azureus/core/clientmessageservice/secure/impl/SecureMessageServiceClientHelper.java work/com/aelitis/azureus/core/clientmessageservice/secure/impl/SecureMessageServiceClientHelper.java
+--- work.old/com/aelitis/azureus/core/clientmessageservice/secure/impl/SecureMessageServiceClientHelper.java 2008-04-20 15:29:59.000000000 +0300
++++ work/com/aelitis/azureus/core/clientmessageservice/secure/impl/SecureMessageServiceClientHelper.java 2008-04-20 15:35:56.000000000 +0300
+@@ -36,7 +36,7 @@
+ import org.bouncycastle.crypto.encodings.PKCS1Encoding;
+ import org.bouncycastle.crypto.engines.RSAEngine;
+ import org.bouncycastle.crypto.params.ParametersWithRandom;
+-import org.bouncycastle.jce.provider.RSAUtil;
++//import org.bouncycastle.jce.provider.RSAUtil;
+ import org.gudy.azureus2.core3.util.Debug;
+ import org.gudy.azureus2.plugins.utils.StaticUtilities;
+
+@@ -82,13 +82,15 @@
+
+ byte[] secret_bytes = session_key.getEncoded();
+
+- try{
++ //try{
+ Cipher rsa_cipher = Cipher.getInstance( "RSA" );
+
+ rsa_cipher.init( Cipher.ENCRYPT_MODE, public_key );
+
+ encryped_session_key = rsa_cipher.doFinal( secret_bytes );
+-
++
++ /* Gentoo: Depend on JDK >=1.5 so we don't need this code. This does not work
++ * with our packaged bcprov
+ }catch( Throwable e ){
+
+ // fallback to the BC implementation for jdk1.4.2 as JCE RSA not available
+@@ -105,6 +107,7 @@
+
+ encryped_session_key = padded_eng.processBlock(secret_bytes, 0, secret_bytes.length);
+ }
++ */
+
+ }catch( Throwable e ){
+
+Only in work.old/org: bouncycastle
+Only in work.old/org/gudy/azureus2/platform: macosx
+Only in work.old/org/gudy/azureus2/ui/swt: osx
+Only in work.old/org/gudy/azureus2/ui/swt: test
+Only in work.old/org/gudy/azureus2/ui/swt/win32: Win32UIEnhancer.java