summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-09-04 21:20:40 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-09-04 21:20:40 +0000
commite5ea0d739f0bf7ef41fd8c093361fa5af7928e36 (patch)
tree33a1003faaea3218cff921dae4cd1967035b09f7 /net-print/cups
parentAdd ~x86-fbsd keyword. (diff)
downloadgentoo-2-e5ea0d739f0bf7ef41fd8c093361fa5af7928e36.tar.gz
gentoo-2-e5ea0d739f0bf7ef41fd8c093361fa5af7928e36.tar.bz2
gentoo-2-e5ea0d739f0bf7ef41fd8c093361fa5af7928e36.zip
Add php useflag, bug 144464 thanks to Christian Korff <christian.korff@gmail.com>, version bump thanks to Francisco Javier <ffelix@sshinf.com> in bug 146266, add patch from upstream issue tracker to fix problems with dead links thanks to Ed Catmur
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'net-print/cups')
-rw-r--r--net-print/cups/ChangeLog11
-rw-r--r--net-print/cups/cups-1.2.3.ebuild202
-rw-r--r--net-print/cups/files/cupsDirRead-dont-end-on-failed-stat.patch41
-rw-r--r--net-print/cups/files/digest-cups-1.2.33
4 files changed, 256 insertions, 1 deletions
diff --git a/net-print/cups/ChangeLog b/net-print/cups/ChangeLog
index a4438d404314..5ed7b819757d 100644
--- a/net-print/cups/ChangeLog
+++ b/net-print/cups/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-print/cups
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.198 2006/09/02 04:23:56 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.199 2006/09/04 21:20:40 genstef Exp $
+
+*cups-1.2.3 (04 Sep 2006)
+
+ 04 Sep 2006; Stefan Schweizer <genstef@gentoo.org>
+ +files/cupsDirRead-dont-end-on-failed-stat.patch, +cups-1.2.3.ebuild:
+ Add php useflag, bug 144464 thanks to Christian Korff
+ <christian.korff@gmail.com>, version bump thanks to Francisco Javier
+ <ffelix@sshinf.com> in bug 146266, add patch from upstream issue tracker to
+ fix problems with dead links thanks to Ed Catmur
02 Sep 2006; Stefan Schweizer <genstef@gentoo.org> cups-1.2.2.ebuild:
resolve circular dep by moving the ppds dep to PDEPEND, thanks to Mart
diff --git a/net-print/cups/cups-1.2.3.ebuild b/net-print/cups/cups-1.2.3.ebuild
new file mode 100644
index 000000000000..0103cafaee31
--- /dev/null
+++ b/net-print/cups/cups-1.2.3.ebuild
@@ -0,0 +1,202 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.2.3.ebuild,v 1.1 2006/09/04 21:20:40 genstef Exp $
+
+inherit autotools eutils flag-o-matic multilib pam
+
+MY_P=${P/_/}
+
+DESCRIPTION="The Common Unix Printing System"
+HOMEPAGE="http://www.cups.org/"
+SRC_URI="http://ftp.easysw.com/pub/cups/${PV}/${MY_P}-source.tar.bz2"
+#ESVN_REPO_URI="http://svn.easysw.com/public/cups/trunk"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl slp pam php samba nls dbus tiff png ppds jpeg X"
+
+DEP="pam? ( virtual/pam )
+ ssl? ( net-libs/gnutls )
+ slp? ( >=net-libs/openslp-1.0.4 )
+ dbus? ( || ( sys-apps/dbus-core sys-apps/dbus ) )
+ png? ( >=media-libs/libpng-1.2.1 )
+ tiff? ( >=media-libs/tiff-3.5.5 )
+ jpeg? ( >=media-libs/jpeg-6b )
+ php? ( dev-lang/php )
+ app-text/libpaper"
+DEPEND="${DEP}
+ nls? ( sys-devel/gettext )"
+RDEPEND="${DEP}
+ nls? ( virtual/libintl )
+ !virtual/lpr
+ >=app-text/poppler-0.4.3-r1
+ X? ( x11-misc/xdg-utils )
+ "
+PDEPEND="
+ ppds? ( || (
+ (
+ net-print/foomatic-filters-ppds
+ net-print/foomatic-db-ppds
+ )
+ net-print/foomatic-filters-ppds
+ net-print/foomatic-db-ppds
+ net-print/hplip
+ media-gfx/gimp-print
+ net-print/foo2zjs
+ net-print/cups-pdf
+ ) )
+ "
+ # keywording xdg-utils in bug 144345
+PDEPEND="samba? ( >=net-fs/samba-3.0.8 )
+ virtual/ghostscript"
+PROVIDE="virtual/lpr"
+
+# upstream includes an interactive test which is a nono for gentoo.
+# therefore, since the printing herd has bigger fish to fry, for now,
+# we just leave it out, even if FEATURES=test
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ enewgroup lp
+ enewuser lp -1 -1 -1 lp
+
+ enewgroup lpadmin 106
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # upstream does not acknowledge bindnow as a solution
+ epatch ${FILESDIR}/cups-1.2.0-bindnow.patch
+
+ # http://www.cups.org/str.php?L1953 - backend code ignores backends after
+ # hitting broken symbolic link
+ epatch ${FILESDIR}/cupsDirRead-dont-end-on-failed-stat.patch
+
+ # cups does not use autotools "the usual way" and ship a static config.h.in
+ eaclocal
+ eautoconf
+}
+
+src_compile() {
+ export DSOFLAGS="${LDFLAGS}"
+ econf \
+ --with-cups-user=lp \
+ --with-cups-group=lp \
+ --with-system-groups=lpadmin \
+ --localstatedir=/var \
+ --with-docdir=/usr/share/cups/html \
+ --with-bindnow=$(bindnow-flags) \
+ $(use_enable pam) \
+ $(use_enable ssl) \
+ --enable-gnutls \
+ $(use_enable slp) \
+ $(use_enable nls) \
+ $(use_enable dbus) \
+ $(use_enable png) \
+ $(use_enable jpeg) \
+ $(use_enable tiff) \
+ $(use_with php) \
+ --enable-libpaper \
+ --enable-threads \
+ --enable-static \
+ --disable-pdftops \
+ || die "econf failed"
+
+ # Install in /usr/libexec always, instead of using /usr/lib/cups, as that
+ # makes more sense when facing multilib support.
+ sed -i -e 's:SERVERBIN.*:SERVERBIN = $(BUILDROOT)/usr/libexec/cups:' Makedefs
+ sed -i -e 's:#define CUPS_SERVERBIN.*:#define CUPS_SERVERBIN "/usr/libexec/cups":' config.h
+ sed -i -e 's:cups_serverbin=.*:cups_serverbin=/usr/libexec/cups:' cups-config
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake BUILDROOT=${D} install || die "emake install failed"
+ dodoc {CHANGES{,-1.{0,1}},CREDITS,LICENSE,README}.txt
+
+ # clean out cups init scripts
+ rm -rf ${D}/etc/{init.d/cups,rc*,pam.d/cups}
+ # install our init scripts
+ newinitd ${FILESDIR}/cupsd.init cupsd
+ # install our pam script
+ pamd_mimic_system cups auth account
+
+ # correct path
+ sed -i -e "s:server = .*:server = /usr/libexec/cups/daemon/cups-lpd:" ${D}/etc/xinetd.d/cups-lpd
+ # it is safer to disable this by default, bug 137130
+ grep -w 'disable' ${D}/etc/xinetd.d/cups-lpd || \
+ sed -i -e "s:}:\tdisable = yes\n}:" ${D}/etc/xinetd.d/cups-lpd
+
+ # install pdftops filter
+ exeinto /usr/libexec/cups/filter/
+ newexe ${FILESDIR}/pdftops.pl pdftops
+
+ keepdir /usr/share/cups/profiles /usr/libexec/cups/driver /var/log/cups \
+ /var/run/cups/certs /var/cache/cups /var/spool/cups/tmp
+
+ # .desktop handling. X useflag. xdg-open from freedesktop is preferred
+ if use X; then
+ sed -i -e "s:htmlview:xdg-open:" ${D}/usr/share/applications/cups.desktop
+ else
+ rm -r ${D}/usr/share/applications
+ fi
+}
+
+pkg_preinst() {
+ # cleanups
+ [ -n "${PN}" ] && rm -fR ${ROOT}/usr/share/doc/${PN}-*
+}
+
+pkg_postinst() {
+ einfo "Remote printing: change "
+ einfo "Listen localhost:631"
+ einfo "to"
+ einfo "Listen *:631"
+ einfo "in /etc/cups/cupsd.conf"
+ einfo
+ einfo "For more information about installing a printer take a look at:"
+ einfo "http://www.gentoo.org/doc/en/printing-howto.xml."
+
+ local good_gs=false
+ for x in app-text/ghostscript-gpl app-text/ghostscript-gnu app-text/ghostscript-esp; do
+ if has_version ${x} && built_with_use ${x} cups; then
+ good_gs=true
+ break
+ fi
+ done;
+ if ! ${good_gs}; then
+ ewarn
+ ewarn "You need to emerge ghostscript with the cups-USEflag turned on"
+ fi
+ if has_version =net-print/cups-1.1*; then
+ ewarn
+ ewarn "The configuration changed with cups-1.2, you may want to save the old"
+ ewarn "one and start from scratch:"
+ ewarn "# mv /etc/cups /etc/cups.orig; emerge -va1 cups"
+ ewarn
+ ewarn "You need to rebuild kdelibs for kdeprinter to work with cups-1.2"
+ fi
+ if [ -e ${ROOT}/usr/lib/cups ]; then
+ ewarn
+ ewarn "/usr/lib/cups exists - You need to remerge every ebuild that"
+ ewarn "installed into /usr/lib/cups and /etc/cups, qfile is in portage-utils:"
+ ewarn "# FEATURES=-collision-protect emerge -va1 \$(qfile -qC /usr/lib/cups /etc/cups | sed \"s:net-print/cups$::\")"
+ ewarn
+ ewarn "FEATURES=-collision-protect is needed to overwrite the compatibility"
+ ewarn "symlinks installed by this package, it wont be needed on later merges."
+ ewarn "You should also run revdep-rebuild"
+
+ # place symlinks to make the update smoothless
+ for i in ${ROOT}/usr/lib/cups/{backend,filter}/*; do
+ if [ "${i/\*}" == "${i}" ] && ! [ -e ${i/lib/libexec} ]; then
+ ln -s ${i} ${i/lib/libexec}
+ fi
+ done
+ fi
+}
diff --git a/net-print/cups/files/cupsDirRead-dont-end-on-failed-stat.patch b/net-print/cups/files/cupsDirRead-dont-end-on-failed-stat.patch
new file mode 100644
index 000000000000..e99bc256a767
--- /dev/null
+++ b/net-print/cups/files/cupsDirRead-dont-end-on-failed-stat.patch
@@ -0,0 +1,41 @@
+--- cups/dir.c 2006/09/03 08:53:52 1.1
++++ cups/dir.c 2006/09/03 08:57:17
+@@ -381,22 +381,24 @@ cupsDirRead(cups_dir_t *dp) /* I - Dire
+ }
+
+ DEBUG_printf((" readdir_r() returned \"%s\"...\n", entry->d_name));
+- }
+- while (!strcmp(entry->d_name, ".") || !strcmp(entry->d_name, ".."));
+
+- /*
+- * Copy the name over and get the file information...
+- */
++ if (!strcmp(entry->d_name, ".") || !strcmp(entry->d_name, ".."))
++ continue;
+
+- strlcpy(dp->entry.filename, entry->d_name, sizeof(dp->entry.filename));
+-
+- snprintf(filename, sizeof(filename), "%s/%s", dp->directory, entry->d_name);
+- if (stat(filename, &(dp->entry.fileinfo)))
+- {
+- DEBUG_printf((" stat() failed for \"%s\" - %s...\n", filename,
+- strerror(errno)));
+- return (NULL);
+- }
++ /*
++ * Copy the name over and get the file information...
++ */
++
++ strlcpy(dp->entry.filename, entry->d_name, sizeof(dp->entry.filename));
++
++ snprintf(filename, sizeof(filename), "%s/%s", dp->directory, entry->d_name);
++ if (stat(filename, &(dp->entry.fileinfo)))
++ {
++ DEBUG_printf((" stat() failed for \"%s\" - %s...\n", filename,
++ strerror(errno)));
++ continue;
++ }
++ } while (0);
+
+ /*
+ * Return the entry...
diff --git a/net-print/cups/files/digest-cups-1.2.3 b/net-print/cups/files/digest-cups-1.2.3
new file mode 100644
index 000000000000..36bff0cd1375
--- /dev/null
+++ b/net-print/cups/files/digest-cups-1.2.3
@@ -0,0 +1,3 @@
+MD5 7f65bae0054cd8335824942595d867ef cups-1.2.3-source.tar.bz2 3544888
+RMD160 1d232ea83c684723c05977733e73ecff2c398f0a cups-1.2.3-source.tar.bz2 3544888
+SHA256 5acc3e9490cda60dc243961698d303eba4f20cd61784fa3ada7fdf8b0770b821 cups-1.2.3-source.tar.bz2 3544888