summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-07-16 14:45:02 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-07-16 14:45:02 +0000
commit9bb7560d5da289ff1c3cea8c3ab2bfd4348306b3 (patch)
tree6b2c3e8e3495bf260a87316d3b86d0d7a45129f6 /net-print/foomatic-db-engine/foomatic-db-engine-3.0.0.ebuild
parentinitial release (diff)
downloadgentoo-2-9bb7560d5da289ff1c3cea8c3ab2bfd4348306b3.tar.gz
gentoo-2-9bb7560d5da289ff1c3cea8c3ab2bfd4348306b3.tar.bz2
gentoo-2-9bb7560d5da289ff1c3cea8c3ab2bfd4348306b3.zip
initial release
Diffstat (limited to 'net-print/foomatic-db-engine/foomatic-db-engine-3.0.0.ebuild')
-rw-r--r--net-print/foomatic-db-engine/foomatic-db-engine-3.0.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-print/foomatic-db-engine/foomatic-db-engine-3.0.0.ebuild b/net-print/foomatic-db-engine/foomatic-db-engine-3.0.0.ebuild
new file mode 100644
index 000000000000..ac2f70779d68
--- /dev/null
+++ b/net-print/foomatic-db-engine/foomatic-db-engine-3.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/foomatic-db-engine/foomatic-db-engine-3.0.0.ebuild,v 1.1 2003/07/16 14:44:17 lanius Exp $
+
+inherit perl-module
+
+DESCRIPTION="Foomatic printer database engine"
+HOMEPAGE="http://www.linuxprinting.org/foomatic"
+SRC_URI="http://www.linuxprinting.org/download/foomatic/foomatic-db-engine-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE=""
+
+DEPEND="dev-libs/libxml2
+ net-misc/wget
+ net-ftp/curl
+ net-print/foomatic-filters"
+
+src_compile() {
+ epatch ${FILESDIR}/perl-module.diff
+ econf
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ # install perl modules
+ cd lib
+ perl-module_src_prep
+ perl-module_src_compile
+ perl-module_src_test
+ perl-module_src_install
+}