summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-15 03:14:08 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-15 03:14:08 +0000
commit8b9165bf63f511a1c1e391dfb88cefd5141701d6 (patch)
tree2d89c01508256f713458464b98c11c9150f24c1b /net-print/hpijs
parentAdd pidfile override to enable net.eth0 changes to support adsl for bug 24975... (diff)
downloadgentoo-2-8b9165bf63f511a1c1e391dfb88cefd5141701d6.tar.gz
gentoo-2-8b9165bf63f511a1c1e391dfb88cefd5141701d6.tar.bz2
gentoo-2-8b9165bf63f511a1c1e391dfb88cefd5141701d6.zip
Fix use invocation, clean up ebuilds
Diffstat (limited to 'net-print/hpijs')
-rw-r--r--net-print/hpijs/ChangeLog6
-rw-r--r--net-print/hpijs/hpijs-1.4.1.ebuild46
-rw-r--r--net-print/hpijs/hpijs-1.5.ebuild32
3 files changed, 41 insertions, 43 deletions
diff --git a/net-print/hpijs/ChangeLog b/net-print/hpijs/ChangeLog
index 866b2c1e996c..fe9f8e118e36 100644
--- a/net-print/hpijs/ChangeLog
+++ b/net-print/hpijs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-print/hpijs
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hpijs/ChangeLog,v 1.24 2004/06/02 02:29:03 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hpijs/ChangeLog,v 1.25 2004/06/15 03:14:08 agriffis Exp $
+
+ 14 Jun 2004; Aron Griffis <agriffis@gentoo.org> hpijs-1.4.1.ebuild,
+ hpijs-1.5.ebuild:
+ Fix use invocation, clean up ebuilds
01 Jun 2004; Travis Tilley <lv@gentoo.org> hpijs-1.5.ebuild:
stable on amd64
diff --git a/net-print/hpijs/hpijs-1.4.1.ebuild b/net-print/hpijs/hpijs-1.4.1.ebuild
index 9b6eac03579b..543e406e75f8 100644
--- a/net-print/hpijs/hpijs-1.4.1.ebuild
+++ b/net-print/hpijs/hpijs-1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hpijs/hpijs-1.4.1.ebuild,v 1.9 2004/04/27 22:04:28 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hpijs/hpijs-1.4.1.ebuild,v 1.10 2004/06/15 03:14:08 agriffis Exp $
inherit gnuconfig eutils
@@ -17,55 +17,53 @@ LICENSE="BSD"
SLOT="0"
IUSE="cups foomaticdb ppds"
-src_compile () {
- use amd64 && gnuconfig_update
-
- use ppds \
- && myconf="--enable-foomatic-install" \
- || myconf="--disable-foomatic-install"
-
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ gnuconfig_update
epatch ${FILESDIR}/hpijs-${PV}-rss.1.patch
+}
- econf --disable-cups-install ${myconf} || die "econf failed"
+src_compile() {
+ econf --disable-cups-install \
+ $(use_enable ppds foomatic-install) || die "econf failed"
- for i in Makefile; do
- mv $i $i.orig ;
- cat $i.orig | \
- sed -e 's|/usr/share/cups|${prefix}/share/cups|g' | sed -e 's|/usr/lib/cups|${prefix}/lib/cups|g' > $i
- done
+ sed -i -e 's|/usr/share/cups|${prefix}/share/cups|g' \
+ -e 's|/usr/lib/cups|${prefix}/lib/cups|g' Makefile \
+ || die "sed failed"
- make || die "compile problem"
+ make || die "make failed"
- if [ `use foomaticdb` ]; then
- cd ../foomatic-db-hpijs-1.4-1
+ if use foomaticdb; then
+ cd ${WORKDIR}/foomatic-db-hpijs-1.4-1
econf || die "econf failed"
rm -fR data-generators/hpijs-rss
make || die
- cd ../${P}
fi
}
src_install () {
einstall || die
- if [ "`use cups`" -a "`use ppds`" ] ; then
+ if use cups && use ppds; then
dodir /usr/share/cups/model
dosym /usr/share/ppd /usr/share/cups/model/foomatic-ppds
fi
use ppds && rm -f ${D}/usr/bin/foomatic-rip
- if [ `use foomaticdb` ]; then
+ if use foomaticdb; then
cd ../foomatic-db-hpijs-1.4-1
make DESTDIR=${D} install || die
fi
}
pkg_postinst () {
- einfo "To use the hpijs driver with the PDQ spooler you will need the PDQ driver file"
- einfo "for your printer from http://www.linuxprinting.org/show_driver.cgi?driver=hpijs"
+ einfo "To use the hpijs driver with the PDQ spooler you will need the PDQ"
+ einfo "driver file for your printer from"
+ einfo "http://www.linuxprinting.org/show_driver.cgi?driver=hpijs"
einfo "This file should be installed in /etc/pdq/drivers"
einfo
- einfo "The hpijs ebuild no longer creates the ppds automatically, please use foomatic"
- einfo "to do so or remerge hpijs with the ppds use flag."
+ einfo "The hpijs ebuild no longer creates the ppds automatically, please use"
+ einfo "foomatic to do so or remerge hpijs with the ppds use flag."
}
diff --git a/net-print/hpijs/hpijs-1.5.ebuild b/net-print/hpijs/hpijs-1.5.ebuild
index 851f3bbe4259..ac0faf4421d2 100644
--- a/net-print/hpijs/hpijs-1.5.ebuild
+++ b/net-print/hpijs/hpijs-1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hpijs/hpijs-1.5.ebuild,v 1.7 2004/06/02 02:29:03 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hpijs/hpijs-1.5.ebuild,v 1.8 2004/06/15 03:14:08 agriffis Exp $
inherit gnuconfig eutils
@@ -23,31 +23,26 @@ DEPEND="virtual/ghostscript
src_unpack() {
unpack ${A}
cd ${S}
- use amd64 && gnuconfig_update
+ gnuconfig_update
epatch ${FILESDIR}/${P}-gcc34.patch
epatch ${FILESDIR}/hpijs-1.4.1-rss.1.patch
}
src_compile () {
- econf \
- --disable-cups-install \
- `use_enable ppds foomatic-install` \
- || die "econf failed"
+ econf --disable-cups-install \
+ $(use_enable ppds foomatic-install) || die "econf failed"
- for i in Makefile; do
- mv $i $i.orig ;
- cat $i.orig | \
- sed -e 's|/usr/share/cups|${prefix}/share/cups|g' | sed -e 's|/usr/lib/cups|${prefix}/lib/cups|g' > $i
- done
+ sed -i -e 's|/usr/share/cups|${prefix}/share/cups|g' \
+ -e 's|/usr/lib/cups|${prefix}/lib/cups|g' Makefile \
+ || die "sed failed"
- make || die "compile problem"
+ make || die "make failed"
if use foomaticdb ; then
- cd ../foomatic-db-hpijs-${DB_V}
+ cd ${WORKDIR}/foomatic-db-hpijs-${DB_V}
econf || die "econf failed"
rm -fR data-generators/hpijs-rss
make || die
- cd ../${P}
fi
}
@@ -68,10 +63,11 @@ src_install() {
}
pkg_postinst() {
- einfo "To use the hpijs driver with the PDQ spooler you will need the PDQ driver file"
- einfo "for your printer from http://www.linuxprinting.org/show_driver.cgi?driver=hpijs"
+ einfo "To use the hpijs driver with the PDQ spooler you will need the PDQ"
+ einfo "driver file for your printer from"
+ einfo "http://www.linuxprinting.org/show_driver.cgi?driver=hpijs"
einfo "This file should be installed in /etc/pdq/drivers"
einfo
- einfo "The hpijs ebuild no longer creates the ppds automatically, please use foomatic"
- einfo "to do so or remerge hpijs with the ppds use flag."
+ einfo "The hpijs ebuild no longer creates the ppds automatically, please use"
+ einfo "foomatic to do so or remerge hpijs with the ppds use flag."
}