summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-01-24 19:50:49 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-01-24 19:50:49 +0000
commit8adaae77a1972db76d03b95f2395b1dcf8699d23 (patch)
treede9523e5af9472fc8cdaff1b508c4dddf3fd3722 /net-print/mtink/mtink-1.0.11.ebuild
parentVersion bump to fix an issue on on IA64. This version changes the default fo... (diff)
downloadgentoo-2-8adaae77a1972db76d03b95f2395b1dcf8699d23.tar.gz
gentoo-2-8adaae77a1972db76d03b95f2395b1dcf8699d23.tar.bz2
gentoo-2-8adaae77a1972db76d03b95f2395b1dcf8699d23.zip
version bump thanks to Jeremy Heslop <jeremy@jheslop.com> in bug 120132
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'net-print/mtink/mtink-1.0.11.ebuild')
-rw-r--r--net-print/mtink/mtink-1.0.11.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/net-print/mtink/mtink-1.0.11.ebuild b/net-print/mtink/mtink-1.0.11.ebuild
new file mode 100644
index 000000000000..68d09c110e95
--- /dev/null
+++ b/net-print/mtink/mtink-1.0.11.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/mtink/mtink-1.0.11.ebuild,v 1.1 2006/01/24 19:50:49 genstef Exp $
+
+inherit eutils
+
+DESCRIPTION="mtink is a status monitor and inkjet cartridge changer for some Epson printers"
+HOMEPAGE="http://xwtools.automatix.de/"
+SRC_URI="http://xwtools.automatix.de/files/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE="cups doc X"
+
+DEPEND="X? (
+ || (
+ ( x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXt )
+ virtual/x11
+ )
+ )
+ cups? ( net-print/cups )
+ dev-libs/libusb"
+
+src_compile() {
+ local mytargets
+ mytargets="ttink detect/askPrinter mtinkd"
+ if use X;
+ then
+ mytargets="${mytargets} mtink mtinkc";
+ fi
+ make ${mytargets} || die "Compile problem"
+}
+
+src_install() {
+ exeinto /usr/bin
+ if use X; then
+ doexe mtinkc mtink ttink detect/askPrinter
+ else
+ doexe ttink detect/askPrinter
+ fi
+ exeinto /usr/sbin
+ doexe mtinkd
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/mtinkd.rc mtinkd
+ insinto /etc/conf.d
+ newins ${FILESDIR}/mtinkd.confd mtinkd
+
+ use cups && \
+ exeinto /usr/lib/cups/backend; \
+ doexe etc/mtink-cups
+
+ dodoc README CHANGE.LOG LICENCE
+ use doc && {
+ dohtml html/*.gif html/*.html
+ }
+}
+
+pkg_postinst() {
+ # see #70310
+ chmod 700 /var/mtink /var/run/mtink 2>/dev/null
+
+ einfo
+ einfo "mtink needs correct permissions to access printer device."
+ einfo "To do this you either need to run the following chmod command:"
+ einfo "chmod 666 /dev/<device>"
+ einfo "or set the suid bit on mtink, mtinkc and ttink in /usr/bin"
+ einfo
+}