summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-22 17:19:20 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-22 17:19:20 +0000
commit1277aca8db8f93ae400abc53eb58eb617fedf2e2 (patch)
tree579b7353133cb7cbbfad9471731376940e436c6d /net-print
parentNow marked stable as patch allows ebuild to compile on both gcc2 and (diff)
downloadgentoo-2-1277aca8db8f93ae400abc53eb58eb617fedf2e2.tar.gz
gentoo-2-1277aca8db8f93ae400abc53eb58eb617fedf2e2.tar.bz2
gentoo-2-1277aca8db8f93ae400abc53eb58eb617fedf2e2.zip
version bump
Diffstat (limited to 'net-print')
-rw-r--r--net-print/gtklp/gtklp-0.9m.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-print/gtklp/gtklp-0.9m.ebuild b/net-print/gtklp/gtklp-0.9m.ebuild
new file mode 100644
index 000000000000..b8bb819408dd
--- /dev/null
+++ b/net-print/gtklp/gtklp-0.9m.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/gtklp/gtklp-0.9m.ebuild,v 1.1 2002/10/22 17:19:20 seemant Exp $
+
+inherit libtool
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A GUI for cupsd"
+SRC_URI="http://www.stud.uni-hannover.de/~sirtobi/gtklp/files/${P}.src.tar.gz"
+HOMEPAGE="http://www.stud.uni-hannover.de/~sirtobi/gtklp"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+LICENSE="GPL-2"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=net-print/cups-1.1.7"
+
+RDEPEND="sys-devel/gettext"
+
+src_compile() {
+ elibtoolize
+
+ local myconf
+
+ # Upstream informs me that there are issues with disabling NLS, because
+ # of gettext versions.
+# use nls \
+# && myconf="${myconf} --enable-nls" \
+# || myconf="${myconf} --disable-nls"
+
+ use ssl \
+ && myconf="${myconf} --enable-ssl" \
+ || myconf="${myconf} --disable-ssl"
+
+ econf ${myconf}
+ make -f Makefile.fallback || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog README NEWS TODO KNOWN_BUGS
+}