summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-05-09 21:11:53 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-05-09 21:11:53 +0000
commitddafcad4b72bb44e1fd2414572f68df7c41d70eb (patch)
treea32fb455b574f26ef5ed6a860f439560490a4123 /net-print
parentrev bump (diff)
downloadgentoo-2-ddafcad4b72bb44e1fd2414572f68df7c41d70eb.tar.gz
gentoo-2-ddafcad4b72bb44e1fd2414572f68df7c41d70eb.tar.bz2
gentoo-2-ddafcad4b72bb44e1fd2414572f68df7c41d70eb.zip
version bump and add lib64 check thanks to Sal Gonzalez <blef@codejunkie.net> in bug 173789
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/cups/ChangeLog8
-rw-r--r--net-print/cups/cups-1.2.11.ebuild219
-rw-r--r--net-print/cups/files/digest-cups-1.2.113
3 files changed, 229 insertions, 1 deletions
diff --git a/net-print/cups/ChangeLog b/net-print/cups/ChangeLog
index b98ea34b475e..5a46fdd3d422 100644
--- a/net-print/cups/ChangeLog
+++ b/net-print/cups/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-print/cups
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.234 2007/05/01 12:20:07 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.235 2007/05/09 21:11:53 genstef Exp $
+
+*cups-1.2.11 (09 May 2007)
+
+ 09 May 2007; Stefan Schweizer <genstef@gentoo.org> +cups-1.2.11.ebuild:
+ version bump and add lib64 check thanks to Sal Gonzalez
+ <blef@codejunkie.net> in bug 173789
*cups-1.2.10-r1 (01 May 2007)
diff --git a/net-print/cups/cups-1.2.11.ebuild b/net-print/cups/cups-1.2.11.ebuild
new file mode 100644
index 000000000000..43cb6ec9a326
--- /dev/null
+++ b/net-print/cups/cups-1.2.11.ebuild
@@ -0,0 +1,219 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.2.11.ebuild,v 1.1 2007/05/09 21:11:53 genstef Exp $
+
+WANT_AUTOMAKE=latest
+
+inherit autotools eutils flag-o-matic multilib pam
+
+MY_P=${P/_}
+
+DESCRIPTION="The Common Unix Printing System"
+HOMEPAGE="http://www.cups.org/"
+SRC_URI="http://ftp.funet.fi/pub/mirrors/ftp.easysw.com/pub/cups/${PV}/${MY_P}-source.tar.bz2"
+#ESVN_REPO_URI="http://svn.easysw.com/public/cups/trunk"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ldap ssl slp pam php samba nls dbus tiff png ppds jpeg X"
+
+DEP="pam? ( virtual/pam )
+ ssl? ( net-libs/gnutls )
+ slp? ( >=net-libs/openslp-1.0.4 )
+ ldap? ( net-nds/openldap )
+ dbus? ( sys-apps/dbus )
+ png? ( >=media-libs/libpng-1.2.1 )
+ tiff? ( >=media-libs/tiff-3.5.5 )
+ jpeg? ( >=media-libs/jpeg-6b )
+ php? ( dev-lang/php )
+ app-text/libpaper"
+DEPEND="${DEP}
+ !<net-print/foomatic-filters-ppds-20070501
+ !<net-print/hplip-1.7.4a-r1
+ nls? ( sys-devel/gettext )"
+RDEPEND="${DEP}
+ nls? ( virtual/libintl )
+ !virtual/lpr
+ >=app-text/poppler-0.4.3-r1
+ X? ( x11-misc/xdg-utils )"
+
+PDEPEND="
+ ppds? ( || (
+ (
+ net-print/foomatic-filters-ppds
+ net-print/foomatic-db-ppds
+ )
+ net-print/foomatic-filters-ppds
+ net-print/foomatic-db-ppds
+ net-print/hplip
+ media-gfx/gimp-print
+ net-print/foo2zjs
+ net-print/cups-pdf
+ ) )
+ samba? ( >=net-fs/samba-3.0.8 )
+ virtual/ghostscript"
+PROVIDE="virtual/lpr"
+
+# upstream includes an interactive test which is a nono for gentoo.
+# therefore, since the printing herd has bigger fish to fry, for now,
+# we just leave it out, even if FEATURES=test
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if [ ${ARCH} -eq "x86" -a -d "/usr/lib64" ]
+ then
+ eerror "You are running an x86 system, but /usr/lib64 exists, cups will install all library objects into this directory!"
+ eerror "You should remove /usr/lib64, but before you do, you should check for existing objects, and re-compile all effected packages."
+ eerror "You can use qfile (emerge portage-utils to install qfile) to get a list of the effected ebuilds:"
+ eerror "# qfile -qC /usr/lib64"
+ fi
+
+ enewgroup lp
+ enewuser lp -1 -1 -1 lp
+
+ enewgroup lpadmin 106
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # upstream does not acknowledge bindnow as a solution
+ epatch ${FILESDIR}/cups-1.2.0-bindnow.patch
+
+ # cups does not use autotools "the usual way" and ship a static config.h.in
+ eaclocal
+ eautoconf
+}
+
+src_compile() {
+ export DSOFLAGS="${LDFLAGS}"
+ econf \
+ --with-cups-user=lp \
+ --with-cups-group=lp \
+ --with-system-groups=lpadmin \
+ --localstatedir=/var \
+ --with-docdir=/usr/share/cups/html \
+ --with-bindnow=$(bindnow-flags) \
+ $(use_enable pam) \
+ $(use_enable ssl) \
+ --enable-gnutls \
+ $(use_enable slp) \
+ $(use_enable nls) \
+ $(use_enable dbus) \
+ $(use_enable png) \
+ $(use_enable jpeg) \
+ $(use_enable tiff) \
+ $(use_with php) \
+ $(use_enable ldap) \
+ --enable-libpaper \
+ --enable-threads \
+ --enable-static \
+ --disable-pdftops \
+ || die "econf failed"
+
+ # Install in /usr/libexec always, instead of using /usr/lib/cups, as that
+ # makes more sense when facing multilib support.
+ sed -i -e 's:SERVERBIN.*:SERVERBIN = $(BUILDROOT)/usr/libexec/cups:' Makedefs
+ sed -i -e 's:#define CUPS_SERVERBIN.*:#define CUPS_SERVERBIN "/usr/libexec/cups":' config.h
+ sed -i -e 's:cups_serverbin=.*:cups_serverbin=/usr/libexec/cups:' cups-config
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake BUILDROOT=${D} install || die "emake install failed"
+ dodoc {CHANGES{,-1.{0,1}},CREDITS,LICENSE,README}.txt
+
+ # clean out cups init scripts
+ rm -rf ${D}/etc/{init.d/cups,rc*,pam.d/cups}
+ # install our init scripts
+ newinitd ${FILESDIR}/cupsd.init cupsd
+ # install our pam script
+ pamd_mimic_system cups auth account
+
+ # correct path
+ sed -i -e "s:server = .*:server = /usr/libexec/cups/daemon/cups-lpd:" ${D}/etc/xinetd.d/cups-lpd
+ # it is safer to disable this by default, bug 137130
+ grep -w 'disable' ${D}/etc/xinetd.d/cups-lpd || \
+ sed -i -e "s:}:\tdisable = yes\n}:" ${D}/etc/xinetd.d/cups-lpd
+
+ # install pdftops filter
+ exeinto /usr/libexec/cups/filter/
+ newexe ${FILESDIR}/pdftops.pl pdftops
+
+ # only for gs-esp this is correct, see bug 163897
+ if has_version app-text/ghostscript-gpl || has_version app-text/ghostscript-gnu; then
+ sed -i -e "s:#application/vnd.cups-postscript:application/vnd.cups-postscript:" ${D}/etc/cups/mime.convs
+ fi
+
+ keepdir /usr/share/cups/profiles /usr/libexec/cups/driver /var/log/cups \
+ /var/run/cups/certs /var/cache/cups /var/spool/cups/tmp /etc/cups/ssl
+
+ # .desktop handling. X useflag. xdg-open from freedesktop is preferred
+ if use X; then
+ sed -i -e "s:htmlview:xdg-open:" ${D}/usr/share/applications/cups.desktop
+ else
+ rm -r ${D}/usr/share/applications
+ fi
+
+ # Fix a symlink collision, see bug #172341
+ dodir /usr/share/ppd
+ dosym /usr/share/ppd /usr/share/cups/model/foomatic-ppds
+}
+
+pkg_preinst() {
+ # cleanups
+ [ -n "${PN}" ] && rm -fR ${ROOT}/usr/share/doc/${PN}-*
+}
+
+pkg_postinst() {
+ einfo "Remote printing: change "
+ einfo "Listen localhost:631"
+ einfo "to"
+ einfo "Listen *:631"
+ einfo "in /etc/cups/cupsd.conf"
+ einfo
+ einfo "For more information about installing a printer take a look at:"
+ einfo "http://www.gentoo.org/doc/en/printing-howto.xml."
+
+ local good_gs=false
+ for x in app-text/ghostscript-gpl app-text/ghostscript-gnu app-text/ghostscript-esp; do
+ if has_version ${x} && built_with_use ${x} cups; then
+ good_gs=true
+ break
+ fi
+ done;
+ if ! ${good_gs}; then
+ ewarn
+ ewarn "You need to emerge ghostscript with the \"cups\" USE flag turned on"
+ fi
+ if has_version =net-print/cups-1.1*; then
+ ewarn
+ ewarn "The configuration changed with cups-1.2, you may want to save the old"
+ ewarn "one and start from scratch:"
+ ewarn "# mv /etc/cups /etc/cups.orig; emerge -va1 cups"
+ ewarn
+ ewarn "You need to rebuild kdelibs for kdeprinter to work with cups-1.2"
+ fi
+ if [ -e ${ROOT}/usr/lib/cups ]; then
+ ewarn
+ ewarn "/usr/lib/cups exists - You need to remerge every ebuild that"
+ ewarn "installed into /usr/lib/cups and /etc/cups, qfile is in portage-utils:"
+ ewarn "# FEATURES=-collision-protect emerge -va1 \$(qfile -qC /usr/lib/cups /etc/cups | sed \"s:net-print/cups$::\")"
+ ewarn
+ ewarn "FEATURES=-collision-protect is needed to overwrite the compatibility"
+ ewarn "symlinks installed by this package, it wont be needed on later merges."
+ ewarn "You should also run revdep-rebuild"
+
+ # place symlinks to make the update smoothless
+ for i in ${ROOT}/usr/lib/cups/{backend,filter}/*; do
+ if [ "${i/\*}" == "${i}" ] && ! [ -e ${i/lib/libexec} ]; then
+ ln -s ${i} ${i/lib/libexec}
+ fi
+ done
+ fi
+}
diff --git a/net-print/cups/files/digest-cups-1.2.11 b/net-print/cups/files/digest-cups-1.2.11
new file mode 100644
index 000000000000..9c704ef936d6
--- /dev/null
+++ b/net-print/cups/files/digest-cups-1.2.11
@@ -0,0 +1,3 @@
+MD5 2742f1eec38abb04472b86627da8e493 cups-1.2.11-source.tar.bz2 3774113
+RMD160 c5471c205a6ebb7ba0c2067b89769282e1a044a1 cups-1.2.11-source.tar.bz2 3774113
+SHA256 c313e34a79af84e92609428d31ab292c04a4db69596ad9b264dd0ea719e2ecb0 cups-1.2.11-source.tar.bz2 3774113