summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-05-30 02:26:09 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-05-30 02:26:09 +0000
commitec642eaa8f900998025797c01da8ac5c31279c29 (patch)
treea140b2879f50cd8a379a11f437e51455a29b9959 /net-print
parentNon-maintainer commit. Revbump to fix bug #464246. Move to autotools-utils, E... (diff)
downloadgentoo-2-ec642eaa8f900998025797c01da8ac5c31279c29.tar.gz
gentoo-2-ec642eaa8f900998025797c01da8ac5c31279c29.tar.bz2
gentoo-2-ec642eaa8f900998025797c01da8ac5c31279c29.zip
Version bump. Fixes bug #511062.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'net-print')
-rw-r--r--net-print/gutenprint/ChangeLog8
-rw-r--r--net-print/gutenprint/files/gutenprint-5.2.10-genppd.patch23
-rw-r--r--net-print/gutenprint/gutenprint-5.2.10.ebuild96
3 files changed, 126 insertions, 1 deletions
diff --git a/net-print/gutenprint/ChangeLog b/net-print/gutenprint/ChangeLog
index 6fa289237204..38aeb1383f04 100644
--- a/net-print/gutenprint/ChangeLog
+++ b/net-print/gutenprint/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-print/gutenprint
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/gutenprint/ChangeLog,v 1.50 2014/03/10 17:09:34 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/gutenprint/ChangeLog,v 1.51 2014/05/30 02:26:09 mrueg Exp $
+
+*gutenprint-5.2.10 (30 May 2014)
+
+ 30 May 2014; Manuel Rüger <mrueg@gentoo.org>
+ +files/gutenprint-5.2.10-genppd.patch, +gutenprint-5.2.10.ebuild:
+ Version bump. Fixes bug #511062.
10 Mar 2014; Manuel Rüger <mrueg@gentoo.org>
-files/gutenprint-5.2.7-genppd.patch, -files/gutenprint-5.2.7-stdio.patch,
diff --git a/net-print/gutenprint/files/gutenprint-5.2.10-genppd.patch b/net-print/gutenprint/files/gutenprint-5.2.10-genppd.patch
new file mode 100644
index 000000000000..46d8d78b9ead
--- /dev/null
+++ b/net-print/gutenprint/files/gutenprint-5.2.10-genppd.patch
@@ -0,0 +1,23 @@
+diff -urN gutenprint-5.2.8.old/src/cups/Makefile.am gutenprint-5.2.8/src/cups/Makefile.am
+--- gutenprint-5.2.8.old/src/cups/Makefile.am 2012-06-14 14:03:53.011828220 +0200
++++ gutenprint-5.2.8/src/cups/Makefile.am 2012-06-14 14:04:57.672829331 +0200
+@@ -98,16 +98,16 @@
+
+ cups_genppd_@GUTENPRINT_RELEASE_VERSION@_SOURCES = genppd.c i18n.c i18n.h
+ cups_genppd_@GUTENPRINT_RELEASE_VERSION@_CFLAGS = -DALL_LINGUAS='"$(ALL_LINGUAS)"' $(BUILD_SIMPLE_PPDS) $(TRANSLATE_PPDS)
+-cups_genppd_@GUTENPRINT_RELEASE_VERSION@_LDADD = $(CUPS_LIBS) $(GENPPD_LIBS) $(GUTENPRINT_LIBS) @LIBICONV@
++cups_genppd_@GUTENPRINT_RELEASE_VERSION@_LDADD = $(GUTENPRINT_LIBS) $(CUPS_LIBS) $(GENPPD_LIBS) @LIBICONV@
+ cups_genppd_@GUTENPRINT_RELEASE_VERSION@_LDFLAGS = $(STATIC_LDOPTS)
+
+ gutenprint_@GUTENPRINT_RELEASE_VERSION@_SOURCES = genppd.c i18n.c i18n.h
+ gutenprint_@GUTENPRINT_RELEASE_VERSION@_CFLAGS = -DCUPS_DRIVER_INTERFACE -DALL_LINGUAS='"$(ALL_LINGUAS)"' $(BUILD_SIMPLE_PPDS) $(TRANSLATE_PPDS)
+-gutenprint_@GUTENPRINT_RELEASE_VERSION@_LDADD = $(CUPS_LIBS) $(GUTENPRINT_LIBS) @LIBICONV@
++gutenprint_@GUTENPRINT_RELEASE_VERSION@_LDADD = $(GUTENPRINT_LIBS) $(CUPS_LIBS) @LIBICONV@
+ gutenprint_@GUTENPRINT_RELEASE_VERSION@_LDFLAGS = $(STATIC_LDOPTS)
+
+ rastertogutenprint_@GUTENPRINT_RELEASE_VERSION@_SOURCES = rastertoprinter.c i18n.c i18n.h
+-rastertogutenprint_@GUTENPRINT_RELEASE_VERSION@_LDADD = $(CUPS_LIBS) $(GUTENPRINT_LIBS) @LIBICONV@
++rastertogutenprint_@GUTENPRINT_RELEASE_VERSION@_LDADD = $(GUTENPRINT_LIBS) $(CUPS_LIBS) @LIBICONV@
+ rastertogutenprint_@GUTENPRINT_RELEASE_VERSION@_LDFLAGS = $(STATIC_LDOPTS)
+
+ ## Data
diff --git a/net-print/gutenprint/gutenprint-5.2.10.ebuild b/net-print/gutenprint/gutenprint-5.2.10.ebuild
new file mode 100644
index 000000000000..76f9a2e8b3c4
--- /dev/null
+++ b/net-print/gutenprint/gutenprint-5.2.10.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/gutenprint/gutenprint-5.2.10.ebuild,v 1.1 2014/05/30 02:26:09 mrueg Exp $
+
+EAPI=5
+
+inherit eutils multilib autotools
+
+DESCRIPTION="Ghostscript and cups printer drivers"
+HOMEPAGE="http://gutenprint.sourceforge.net"
+SRC_URI="mirror://sourceforge/gimp-print/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cups foomaticdb gimp gtk nls readline ppds static-libs"
+
+RDEPEND="app-text/ghostscript-gpl
+ dev-lang/perl
+ readline? ( sys-libs/readline )
+ cups? ( >=net-print/cups-1.1.14 )
+ foomaticdb? ( net-print/foomatic-db-engine )
+ gimp? ( >=media-gfx/gimp-2.2 x11-libs/gtk+:2 )
+ gtk? ( x11-libs/gtk+:2 )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ gtk? ( virtual/pkgconfig )
+ nls? ( sys-devel/gettext )"
+
+RESTRICT="test"
+
+REQUIRED_USE="gimp? ( gtk )"
+
+DOCS=( AUTHORS ChangeLog NEWS README doc/gutenprint-users-manual.{pdf,odt} )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-5.2.4-CFLAGS.patch\
+ "${FILESDIR}"/${PN}-5.2.10-genppd.patch # bug 382927
+ sed -i "s:m4local:m4extra:" Makefile.am || die
+
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" \
+ -e "s/AM_PROG_CC_STDC/AC_PROG_CC/" \
+ -i configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=""
+
+ if use cups && use ppds; then
+ myconf+=" --enable-cups-ppds --enable-cups-level3-ppds"
+ else
+ myconf+=" --disable-cups-ppds"
+ fi
+
+ use foomaticdb \
+ && myconf+=" --with-foomatic3" \
+ || myconf+=" --without-foomatic"
+
+ econf \
+ --enable-test \
+ --with-ghostscript \
+ --disable-translated-cups-ppds \
+ $(use_enable gtk libgutenprintui2) \
+ $(use_with gimp gimp2) \
+ $(use_with gimp gimp2-as-gutenprint) \
+ $(use_with cups) \
+ $(use_enable nls) \
+ $(use_with readline) \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_install() {
+ default
+
+ dohtml doc/FAQ.html
+ dohtml -r doc/gutenprintui2/html
+ rm -fR "${ED}"/usr/share/gutenprint/doc
+ if ! use gtk; then
+ rm -f "${ED}"/usr/$(get_libdir)/pkgconfig/gutenprintui2.pc
+ rm -rf "${ED}"/usr/include/gutenprintui2
+ fi
+
+ find "${ED}" -name '*.la' -exec rm -f '{}' +
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" == "/" ] && [ -x /usr/sbin/cups-genppdupdate ]; then
+ elog "Updating installed printer ppd files"
+ elog $(/usr/sbin/cups-genppdupdate)
+ else
+ elog "You need to update installed ppds manually using cups-genppdupdate"
+ fi
+}