summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2009-02-05 13:04:09 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2009-02-05 13:04:09 +0000
commit97ed13c20ecd96774f71856e2afec927b7289401 (patch)
tree45a4dfbcf4976e8f009dde55ff7b293fa64cc7f5 /net-proxy/ratproxy
parentVersion bump (diff)
downloadgentoo-2-97ed13c20ecd96774f71856e2afec927b7289401.tar.gz
gentoo-2-97ed13c20ecd96774f71856e2afec927b7289401.tar.bz2
gentoo-2-97ed13c20ecd96774f71856e2afec927b7289401.zip
Version bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy/ratproxy')
-rw-r--r--net-proxy/ratproxy/ChangeLog9
-rw-r--r--net-proxy/ratproxy/ratproxy-1.53.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/net-proxy/ratproxy/ChangeLog b/net-proxy/ratproxy/ChangeLog
index 07444c20cf08..d04ee523f0c8 100644
--- a/net-proxy/ratproxy/ChangeLog
+++ b/net-proxy/ratproxy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-proxy/ratproxy
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/ratproxy/ChangeLog,v 1.2 2008/08/01 19:02:35 drizzt Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/ratproxy/ChangeLog,v 1.3 2009/02/05 13:04:09 drizzt Exp $
+
+*ratproxy-1.53 (05 Feb 2009)
+
+ 05 Feb 2009; Timothy Redaelli <drizzt@gentoo.org> +ratproxy-1.53.ebuild:
+ Version bump
*ratproxy-1.51-r1 (01 Aug 2008)
diff --git a/net-proxy/ratproxy/ratproxy-1.53.ebuild b/net-proxy/ratproxy/ratproxy-1.53.ebuild
new file mode 100644
index 000000000000..aced8d14f16a
--- /dev/null
+++ b/net-proxy/ratproxy/ratproxy-1.53.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/ratproxy/ratproxy-1.53.ebuild,v 1.1 2009/02/05 13:04:09 drizzt Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A semi-automated, largely passive web application security audit tool."
+HOMEPAGE="http://code.google.com/p/ratproxy/"
+SRC_URI="http://ratproxy.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s:keyfile\.pem:/usr/share/${PN}/&:" ssl.c
+ sed -r -i -e "s:(ratproxy-back\.png|messages\.list):/usr/share/${PN}/&:" ratproxy-report.sh
+ epatch "${FILESDIR}"/${PN}-Makefile.patch
+}
+
+src_compile() {
+ tc-export CC
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin ${PN}-report.sh || die "install failed"
+ dobin ${PN} || die "install failed"
+ dodoc doc/{README,TODO}
+ insinto /usr/share/${PN}
+ doins keyfile.pem ratproxy-back.png messages.list
+}