summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-02-16 10:38:36 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-02-16 10:38:36 +0000
commit47c05da36e9fa1d9dbda26916da5e26d090b9f97 (patch)
treef3e81785251c70003ef74cd43b74410eafcf19c6 /net-proxy
parentStable on amd64 wrt bug #355001 (diff)
downloadgentoo-2-47c05da36e9fa1d9dbda26916da5e26d090b9f97.tar.gz
gentoo-2-47c05da36e9fa1d9dbda26916da5e26d090b9f97.tar.bz2
gentoo-2-47c05da36e9fa1d9dbda26916da5e26d090b9f97.zip
Version bump.
(Portage version: 2.2.0_alpha23/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/ufdbguard/ChangeLog8
-rw-r--r--net-proxy/ufdbguard/files/ufdbguard-1.24-gentoo.patch13
-rw-r--r--net-proxy/ufdbguard/ufdbguard-1.24.ebuild130
3 files changed, 150 insertions, 1 deletions
diff --git a/net-proxy/ufdbguard/ChangeLog b/net-proxy/ufdbguard/ChangeLog
index 6ac7cce691f4..a769ff1789b7 100644
--- a/net-proxy/ufdbguard/ChangeLog
+++ b/net-proxy/ufdbguard/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/ufdbguard
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/ufdbguard/ChangeLog,v 1.11 2011/01/31 05:37:32 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/ufdbguard/ChangeLog,v 1.12 2011/02/16 10:38:36 flameeyes Exp $
+
+*ufdbguard-1.24 (16 Feb 2011)
+
+ 16 Feb 2011; Diego E. Pettenò <flameeyes@gentoo.org> +ufdbguard-1.24.ebuild,
+ +files/ufdbguard-1.24-gentoo.patch:
+ Version bump.
*ufdbguard-1.23-r1 (31 Jan 2011)
diff --git a/net-proxy/ufdbguard/files/ufdbguard-1.24-gentoo.patch b/net-proxy/ufdbguard/files/ufdbguard-1.24-gentoo.patch
new file mode 100644
index 000000000000..63da98175a0e
--- /dev/null
+++ b/net-proxy/ufdbguard/files/ufdbguard-1.24-gentoo.patch
@@ -0,0 +1,13 @@
+Index: ufdbGuard-1.24/src/ufdbUpdate.in
+===================================================================
+--- ufdbGuard-1.24.orig/src/ufdbUpdate.in
++++ ufdbGuard-1.24/src/ufdbUpdate.in
+@@ -39,6 +39,8 @@ WGET_COMMAND="@WGET@"
+ NOTIFY_UFDBGUARDD="yes" # send HUP signal to ufdbguardd
+ SYSLOG_FACILITY="local6" # errors/warnings in system log have this facility name
+
++source /etc/conf.d/ufdb
++
+ # end of user settings.
+ # DO NOT EDIT ANYTHING BELOW THIS LINE. ########################################
+
diff --git a/net-proxy/ufdbguard/ufdbguard-1.24.ebuild b/net-proxy/ufdbguard/ufdbguard-1.24.ebuild
new file mode 100644
index 000000000000..97912d9b1509
--- /dev/null
+++ b/net-proxy/ufdbguard/ufdbguard-1.24.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/ufdbguard/ufdbguard-1.24.ebuild,v 1.1 2011/02/16 10:38:36 flameeyes Exp $
+
+EAPI="2"
+
+inherit eutils
+
+MY_P="ufdbGuard-${PV}"
+
+DESCRIPTION="ufdbGuard is a redirector for the Squid internet proxy."
+HOMEPAGE="http://www.urlfilterdb.com/en/products/ufdbguard.html"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz
+ doc? ( mirror://sourceforge/${PN}/ReferenceManual_v${PV/\./_}.pdf -> ${P}-manual.pdf )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+httpd doc"
+
+RDEPEND="dev-libs/openssl
+ app-arch/bzip2
+ net-misc/wget"
+
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ # create the squid user exactly as done by net-proxy/squid-3.1.9
+ enewgroup squid 31
+ enewuser squid 31 -1 /var/cache/squid squid
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.23-parallel-make.patch
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+
+ egrep -r -e '/var/tmp/ufdb(guard|http)d.pid' "${S}" -lZ | xargs -0 \
+ sed -i -e 's:/var/tmp/ufdb\(guard\|http\)d.pid:/var/run/ufdbguard/ufdb\1d.pid:' \
+ || die
+
+ # directory where ufdbhttpd is to be found
+ sed -i -e 's:DEFAULT_BINDIR.*:DEFAULT_BINDIR "/usr/libexec/ufdbguard":' \
+ src/ufdb.h.in || die
+}
+
+src_configure() {
+ econf \
+ --with-ufdb-user=squid \
+ --with-ufdb-config=/etc \
+ --with-ufdb-logdir=/var/log/ufdbguard \
+ --with-ufdb-dbhome=/usr/share/ufdbguard/blacklists \
+ --with-ufdb-images_dir=/usr/share/ufdbguard/images
+}
+
+src_install() {
+ dodoc CHANGELOG INSTALL README src/sampleufdbGuard.conf || die
+ doman doc/*.1 || die
+
+ dobin src/ufdbAnalyse src/ufdbGenTable src/ufdbGrab \
+ src/ufdbConvertDB || die
+ dosbin src/ufdbUpdate || die
+
+ exeinto /usr/libexec/ufdbguard
+ doexe src/mtserver/ufdbguardd src/mtserver/ufdbgclient || die
+
+ if use httpd; then
+ exeinto /usr/libexec/ufdbguard
+ doexe src/ufdbhttpd || die
+ fi
+
+ keepdir /usr/share/ufdbguard/blacklists
+
+ insinto /etc
+ doins src/ufdbGuard.conf || die
+
+ insinto /usr/share/ufdbguard/images
+ doins src/images/* || die
+
+ newconfd "${FILESDIR}"/ufdb.confd ufdb || die
+ newinitd "${FILESDIR}"/ufdb.initd ufdb || die
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/ufdbUpdate.cron ufdbUpdate || die
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ newins "${DISTDIR}"/${P}-manual.pdf ReferenceManual.pdf || die
+ fi
+}
+
+pkg_postinst() {
+ elog "The default location for the blacklist database has been"
+ elog "moved to /usr/share/ufdbguard/blacklists."
+ elog ""
+ elog "The configuration file is no longer configurable in the"
+ elog "service file, and now resides at /etc/ufdbGuard.conf ."
+ elog ""
+ elog "The service script has been renamed from ufdbguad to simply"
+ elog "/etc/init.d/ufdb, to follow the official documentation, and"
+ elog "it gained a reload option with a reconfig alias."
+ elog ""
+ elog "You can configure the username and password parameters for"
+ elog "ufdbUpdate, to fetch the blacklist database provided by"
+ elog "URLfilterDB, directly in /etc/conf.d/ufdb without touching"
+ elog "the script itself."
+ elog ""
+ elog "To enable ufdbguard in squid, you should add this to your"
+ elog "squid.conf:"
+ elog ""
+ elog " url_rewrite_program /usr/libexec/ufdbguard/ufdbgclient -l /var/log/ufdbguard"
+ elog " url_rewrite_children 64"
+ elog ""
+ if ! use httpd; then
+ elog "You chose to not install the lightweight http daemon that"
+ elog "comes with ufdbguard."
+ else
+ elog "The ufdb service will start both the ufdbguardd daemon and"
+ elog "the ufdbhttpd http daemon to provide a local redirect CGI."
+ elog "If you don't want this to happen, disable the httpd USE flag."
+ fi
+ if use doc; then
+ elog ""
+ elog "The reference manual has been installed as"
+ elog " /usr/share/doc/${PF}/ReferenceManual.pdf"
+ fi
+}