summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2007-07-10 18:25:50 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2007-07-10 18:25:50 +0000
commit7f171b421f9139b87d339535ffe82d41e4e49f1f (patch)
tree723f344095ce16c00e5ff7dde115f962739acf57 /net-proxy
parentwhitespace (diff)
downloadgentoo-2-7f171b421f9139b87d339535ffe82d41e4e49f1f.tar.gz
gentoo-2-7f171b421f9139b87d339535ffe82d41e4e49f1f.tar.bz2
gentoo-2-7f171b421f9139b87d339535ffe82d41e4e49f1f.zip
Patch http-replicator to ignore SIGHUP as a work-around for bug #177428.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/http-replicator/ChangeLog10
-rw-r--r--net-proxy/http-replicator/files/http-replicator-3.0-sighup.patch20
-rwxr-xr-xnet-proxy/http-replicator/files/http-replicator-3.0.init7
-rw-r--r--net-proxy/http-replicator/http-replicator-3.0.ebuild5
4 files changed, 36 insertions, 6 deletions
diff --git a/net-proxy/http-replicator/ChangeLog b/net-proxy/http-replicator/ChangeLog
index 7abc8d3b1a11..a21b7450c026 100644
--- a/net-proxy/http-replicator/ChangeLog
+++ b/net-proxy/http-replicator/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-proxy/http-replicator
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/http-replicator/ChangeLog,v 1.14 2007/04/22 00:24:03 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/http-replicator/ChangeLog,v 1.15 2007/07/10 18:25:50 griffon26 Exp $
+
+ 10 Jul 2007; Maurice van der Pot <griffon26@gentoo.org>
+ +files/http-replicator-3.0-sighup.patch, files/http-replicator-3.0.init,
+ http-replicator-3.0.ebuild:
+ Slight changes to init script as well as a patch to ignore SIGHUP to prevent
+ the daemon from exiting right away when http-replicator is started at boot
+ time. This is a work-around for bug #177428 until the next version of
+ http-replicator, which is a rewrite, is released.
22 Apr 2007; Alin Năstac <mrness@gentoo.org> http-replicator-3.0.ebuild:
Use newinitd and newconfd (#174266).
diff --git a/net-proxy/http-replicator/files/http-replicator-3.0-sighup.patch b/net-proxy/http-replicator/files/http-replicator-3.0-sighup.patch
new file mode 100644
index 000000000000..11ccca7d70e3
--- /dev/null
+++ b/net-proxy/http-replicator/files/http-replicator-3.0-sighup.patch
@@ -0,0 +1,20 @@
+--- /usr/bin/http-replicator 2007-07-09 20:09:44.000000000 +0200
++++ http-replicator 2007-07-09 20:11:48.433913445 +0200
+@@ -5,7 +5,7 @@
+ # Because of this the server runs as a single process, multiplexing I/O with its various client and server connections within a single process/thread.
+ # According to the readme <http://www.nightmare.com/medusa/README.html> this means it is capable of smoother and higher performance than most other servers, while placing a dramatically reduced load on the server machine.
+
+-import asyncore, socket, os, time, calendar, sys, re, optparse, logging
++import asyncore, socket, os, time, calendar, sys, re, optparse, logging, signal
+
+ # LISTENER
+ #
+@@ -636,6 +636,8 @@
+ pidfile.write(str(pid)) # store child's pid
+ pidfile.close()
+ return
++ else:
++ signal.signal(signal.SIGHUP, signal.SIG_IGN)
+ else:
+ handler = logging.StreamHandler(sys.stdout) # log to stdout
+ handler.setFormatter(logging.Formatter('%(levelname)s: %(name)s %(message)s'))
diff --git a/net-proxy/http-replicator/files/http-replicator-3.0.init b/net-proxy/http-replicator/files/http-replicator-3.0.init
index c2a7a33215ca..b9b3718f6305 100755
--- a/net-proxy/http-replicator/files/http-replicator-3.0.init
+++ b/net-proxy/http-replicator/files/http-replicator-3.0.init
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/http-replicator/files/http-replicator-3.0.init,v 1.1 2005/06/02 06:33:24 griffon26 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/http-replicator/files/http-replicator-3.0.init,v 1.2 2007/07/10 18:25:50 griffon26 Exp $
depend() {
need net
@@ -10,13 +10,12 @@ depend() {
start() {
ebegin "Starting Http-Replicator"
start-stop-daemon --start --pidfile /var/run/http-replicator.pid --name http-replicator \
- --startas /usr/bin/http-replicator -- -s -f --pid /var/run/http-replicator.pid --daemon $DAEMON_OPTS
+ --exec /usr/bin/http-replicator -- -s -f --pid /var/run/http-replicator.pid --daemon $DAEMON_OPTS
eend $? "Failed to start Http-Replicator"
}
stop() {
ebegin "Stopping Http-Replicator"
- start-stop-daemon --stop --pidfile /var/run/http-replicator.pid --name http-replicator \
- --signal 2 --oknodo
+ start-stop-daemon --stop --pidfile /var/run/http-replicator.pid --name http-replicator --signal 2
eend $? "Failed to stop Http-Replicator"
}
diff --git a/net-proxy/http-replicator/http-replicator-3.0.ebuild b/net-proxy/http-replicator/http-replicator-3.0.ebuild
index 5d473d06806c..15cc2b95b71b 100644
--- a/net-proxy/http-replicator/http-replicator-3.0.ebuild
+++ b/net-proxy/http-replicator/http-replicator-3.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/http-replicator/http-replicator-3.0.ebuild,v 1.16 2007/04/22 00:24:03 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/http-replicator/http-replicator-3.0.ebuild,v 1.17 2007/07/10 18:25:50 griffon26 Exp $
+
+inherit eutils
DESCRIPTION="Proxy cache for Gentoo packages"
HOMEPAGE="http://gertjan.freezope.org/replicator/"
@@ -14,6 +16,7 @@ IUSE=""
DEPEND=">=dev-lang/python-2.3"
src_compile() {
+ epatch "${FILESDIR}/http-replicator-3.0-sighup.patch"
einfo "No compilation necessary"
}