summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-05-02 19:45:58 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-05-02 19:45:58 +0000
commitb28dd70944760f69b5cdedf3475bdb74e39e53c2 (patch)
treeed8fd1041873baf0b6728e79288ff2293f76d9a6 /net-proxy
parentVersion bump, bug 468278. (diff)
downloadgentoo-2-b28dd70944760f69b5cdedf3475bdb74e39e53c2.tar.gz
gentoo-2-b28dd70944760f69b5cdedf3475bdb74e39e53c2.tar.bz2
gentoo-2-b28dd70944760f69b5cdedf3475bdb74e39e53c2.zip
EAPI 5. Fix incorrect timeout reporting for domains that are available, revision bump. Thanks to Andrew Savchenko for reporting. Fixes bug #389675.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/polipo/ChangeLog9
-rw-r--r--net-proxy/polipo/files/polipo-1.0.4.1-dns-timeout-fix.patch22
-rw-r--r--net-proxy/polipo/polipo-1.0.4.1-r2.ebuild52
3 files changed, 82 insertions, 1 deletions
diff --git a/net-proxy/polipo/ChangeLog b/net-proxy/polipo/ChangeLog
index 457391c5461e..cb5776a8e2bb 100644
--- a/net-proxy/polipo/ChangeLog
+++ b/net-proxy/polipo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-proxy/polipo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/polipo/ChangeLog,v 1.37 2013/03/31 15:30:54 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/polipo/ChangeLog,v 1.38 2013/05/02 19:45:58 tomwij Exp $
+
+*polipo-1.0.4.1-r2 (02 May 2013)
+
+ 02 May 2013; Tom Wijsman <TomWij@gentoo.org>
+ +files/polipo-1.0.4.1-dns-timeout-fix.patch, +polipo-1.0.4.1-r2.ebuild:
+ EAPI 5. Fix incorrect timeout reporting for domains that are available,
+ revision bump. Thanks to Andrew Savchenko for reporting. Fixes bug #389675.
*polipo-9999 (31 Mar 2013)
diff --git a/net-proxy/polipo/files/polipo-1.0.4.1-dns-timeout-fix.patch b/net-proxy/polipo/files/polipo-1.0.4.1-dns-timeout-fix.patch
new file mode 100644
index 000000000000..bf5757b36c36
--- /dev/null
+++ b/net-proxy/polipo/files/polipo-1.0.4.1-dns-timeout-fix.patch
@@ -0,0 +1,22 @@
+--- polipo-1.0.4/dns.c.orig 2008-01-08 16:56:45.000000000 +0400
++++ polipo-1.0.4/dns.c 2010-03-29 18:28:43.225601510 +0500
+@@ -1181,7 +1181,8 @@
+ } else
+ releaseAtom(value);
+ } else if(af == 0) {
+- if(query->inet4 || query->inet6) {
++ if(query->inet4 && query->inet4->length ||
++ query->inet6 && query->inet6->length) {
+ do_log(L_WARN, "Host %s has both %s and CNAME -- "
+ "ignoring CNAME.\n", query->name->string,
+ query->inet4 ? "A" : "AAAA");
+@@ -1207,7 +1208,8 @@
+ if(object->flags & OBJECT_INITIAL) {
+ assert(!object->headers);
+ if(cname) {
+- assert(query->inet4 == NULL && query->inet6 == NULL);
++ assert(!(query->inet4 && query->inet4->length));
++ assert(!(query->inet6 && query->inet6->length));
+ object->headers = cname;
+ object->expires = current_time.tv_sec + ttl;
+ } else if((!query->inet4 || query->inet4->length == 0) &&
diff --git a/net-proxy/polipo/polipo-1.0.4.1-r2.ebuild b/net-proxy/polipo/polipo-1.0.4.1-r2.ebuild
new file mode 100644
index 000000000000..62a4479d5717
--- /dev/null
+++ b/net-proxy/polipo/polipo-1.0.4.1-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/polipo/polipo-1.0.4.1-r2.ebuild,v 1.1 2013/05/02 19:45:58 tomwij Exp $
+
+EAPI="5"
+
+inherit eutils toolchain-funcs user
+
+DESCRIPTION="A caching web proxy"
+HOMEPAGE="http://www.pps.jussieu.fr/~jch/software/polipo/"
+SRC_URI="http://www.pps.jussieu.fr/~jch/software/files/${PN}/${P}.tar.gz"
+SRC_URI="http://freehaven.net/~chrisd/${PN}/${P}.tar.gz"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-apps/texinfo"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/cache/${PN} ${PN}
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-dns-timeout-fix.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake PREFIX=/usr "CDEBUGFLAGS=${CFLAGS}" all
+}
+
+src_install() {
+ einstall PREFIX=/usr MANDIR=/usr/share/man INFODIR=/usr/share/info "TARGET=${D}"
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ insinto /etc/${PN} ; doins "${FILESDIR}/config"
+ exeinto /etc/cron.daily ; newexe "${FILESDIR}/${PN}.crond" ${PN}.sh
+
+ diropts -m0750 -o ${PN} -g ${PN}
+ keepdir /var/cache/${PN}
+
+ dodoc CHANGES README
+ dohtml html/*
+}
+
+pkg_postinst() {
+ einfo "Do not forget to read the manual."
+ einfo "Change the config file in /etc/${PN} to suit your needs."
+}