summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2009-04-08 17:18:49 +0000
committerMounir Lamouri <volkmar@gentoo.org>2009-04-08 17:18:49 +0000
commit01c1c51680ac3c5d227aae78d4ee97cadc9c53cf (patch)
tree5e462153a62820f6c3ab25a9e55074c271803d48 /net-voip
parentRemove -j1 from emake install since the package installs fine with parallel m... (diff)
downloadgentoo-2-01c1c51680ac3c5d227aae78d4ee97cadc9c53cf.tar.gz
gentoo-2-01c1c51680ac3c5d227aae78d4ee97cadc9c53cf.tar.bz2
gentoo-2-01c1c51680ac3c5d227aae78d4ee97cadc9c53cf.zip
adding missing patches and fix parallel build
(Portage version: 2.1.6.7/cvs/Linux ppc)
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/gnugk/ChangeLog7
-rw-r--r--net-voip/gnugk/files/gnugk-2.2.7-configure.patch26
-rw-r--r--net-voip/gnugk/files/gnugk-2.2.7-firebird-2.1.patch79
-rw-r--r--net-voip/gnugk/gnugk-2.2.7.ebuild7
4 files changed, 115 insertions, 4 deletions
diff --git a/net-voip/gnugk/ChangeLog b/net-voip/gnugk/ChangeLog
index 13ed3640d66f..ebe450feb9f3 100644
--- a/net-voip/gnugk/ChangeLog
+++ b/net-voip/gnugk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-voip/gnugk
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/gnugk/ChangeLog,v 1.6 2009/02/12 04:47:00 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/gnugk/ChangeLog,v 1.7 2009/04/08 17:18:48 volkmar Exp $
+
+ 08 Apr 2009; Mounir Lamouri <volkmar@gentoo.org>
+ +files/gnugk-2.2.7-configure.patch, +files/gnugk-2.2.7-firebird-2.1.patch,
+ gnugk-2.2.7.ebuild:
+ adding missing patches and fix parallel build
*gnugk-2.2.7 (12 Feb 2009)
diff --git a/net-voip/gnugk/files/gnugk-2.2.7-configure.patch b/net-voip/gnugk/files/gnugk-2.2.7-configure.patch
new file mode 100644
index 000000000000..d4a589719b36
--- /dev/null
+++ b/net-voip/gnugk/files/gnugk-2.2.7-configure.patch
@@ -0,0 +1,26 @@
+--- configure.old 2009-02-10 17:14:47.000000000 -0500
++++ configure 2009-02-10 17:14:18.000000000 -0500
+@@ -3979,11 +3979,6 @@
+ fi
+
+
+-if test "x$pgsql" != "xno" -o "x$mysql" != "xno"; then
+- SOURCES="$SOURCES sqlauth.cxx sqlacct.cxx gksql.cxx"
+- HEADERS="$HEADERS sqlacct.h gksql.h"
+-fi
+-
+ # Check whether --enable-firebird or --disable-firebird was given.
+ if test "${enable_firebird+set}" = set; then
+ enableval="$enable_firebird"
+@@ -4242,6 +4237,11 @@
+ fi
+
+
++if test "x$pgsql" != "xno" -o "x$mysql" != "xno" -o "x$firebird" != "xno"; then
++ SOURCES="$SOURCES sqlauth.cxx sqlacct.cxx gksql.cxx"
++ HEADERS="$HEADERS sqlacct.h gksql.h"
++fi
++
+
+ GNUGK_MAJOR_VERSION=`cat version.h | grep "define GNUGK_MAJOR_VERSION" | cut -f4 -d' '`
+ GNUGK_MINOR_VERSION=`cat version.h | grep "define GNUGK_MINOR_VERSION" | cut -f4 -d' '`
diff --git a/net-voip/gnugk/files/gnugk-2.2.7-firebird-2.1.patch b/net-voip/gnugk/files/gnugk-2.2.7-firebird-2.1.patch
new file mode 100644
index 000000000000..9696c12c5bd6
--- /dev/null
+++ b/net-voip/gnugk/files/gnugk-2.2.7-firebird-2.1.patch
@@ -0,0 +1,79 @@
+--- gksql_firebird.cxx.old 2009-02-10 21:43:26.000000000 +0100
++++ gksql_firebird.cxx 2009-02-10 21:58:06.000000000 +0100
+@@ -342,11 +342,11 @@
+ if (status[0] == 1 && status[1] != 0) {
+ m_numRows = m_sqlRow;
+ if (retval != 100) {
+- long errcode = isc_sqlcode(status);
++ ISC_STATUS errcode = isc_sqlcode(status);
+ char errormsg[512];
+ if (errcode == -999) {
+ errcode = status[1];
+- long *pvector = status;
++ ISC_STATUS *pvector = status;
+ errormsg[isc_interprete(errormsg, &pvector)] = 0;
+ } else {
+ strcpy(errormsg, "SQL:");
+@@ -392,7 +392,7 @@
+ char errormsg[512];
+ if (errcode == -999) {
+ errcode = status[1];
+- long *pvector = status;
++ ISC_STATUS *pvector = status;
+ errormsg[isc_interprete(errormsg, &pvector)] = 0;
+ } else {
+ strcpy(errormsg, "SQL:");
+@@ -472,7 +472,7 @@
+
+ isc_attach_database(status, 0, const_cast<char*>(dbname.c_str()), &conn, dpb_offset, &(dpb[0]));
+ if (status[0] == 1 && status[1] != 0) {
+- long *pvector = status;
++ ISC_STATUS *pvector = status;
+ char errormsg[512];
+ errormsg[isc_interprete(errormsg, &pvector)] = 0;
+ PTRACE(2, GetName() << "\tFirebird connection to " << m_username << '@' << dbname
+@@ -505,7 +505,7 @@
+
+ isc_start_transaction(status, &tr, 1, &conn, 0, NULL);
+ if (status[0] == 1 && status[1] != 0) {
+- long *pvector = status;
++ ISC_STATUS *pvector = status;
+ char errormsg[512];
+ errormsg[isc_interprete(errormsg, &pvector)] = 0;
+ return new GkIBSQLResult(status[1], errormsg);
+@@ -516,7 +516,7 @@
+ long errorcode = isc_sqlcode(status);
+ if (errorcode == -999) {
+ errorcode = status[1];
+- long *pvector = status;
++ ISC_STATUS *pvector = status;
+ errormsg[isc_interprete(errormsg, &pvector)] = 0;
+ } else {
+ strcpy(errormsg, "SQL:");
+@@ -536,7 +536,7 @@
+ long errorcode = isc_sqlcode(status);
+ if (errorcode == -999) {
+ errorcode = status[1];
+- long *pvector = status;
++ ISC_STATUS *pvector = status;
+ errormsg[isc_interprete(errormsg, &pvector)] = 0;
+ } else {
+ strcpy(errormsg, "SQL:");
+@@ -558,7 +558,7 @@
+ long errorcode = isc_sqlcode(status);
+ if (errorcode == -999) {
+ errorcode = status[1];
+- long *pvector = status;
++ ISC_STATUS *pvector = status;
+ errormsg[isc_interprete(errormsg, &pvector)] = 0;
+ } else {
+ strcpy(errormsg, "SQL:");
+@@ -575,7 +575,7 @@
+ long errorcode = isc_sqlcode(status);
+ if (errorcode == -999) {
+ errorcode = status[1];
+- long *pvector = status;
++ ISC_STATUS *pvector = status;
+ errormsg[isc_interprete(errormsg, &pvector)] = 0;
+ } else {
+ strcpy(errormsg, "SQL:");
diff --git a/net-voip/gnugk/gnugk-2.2.7.ebuild b/net-voip/gnugk/gnugk-2.2.7.ebuild
index c259daba46cb..46af604d7c7a 100644
--- a/net-voip/gnugk/gnugk-2.2.7.ebuild
+++ b/net-voip/gnugk/gnugk-2.2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/gnugk/gnugk-2.2.7.ebuild,v 1.1 2009/02/12 04:47:00 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/gnugk/gnugk-2.2.7.ebuild,v 1.2 2009/04/08 17:18:49 volkmar Exp $
EAPI="2"
@@ -60,8 +60,9 @@ src_compile() {
# `make debugdepend debugshared` and `make debug` failed (so no debug)
# `make optdepend optnoshared` also failed (so no static)
- # fails with -j2
- emake -j1 optdepend optshared || die "emake failed"
+ # splitting emake calls fixes parallel build issue
+ emake optdepend || die "emake optdepend failed"
+ emake optshared || die "emake optshared failed"
# build tool addpasswd
emake addpasswd || die "emake addpasswd failed"