summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2009-04-08 17:30:28 +0000
committerMounir Lamouri <volkmar@gentoo.org>2009-04-08 17:30:28 +0000
commit656f92003ea2341bdc5653bb45bd2e7a3cf3490f (patch)
tree0052726553b821af243e5f9d9717732cff798500 /net-voip
parentRemove sudo 1.7.1 beta masking, moved on to RCs. (diff)
downloadgentoo-2-656f92003ea2341bdc5653bb45bd2e7a3cf3490f.tar.gz
gentoo-2-656f92003ea2341bdc5653bb45bd2e7a3cf3490f.tar.bz2
gentoo-2-656f92003ea2341bdc5653bb45bd2e7a3cf3490f.zip
version bump to 2.2.8 see bug 258518
(Portage version: 2.1.6.7/cvs/Linux ppc)
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/gnugk/ChangeLog8
-rw-r--r--net-voip/gnugk/files/gnugk-2.2.8-firebird-2.1.patch74
-rw-r--r--net-voip/gnugk/gnugk-2.2.8.ebuild116
3 files changed, 197 insertions, 1 deletions
diff --git a/net-voip/gnugk/ChangeLog b/net-voip/gnugk/ChangeLog
index ebe450feb9f3..7185dbf07c03 100644
--- a/net-voip/gnugk/ChangeLog
+++ b/net-voip/gnugk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-voip/gnugk
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/gnugk/ChangeLog,v 1.7 2009/04/08 17:18:48 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/gnugk/ChangeLog,v 1.8 2009/04/08 17:30:18 volkmar Exp $
+
+*gnugk-2.2.8 (08 Apr 2009)
+
+ 08 Apr 2009; Mounir Lamouri <volkmar@gentoo.org>
+ +files/gnugk-2.2.8-firebird-2.1.patch, +gnugk-2.2.8.ebuild:
+ version bump to 2.2.8 see bug 258518
08 Apr 2009; Mounir Lamouri <volkmar@gentoo.org>
+files/gnugk-2.2.7-configure.patch, +files/gnugk-2.2.7-firebird-2.1.patch,
diff --git a/net-voip/gnugk/files/gnugk-2.2.8-firebird-2.1.patch b/net-voip/gnugk/files/gnugk-2.2.8-firebird-2.1.patch
new file mode 100644
index 000000000000..2ba55f7ea135
--- /dev/null
+++ b/net-voip/gnugk/files/gnugk-2.2.8-firebird-2.1.patch
@@ -0,0 +1,74 @@
+--- gksql_firebird.cxx.old 2009-02-11 01:31:53.000000000 +0100
++++ gksql_firebird.cxx 2009-02-11 01:31:59.000000000 +0100
+@@ -370,7 +370,7 @@
+ char errormsg[512];
+ if (errcode == -999) {
+ errcode = status[1];
+- long *pvector = status;
++ ISC_STATUS *pvector = status;
+ // TODO: replace all isc_interprete() with fb_interpret()
+ errormsg[isc_interprete(errormsg, &pvector)] = 0;
+ } else {
+@@ -417,7 +417,7 @@
+ char errormsg[512];
+ if (errcode == -999) {
+ errcode = status[1];
+- long *pvector = status;
++ ISC_STATUS *pvector = status;
+ errormsg[isc_interprete(errormsg, &pvector)] = 0;
+ } else {
+ strcpy(errormsg, "SQL:");
+@@ -497,7 +497,7 @@
+
+ isc_attach_database(status, 0, const_cast<char*>(dbname.c_str()), &conn, dpb_offset, &(dpb[0]));
+ if (status[0] == 1 && status[1] != 0) {
+- long *pvector = status;
++ ISC_STATUS *pvector = status;
+ char errormsg[512];
+ errormsg[isc_interprete(errormsg, &pvector)] = 0;
+ PTRACE(2, GetName() << "\tFirebird connection to " << m_username << '@' << dbname
+@@ -530,7 +530,7 @@
+
+ isc_start_transaction(status, &tr, 1, &conn, 0, NULL);
+ if (status[0] == 1 && status[1] != 0) {
+- long *pvector = status;
++ ISC_STATUS *pvector = status;
+ char errormsg[512];
+ errormsg[isc_interprete(errormsg, &pvector)] = 0;
+ return new GkIBSQLResult(status[1], errormsg);
+@@ -541,7 +541,7 @@
+ long errorcode = isc_sqlcode(status);
+ if (errorcode == -999) {
+ errorcode = status[1];
+- long *pvector = status;
++ ISC_STATUS *pvector = status;
+ errormsg[isc_interprete(errormsg, &pvector)] = 0;
+ } else {
+ strcpy(errormsg, "SQL:");
+@@ -562,7 +562,7 @@
+ long errorcode = isc_sqlcode(status);
+ if (errorcode == -999) {
+ errorcode = status[1];
+- long *pvector = status;
++ ISC_STATUS *pvector = status;
+ errormsg[isc_interprete(errormsg, &pvector)] = 0;
+ } else {
+ strcpy(errormsg, "SQL:");
+@@ -585,7 +585,7 @@
+ long errorcode = isc_sqlcode(status);
+ if (errorcode == -999) {
+ errorcode = status[1];
+- long *pvector = status;
++ ISC_STATUS *pvector = status;
+ errormsg[isc_interprete(errormsg, &pvector)] = 0;
+ } else {
+ strcpy(errormsg, "SQL:");
+@@ -603,7 +603,7 @@
+ long errorcode = isc_sqlcode(status);
+ if (errorcode == -999) {
+ errorcode = status[1];
+- long *pvector = status;
++ ISC_STATUS *pvector = status;
+ errormsg[isc_interprete(errormsg, &pvector)] = 0;
+ } else {
+ strcpy(errormsg, "SQL:");
diff --git a/net-voip/gnugk/gnugk-2.2.8.ebuild b/net-voip/gnugk/gnugk-2.2.8.ebuild
new file mode 100644
index 000000000000..8eb718a4bbb7
--- /dev/null
+++ b/net-voip/gnugk/gnugk-2.2.8.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/gnugk/gnugk-2.2.8.ebuild,v 1.1 2009/04/08 17:30:18 volkmar Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="GNU H.323 gatekeeper"
+HOMEPAGE="http://www.gnugk.org/"
+SRC_URI="mirror://sourceforge/openh323gk/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+# dev-db/firebird isn't keyworded for ppc but firebird IUSE is masked for ppc
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc firebird mysql odbc postgres radius sqlite linguas_en linguas_es linguas_fr"
+
+# TODO: when h323plus will be in portage tree, add it as || dep with openh323
+RDEPEND=">=dev-libs/pwlib-1.7.5.2
+ >=net-libs/openh323-1.14.2
+ dev-libs/openssl
+ firebird? ( dev-db/firebird )
+ mysql? ( virtual/mysql )
+ odbc? ( dev-db/unixODBC )
+ postgres? ( virtual/postgresql-base )
+ sqlite? ( dev-db/sqlite:3 )"
+DEPEND="${RDEPEND}
+ doc? ( app-text/linuxdoc-tools )"
+
+pkg_setup() {
+ if use doc && ! use linguas_en && ! use linguas_es && ! use linguas_fr; then
+ elog "No linguas specified."
+ elog "English documentation will be installed."
+ fi
+}
+
+src_prepare() {
+ # fix build with firebird 2.1
+ # upstream has been contacted, watch if fixed in next releases
+ use firebird && epatch "${FILESDIR}"/${P}-firebird-2.1.patch
+}
+
+src_configure() {
+ # --with-large-fdset=4096 is added because of bug #128102
+ # and it is recommanded in the online manual
+ econf \
+ $(use_enable firebird) \
+ $(use_enable mysql) \
+ $(use_enable postgres pgsql) \
+ $(use_enable odbc unixodbc) \
+ $(use_enable radius) \
+ $(use_enable sqlite) \
+ --with-large-fdset=4096
+}
+
+src_compile() {
+ # PASN_NOPRINT should be set for -debug but it's buggy
+ # better to prevent issues and keep default settings
+ # `make debugdepend debugshared` and `make debug` failed (so no debug)
+ # `make optdepend optnoshared` also failed (so no static)
+
+ # splitting emake calls fixes parallel build issue
+ emake optdepend || die "emake optdepend failed"
+ emake optshared || die "emake optshared failed"
+
+ # build tool addpasswd
+ emake addpasswd || die "emake addpasswd failed"
+
+ if use doc; then
+ cd docs/manual
+
+ if use linguas_en || ( ! use linguas_es && ! use linguas_fr ); then
+ emake html || die "emake en doc failed"
+ fi
+
+ if use linguas_es; then
+ emake html-es || die "emake es doc failed"
+ fi
+
+ if use linguas_fr; then
+ emake html-fr || die "emake fr doc failed"
+ fi
+ cd ../..
+ fi
+}
+
+src_install() {
+ dosbin obj_*_*_*/${PN} || die "dosbin failed"
+ dosbin obj_*_*_*/addpasswd || die "dosbin failed"
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins etc/* || die "doins etc/* failed"
+
+ dodoc changes.txt readme.txt p2pnat_license.txt || die "dodoc failed"
+
+ if use doc; then
+ dodoc docs/*.txt docs/*.pdf || die "dodoc failed"
+
+ if use linguas_en || ( ! use linguas_es && ! use linguas_fr ); then
+ dohtml docs/manual/manual*.html || die "dohtml failed"
+ fi
+ if use linguas_fr; then
+ dohtml docs/manual/fr/manual-fr*.html || die "dohtml failed"
+ fi
+ if use linguas_es; then
+ dohtml docs/manual/es/manual-es*.html || die "dohtml failed"
+ fi
+ fi
+
+ doman docs/${PN}.1 || die "doman failed"
+
+ newinitd "${FILESDIR}"/${PN}.rc6 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}