summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-02-13 05:22:23 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-02-13 05:22:23 +0000
commit6d15bea95af7d3c60c8037010580feceec220d9b (patch)
tree252a5f5155f45473c91d526d53c1d6e7a197cf18 /net-voip
parentstable amd64, bug 258247 (diff)
downloadgentoo-2-6d15bea95af7d3c60c8037010580feceec220d9b.tar.gz
gentoo-2-6d15bea95af7d3c60c8037010580feceec220d9b.tar.bz2
gentoo-2-6d15bea95af7d3c60c8037010580feceec220d9b.zip
version bump by Mounir Lamouri, bug 174527
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/openmcu/ChangeLog11
-rw-r--r--net-voip/openmcu/files/openmcu-2.2.1-deque.patch10
-rw-r--r--net-voip/openmcu/files/openmcu-2.2.1-path.patch48
-rw-r--r--net-voip/openmcu/openmcu-2.2.1.ebuild74
4 files changed, 141 insertions, 2 deletions
diff --git a/net-voip/openmcu/ChangeLog b/net-voip/openmcu/ChangeLog
index 0eacefd156cd..ab968dcfa1f5 100644
--- a/net-voip/openmcu/ChangeLog
+++ b/net-voip/openmcu/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-voip/openmcu
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/openmcu/ChangeLog,v 1.3 2008/08/16 16:24:17 tove Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/openmcu/ChangeLog,v 1.4 2009/02/13 05:22:23 darkside Exp $
+
+*openmcu-2.2.1 (13 Feb 2009)
+
+ 13 Feb 2009; Jeremy Olexa <darkside@gentoo.org>
+ +files/openmcu-2.2.1-deque.patch, +files/openmcu-2.2.1-path.patch,
+ +openmcu-2.2.1.ebuild:
+ version bump by Mounir Lamouri, bug 174527
16 Aug 2008; Torsten Veller <tove@gentoo.org> metadata.xml:
Remove stkn from metadata.xml (#27693)
diff --git a/net-voip/openmcu/files/openmcu-2.2.1-deque.patch b/net-voip/openmcu/files/openmcu-2.2.1-deque.patch
new file mode 100644
index 000000000000..742d35a8c17c
--- /dev/null
+++ b/net-voip/openmcu/files/openmcu-2.2.1-deque.patch
@@ -0,0 +1,10 @@
+--- filemembers.h.old 2009-02-10 22:48:49.000000000 -0500
++++ filemembers.h 2009-02-10 22:49:00.000000000 -0500
+@@ -80,6 +80,7 @@
+
+ #include "config.h"
+
++#include <deque>
+ #include <ptlib/sound.h>
+ #include <opalwavfile.h>
+ #include "conference.h"
diff --git a/net-voip/openmcu/files/openmcu-2.2.1-path.patch b/net-voip/openmcu/files/openmcu-2.2.1-path.patch
new file mode 100644
index 000000000000..48ae0364a8c6
--- /dev/null
+++ b/net-voip/openmcu/files/openmcu-2.2.1-path.patch
@@ -0,0 +1,48 @@
+diff -u openmcu_v2_2_1.orig/main.cxx openmcu_v2_2_1/main.cxx
+--- openmcu_v2_2_1.orig/main.cxx 2006-06-09 00:39:59.000000000 -0400
++++ openmcu_v2_2_1/main.cxx 2009-02-10 23:09:49.000000000 -0500
+@@ -54,9 +54,9 @@
+ #include <ptlib.h>
+ #include "mcu.h"
+
+-static const char DefaultConnectingWAVFile[] = "connecting.wav";
+-static const char DefaultEnteringWAVFile[] = "entering.wav";
+-static const char DefaultLeavingWAVFile[] = "leaving.wav";
++static const char DefaultConnectingWAVFile[] = "/usr/share/openmcu/sounds/connecting.wav";
++static const char DefaultEnteringWAVFile[] = "/usr/share/openmcu/sounds/entering.wav";
++static const char DefaultLeavingWAVFile[] = "/usr/share/openmcu/sounds/leaving.wav";
+
+ static const char ConnectingWAVFileKey[] = "Connecting WAV File";
+ static const char EnteringWAVFileKey[] = "Entering WAV File";
+diff -u openmcu_v2_2_1.orig/mcu.cxx openmcu_v2_2_1/mcu.cxx
+--- openmcu_v2_2_1.orig/mcu.cxx 2006-07-14 01:28:01.000000000 -0400
++++ openmcu_v2_2_1/mcu.cxx 2009-02-10 23:11:43.000000000 -0500
+@@ -83,7 +83,7 @@
+ static const char DefaultRoomKey[] = "Default room";
+ static const char DefaultRoomTimeLimitKey[] = "Room time limit";
+
+-static const char DefaultCallLogFilename[] = "mcu_log.txt";
++static const char DefaultCallLogFilename[] = "/var/log/openmcu/openmcu.log";
+ static const char DefaultRoom[] = "room101";
+
+ #if OPENMCU_VIDEO
+@@ -154,8 +154,8 @@
+ #endif
+ exeDir.Change();
+
+- httpNameSpace.AddResource(new PHTTPDirectory("data", "data"));
+- httpNameSpace.AddResource(new PServiceHTTPDirectory("html", "html"));
++ httpNameSpace.AddResource(new PHTTPDirectory("data", "/usr/share/openmcu/data"));
++ httpNameSpace.AddResource(new PServiceHTTPDirectory("html", "/usr/share/openmcu/html"));
+
+ manager = CreateConferenceManager();
+ endpoint = CreateEndPoint(*manager);
+@@ -229,7 +229,7 @@
+
+ #if P_SSL
+ // SSL certificate file.
+- PString certificateFile = cfg.GetString(HTTPCertificateFileKey, "server.pem");
++ PString certificateFile = cfg.GetString(HTTPCertificateFileKey, "/etc/openmcu/server.pem");
+ rsrc->Add(new PHTTPStringField(HTTPCertificateFileKey, 25, certificateFile));
+ if (!SetServerCertificate(certificateFile, TRUE)) {
+ PSYSTEMLOG(Fatal, "MCU\tCould not load certificate \"" << certificateFile << '"');
diff --git a/net-voip/openmcu/openmcu-2.2.1.ebuild b/net-voip/openmcu/openmcu-2.2.1.ebuild
new file mode 100644
index 000000000000..ee56c831bc86
--- /dev/null
+++ b/net-voip/openmcu/openmcu-2.2.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/openmcu/openmcu-2.2.1.ebuild,v 1.1 2009/02/13 05:22:23 darkside Exp $
+
+EAPI="2"
+
+inherit eutils
+
+MY_PV=${PV//./_}
+DESCRIPTION="Simple Multi Conference Unit using H.323"
+# http://www.openh323.org/ looks dead
+HOMEPAGE="http://sourceforge.net/projects/openh323/"
+SRC_URI="mirror://sourceforge/openh323/${PN}-v${MY_PV}-src.tar.gz"
+
+LICENSE="MPL-1.0"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="net-libs/openh323"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}_v${MY_PV}
+
+src_prepare() {
+ # fix a compile error due to missing include
+ epatch "${FILESDIR}"/${P}-deque.patch
+ # set path for various files
+ epatch "${FILESDIR}"/${P}-path.patch
+}
+
+src_compile() {
+ OPENH323DIR=/usr/share/openh323 emake opt || die "emake failed"
+}
+
+src_install() {
+ dosbin obj_*_*_*/${PN} || die "dosbin failed"
+
+ keepdir /usr/share/${PN}/data /usr/share/${PN}/html
+
+ # needed for daemon
+ keepdir /var/log/${PN} /var/run/${PN}
+
+ insinto /usr/share/${PN}/sounds
+ doins *.wav || die "doins wav files failed"
+
+ insinto /etc/${PN}
+ doins server.pem || die "doins server.pem failed"
+ doins "${FILESDIR}"/${PN}.ini || die "doins ini file failed"
+
+ doman ${PN}.1 || die "doman failed"
+
+ dodoc ChangeLog ReadMe.txt || die "dodoc failed"
+
+ newinitd "${FILESDIR}"/${PN}.rc6 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
+
+pkg_preinst() {
+ enewgroup openmcu
+ enewuser openmcu -1 -1 /dev/null openmcu
+}
+
+pkg_postinst() {
+ einfo "Setting permissions..."
+ chown -R openmcu:openmcu "${ROOT}"etc/openmcu
+ chmod -R u=rwX,g=rX,o= "${ROOT}"etc/openmcu
+ chown -R openmcu:openmcu "${ROOT}"var/{log,run}/openmcu
+ chmod -R u=rwX,g=rX,o= "${ROOT}"var/{log,run}/openmcu
+
+ echo
+ elog "This patched version of openmcu stores it's configuration"
+ elog "in \"/etc/openmcu/openmcu.ini\""
+}