summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-12-28 19:46:03 +0000
committerPacho Ramos <pacho@gentoo.org>2014-12-28 19:46:03 +0000
commit5e28a63c58f2ba74fe5d863e04a58c723bad961f (patch)
tree0fd7f5e553bab90b6e0a407edf82a3dc2f804120 /net-wireless/bluez
parentCleanup CFLAGS handling. (diff)
downloadgentoo-2-5e28a63c58f2ba74fe5d863e04a58c723bad961f.tar.gz
gentoo-2-5e28a63c58f2ba74fe5d863e04a58c723bad961f.tar.bz2
gentoo-2-5e28a63c58f2ba74fe5d863e04a58c723bad961f.zip
Version bump (#533120 by mrueg), drop old
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-wireless/bluez')
-rw-r--r--net-wireless/bluez/ChangeLog8
-rw-r--r--net-wireless/bluez/bluez-5.27.ebuild (renamed from net-wireless/bluez/bluez-5.21-r1.ebuild)28
-rw-r--r--net-wireless/bluez/files/bluez-5.24-musl-compat.patch37
3 files changed, 27 insertions, 46 deletions
diff --git a/net-wireless/bluez/ChangeLog b/net-wireless/bluez/ChangeLog
index f779cc092357..5d79b8e6ba0b 100644
--- a/net-wireless/bluez/ChangeLog
+++ b/net-wireless/bluez/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/bluez
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/ChangeLog,v 1.232 2014/12/05 10:14:58 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/ChangeLog,v 1.233 2014/12/28 19:46:03 pacho Exp $
+
+*bluez-5.27 (28 Dec 2014)
+
+ 28 Dec 2014; Pacho Ramos <pacho@gentoo.org> +bluez-5.27.ebuild,
+ -bluez-5.21-r1.ebuild, -files/bluez-5.24-musl-compat.patch:
+ Version bump (#533120 by mrueg), drop old
05 Dec 2014; Agostino Sarubbo <ago@gentoo.org> bluez-5.25.ebuild:
Stable for x86, wrt bug #529946
diff --git a/net-wireless/bluez/bluez-5.21-r1.ebuild b/net-wireless/bluez/bluez-5.27.ebuild
index 47adf4bd5fc9..15744a91ae23 100644
--- a/net-wireless/bluez/bluez-5.21-r1.ebuild
+++ b/net-wireless/bluez/bluez-5.27.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/bluez-5.21-r1.ebuild,v 1.7 2014/11/02 09:36:26 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/bluez-5.27.ebuild,v 1.1 2014/12/28 19:46:03 pacho Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
inherit autotools eutils multilib python-any-r1 readme.gentoo systemd udev user multilib-minimal
@@ -13,7 +13,7 @@ SRC_URI="mirror://kernel/linux/bluetooth/${P}.tar.xz"
LICENSE="GPL-2+ LGPL-2.1+"
SLOT="0/3"
-KEYWORDS="amd64 arm hppa ppc ppc64 x86"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
IUSE="cups debug +obex +readline selinux systemd test +udev"
REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )"
@@ -43,7 +43,6 @@ DEPEND="${CDEPEND}
RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-bluetooth )
"
-
DOC_CONTENTS="
If you want to use rfcomm as a normal user, you need to add the user
to the uucp group.
@@ -107,10 +106,10 @@ multilib_src_configure() {
)
fi
- # Missing flags: experimental (sap, nfc, ...)
econf \
--localstatedir=/var \
--disable-android \
+ --enable-datafiles \
--enable-experimental \
--enable-optimization \
$(use_enable debug) \
@@ -119,6 +118,7 @@ multilib_src_configure() {
--enable-library \
$(multilib_native_use_enable test) \
--enable-tools \
+ --enable-manpages \
--enable-monitor \
$(multilib_native_use_enable cups) \
$(multilib_native_use_enable obex) \
@@ -146,6 +146,13 @@ multilib_src_install() {
if multilib_is_native_abi; then
emake DESTDIR="${D}" install
+ # Upstream don't install this, bug #524640
+ # http://permalink.gmane.org/gmane.linux.bluez.kernel/53115
+ # http://comments.gmane.org/gmane.linux.bluez.kernel/54564
+ # gatttool is only built with readline, bug #530776
+ use readline && dobin attrib/gatttool
+ dobin tools/hex2hcd
+
# Unittests are not that useful once installed
if use test ; then
rm -r "${ED}"/usr/$(get_libdir)/bluez/test || die
@@ -163,21 +170,26 @@ multilib_src_install_all() {
keepdir /var/lib/bluetooth
+ # Upstream don't want people to play with them
+ # But we keep installing them due 'historical' reasons
insinto /etc/bluetooth
local d
for d in input network proximity; do
doins profiles/${d}/${d}.conf
done
-
doins src/main.conf
doins src/bluetooth.conf
- insinto /usr/share/dbus-1/system-services
- doins src/org.bluez.service
+# FIXME:
+# Looks like upstream installs it only for systemd, probably not needed
+# insinto /usr/share/dbus-1/system-services
+# doins src/org.bluez.service
newinitd "${FILESDIR}"/bluetooth-init.d-r3 bluetooth
newinitd "${FILESDIR}"/rfcomm-init.d-r2 rfcomm
+ einstalldocs
+
readme.gentoo_create_doc
}
diff --git a/net-wireless/bluez/files/bluez-5.24-musl-compat.patch b/net-wireless/bluez/files/bluez-5.24-musl-compat.patch
deleted file mode 100644
index 766734a4affe..000000000000
--- a/net-wireless/bluez/files/bluez-5.24-musl-compat.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 57c33317f5c3f6d21a9b3c56f8d1e97179e4c457 Mon Sep 17 00:00:00 2001
-From: "Anthony G. Basile" <blueness@gentoo.org>
-Date: Sat, 4 Oct 2014 09:34:05 -0400
-Subject: [PATCH] emulator/serial.c: use posix_openpt() instead of getpt()
-
-getpt(3) is glibc-specific and is not provided on musl. Instead, we
-use use posix_openpt(3) which is equivalent and portable.
-
-Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
----
- emulator/serial.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/emulator/serial.c b/emulator/serial.c
-index 9583be4..8b49dc6 100644
---- a/emulator/serial.c
-+++ b/emulator/serial.c
-@@ -32,6 +32,7 @@
- #include <unistd.h>
- #include <stdlib.h>
- #include <string.h>
-+#include <fcntl.h>
- #include <sys/param.h>
- #include <sys/epoll.h>
- #include <sys/uio.h>
-@@ -160,7 +161,7 @@ static void open_pty(struct serial *serial)
- {
- enum btdev_type uninitialized_var(type);
-
-- serial->fd = getpt();
-+ serial->fd = posix_openpt(O_RDWR | O_NOCTTY);
- if (serial->fd < 0) {
- perror("Failed to get master pseudo terminal");
- return;
---
-2.0.4
-