summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2014-05-08 03:08:23 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2014-05-08 03:08:23 +0000
commit8f75ebeb9c6d486b6e284e924945585f779a1f2a (patch)
tree4af5a64ea9b319ef82129161aab0a0f0bb9d79bd /net-wireless/cinnamon-bluetooth/cinnamon-bluetooth-3.8.4.ebuild
parentversion bump (bug #500816). backported gnutls fix. proper LINGUAS support (bu... (diff)
downloadgentoo-2-8f75ebeb9c6d486b6e284e924945585f779a1f2a.tar.gz
gentoo-2-8f75ebeb9c6d486b6e284e924945585f779a1f2a.tar.bz2
gentoo-2-8f75ebeb9c6d486b6e284e924945585f779a1f2a.zip
Add Cinnamon-2.x wrapper around gnome-bluetooth
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'net-wireless/cinnamon-bluetooth/cinnamon-bluetooth-3.8.4.ebuild')
-rw-r--r--net-wireless/cinnamon-bluetooth/cinnamon-bluetooth-3.8.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-wireless/cinnamon-bluetooth/cinnamon-bluetooth-3.8.4.ebuild b/net-wireless/cinnamon-bluetooth/cinnamon-bluetooth-3.8.4.ebuild
new file mode 100644
index 000000000000..3ee0a8518e30
--- /dev/null
+++ b/net-wireless/cinnamon-bluetooth/cinnamon-bluetooth-3.8.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/cinnamon-bluetooth/cinnamon-bluetooth-3.8.4.ebuild,v 1.1 2014/05/08 03:08:23 tetromino Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Bluetooth support libraries for Cinnamon"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/cinnamon-bluetooth/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.31:2
+ gnome-extra/cinnamon-control-center
+ >=net-wireless/gnome-bluetooth-3.4.1:2=
+ >=x11-libs/gtk+-3.4.2:3
+ x11-libs/libX11
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/gnome-icon-theme-symbolic
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.40.1
+ virtual/pkgconfig
+ x11-proto/xproto
+"
+# eautoreconf needs:
+# gnome-base/gnome-common
+
+src_prepare() {
+ epatch_user
+ eautoreconf
+ gnome2_src_prepare
+}