summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-06-12 22:31:38 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-06-12 22:31:38 +0000
commit0ccc0a8ced3e8f82a3f4fb8e70f7da776a0eae9c (patch)
tree3ed857abf702e295b46a8c21c9e6be858e3b2ea1 /net-wireless/gnuradio
parentAdd optional depend on gvim for bug #419957 thanks to (diff)
downloadgentoo-2-0ccc0a8ced3e8f82a3f4fb8e70f7da776a0eae9c.tar.gz
gentoo-2-0ccc0a8ced3e8f82a3f4fb8e70f7da776a0eae9c.tar.bz2
gentoo-2-0ccc0a8ced3e8f82a3f4fb8e70f7da776a0eae9c.zip
Always enable gr-audio and make the individual output modules non-automagic.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'net-wireless/gnuradio')
-rw-r--r--net-wireless/gnuradio/ChangeLog8
-rw-r--r--net-wireless/gnuradio/files/gnuradio-3.6.1-automagic-audio.patch90
-rw-r--r--net-wireless/gnuradio/gnuradio-3.6.1-r1.ebuild182
3 files changed, 279 insertions, 1 deletions
diff --git a/net-wireless/gnuradio/ChangeLog b/net-wireless/gnuradio/ChangeLog
index bfedc19b7291..ca054442f0f2 100644
--- a/net-wireless/gnuradio/ChangeLog
+++ b/net-wireless/gnuradio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/gnuradio
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/gnuradio/ChangeLog,v 1.11 2012/06/11 22:03:05 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/gnuradio/ChangeLog,v 1.12 2012/06/12 22:31:38 chithanh Exp $
+
+*gnuradio-3.6.1-r1 (12 Jun 2012)
+
+ 12 Jun 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/gnuradio-3.6.1-automagic-audio.patch, +gnuradio-3.6.1-r1.ebuild:
+ Always enable gr-audio and make the individual output modules non-automagic.
*gnuradio-3.6.1 (11 Jun 2012)
diff --git a/net-wireless/gnuradio/files/gnuradio-3.6.1-automagic-audio.patch b/net-wireless/gnuradio/files/gnuradio-3.6.1-automagic-audio.patch
new file mode 100644
index 000000000000..4fa1c664145d
--- /dev/null
+++ b/net-wireless/gnuradio/files/gnuradio-3.6.1-automagic-audio.patch
@@ -0,0 +1,90 @@
+diff -ur a/gr-audio/lib/CMakeLists.txt b/gr-audio/lib/CMakeLists.txt
+--- a/gr-audio/lib/CMakeLists.txt 2012-06-11 17:55:20.000000000 +0200
++++ b/gr-audio/lib/CMakeLists.txt 2012-06-12 23:34:58.601611171 +0200
+@@ -38,7 +38,11 @@
+ ########################################################################
+ find_package(ALSA)
+
+-if(ALSA_FOUND)
++GR_REGISTER_COMPONENT("gr-audio-alsa" ENABLE_GR_AUDIO_ALSA
++ ALSA_FOUND
++)
++
++if(ALSA_FOUND AND ENABLE_GR_AUDIO_ALSA)
+
+ include_directories(${CMAKE_CURRENT_SOURCE_DIR}/alsa ${ALSA_INCLUDE_DIRS})
+ list(APPEND gr_audio_libs ${ALSA_LIBRARIES})
+@@ -49,14 +53,18 @@
+ )
+ list(APPEND gr_audio_confs ${CMAKE_CURRENT_SOURCE_DIR}/alsa/gr-audio-alsa.conf)
+
+-endif(ALSA_FOUND)
++endif(ALSA_FOUND AND ENABLE_GR_AUDIO_ALSA)
+
+ ########################################################################
+ ## OSS Support
+ ########################################################################
+ find_package(OSS)
+
+-if(OSS_FOUND)
++GR_REGISTER_COMPONENT("gr-audio-oss" ENABLE_GR_AUDIO_OSS
++ OSS_FOUND
++)
++
++if(OSS_FOUND AND ENABLE_GR_AUDIO_OSS)
+
+ include_directories(${CMAKE_CURRENT_SOURCE_DIR}/oss ${OSS_INCLUDE_DIRS})
+ list(APPEND gr_audio_sources
+@@ -65,7 +73,7 @@
+ )
+ list(APPEND gr_audio_confs ${CMAKE_CURRENT_SOURCE_DIR}/oss/gr-audio-oss.conf)
+
+-endif(OSS_FOUND)
++endif(OSS_FOUND AND ENABLE_GR_AUDIO_OSS)
+
+
+ ########################################################################
+@@ -73,7 +81,11 @@
+ ########################################################################
+ find_package(Jack)
+
+-if(JACK_FOUND)
++GR_REGISTER_COMPONENT("gr-audio-jack" ENABLE_GR_AUDIO_JACK
++ JACK_FOUND
++)
++
++if(JACK_FOUND AND ENABLE_GR_AUDIO_JACK)
+
+ include_directories(${CMAKE_CURRENT_SOURCE_DIR}/jack ${JACK_INCLUDE_DIRS})
+ list(APPEND gr_audio_libs ${JACK_LIBRARIES})
+@@ -85,7 +97,7 @@
+ )
+ list(APPEND gr_audio_confs ${CMAKE_CURRENT_SOURCE_DIR}/jack/gr-audio-jack.conf)
+
+-endif(JACK_FOUND)
++endif(JACK_FOUND AND ENABLE_GR_AUDIO_JACK)
+
+ ########################################################################
+ ## OSX Support
+@@ -115,7 +127,11 @@
+ ########################################################################
+ find_package(Portaudio)
+
+-if(PORTAUDIO_FOUND)
++GR_REGISTER_COMPONENT("gr-audio-portaudio" ENABLE_GR_AUDIO_PORTAUDIO
++ PORTAUDIO_FOUND
++)
++
++if(PORTAUDIO_FOUND AND ENABLE_GR_AUDIO_PORTAUDIO)
+
+ include_directories(${CMAKE_CURRENT_SOURCE_DIR}/portaudio ${PORTAUDIO_INCLUDE_DIRS})
+ list(APPEND gr_audio_libs ${PORTAUDIO_LIBRARIES})
+@@ -127,7 +143,7 @@
+ )
+ list(APPEND gr_audio_confs ${CMAKE_CURRENT_SOURCE_DIR}/portaudio/gr-audio-portaudio.conf)
+
+-endif(PORTAUDIO_FOUND)
++endif(PORTAUDIO_FOUND AND ENABLE_GR_AUDIO_PORTAUDIO)
+
+ ########################################################################
+ ## Windows Support
diff --git a/net-wireless/gnuradio/gnuradio-3.6.1-r1.ebuild b/net-wireless/gnuradio/gnuradio-3.6.1-r1.ebuild
new file mode 100644
index 000000000000..eda319ee3ad8
--- /dev/null
+++ b/net-wireless/gnuradio/gnuradio-3.6.1-r1.ebuild
@@ -0,0 +1,182 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/gnuradio/gnuradio-3.6.1-r1.ebuild,v 1.1 2012/06/12 22:31:38 chithanh Exp $
+
+EAPI=4
+PYTHON_DEPEND="2"
+
+inherit base cmake-utils fdo-mime python
+
+DESCRIPTION="Toolkit that provides signal processing blocks to implement software radios"
+HOMEPAGE="http://gnuradio.org/"
+SRC_URI="http://gnuradio.org/redmine/attachments/download/389/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa doc examples fcd grc jack oss portaudio qt4 sdl utils wavelet wxwidgets"
+
+# bug #348206
+# comedi? ( >=sci-electronics/comedilib-0.7 )
+# uhd? ( dev-libs/uhd )
+RDEPEND=">=dev-lang/orc-0.4.12
+ dev-libs/boost
+ dev-util/cppunit
+ sci-libs/fftw:3.0
+ fcd? ( virtual/libusb:1 )
+ alsa? (
+ media-libs/alsa-lib
+ )
+ grc? (
+ dev-python/cheetah
+ dev-python/lxml
+ dev-python/numpy
+ dev-python/pygtk:2
+ )
+ jack? (
+ media-sound/jack-audio-connection-kit
+ )
+ portaudio? (
+ >=media-libs/portaudio-19_pre
+ )
+ qt4? (
+ dev-python/PyQt4[X,opengl]
+ dev-python/pyqwt:5
+ x11-libs/qt-gui
+ )
+ sdl? ( media-libs/libsdl )
+ wavelet? (
+ sci-libs/gsl
+ )
+ wxwidgets? (
+ dev-python/wxpython:2.8
+ dev-python/numpy
+ )
+"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ virtual/pkgconfig
+ doc? (
+ >=app-doc/doxygen-1.5.7.1
+ dev-python/sphinx
+ )
+ grc? (
+ x11-misc/xdg-utils
+ )
+ oss? (
+ virtual/os-headers
+ )
+"
+
+# Add support for custom SYSCONFDIR, upstream bug #492
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.6.0-cmake-sysconfdir.patch
+ "${FILESDIR}"/${PN}-3.6.1-automagic-audio.patch
+)
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -q -r 2 "${S}"
+ # Useless UI element would require qt3support, bug #365019
+ sed -i '/qPixmapFromMimeSource/d' "${S}"/gr-qtgui/lib/spectrumdisplayform.ui || die
+ base_src_prepare
+}
+
+src_configure() {
+ # TODO: docs are installed to /usr/share/doc/${PN} not /usr/share/doc/${PF}
+ # SYSCONFDIR/GR_PREFSDIR default to install below CMAKE_INSTALL_PREFIX
+ mycmakeargs=(
+ $(cmake-utils_use_enable alsa GR_AUDIO_ALSA)
+ $(cmake-utils_use_enable doc DOXYGEN) \
+ $(cmake-utils_use_enable doc SPHINX) \
+ $(cmake-utils_use_enable fcd GR_FCD) \
+ $(cmake-utils_use_enable grc GRC) \
+ $(cmake-utils_use_enable jack GR_AUDIO_JACK)
+ $(cmake-utils_use_enable oss GR_AUDIO_OSS)
+ $(cmake-utils_use_enable portaudio GR_AUDIO_PORTAUDIO)
+ $(cmake-utils_use_enable utils GR_UTILS) \
+ $(cmake-utils_use_enable wavelet GR_WAVELET) \
+ $(cmake-utils_use_enable wxwidgets GR_WXGUI) \
+ $(cmake-utils_use_enable qt4 GR_QTGUI) \
+ $(cmake-utils_use_enable sdl GR_VIDEO_SDL) \
+ -DENABLE_GR_CORE=ON
+ -DQWT_INCLUDE_DIRS="${EPREFIX}"/usr/include/qwt5
+ -DSYSCONFDIR="${EPREFIX}"/etc
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ python_clean_installation_image -q
+
+ # Remove bad shebangs that creep back in during install
+ sed -i '\|#!/usr/bin/python|d' "${ED}"/usr/bin/* || die
+
+ # Install examples to /usr/share/doc/$PF
+ if use examples ; then
+ dodir /usr/share/doc/${PF}/
+ mv "${ED}"/usr/share/${PN}/examples "${ED}"/usr/share/doc/${PF}/ || die
+ else
+ # It seems that the examples are always installed
+ rm -rf "${ED}"/usr/share/${PN}/examples || die
+ fi
+
+ # We install the mimetypes to the correct locations from the ebuild
+ rm -rf "${ED}"/usr/share/${PN}/grc/freedesktop || die
+ rm -f "${ED}"/usr/libexec/${PN}/grc_setup_freedesktop || die
+
+ # Install icons, menu items and mime-types for GRC
+ if use grc ; then
+ local fd_path="${S}/grc/freedesktop"
+ insinto /usr/share/mime/packages
+ doins "${fd_path}/${PN}-grc.xml"
+
+ domenu "${fd_path}/"*.desktop
+ doicon "${fd_path}/"*.png
+ fi
+}
+
+pkg_postinst()
+{
+ local GRC_ICON_SIZES="32 48 64 128 256"
+ python_mod_optimize gnuradio
+
+ if use grc ; then
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ for size in ${GRC_ICON_SIZES} ; do
+ xdg-icon-resource install --noupdate --context mimetypes --size ${size} \
+ "${EROOT}/usr/share/pixmaps/grc-icon-${size}.png" application-gnuradio-grc \
+ || die "icon resource installation failed"
+ xdg-icon-resource install --noupdate --context apps --size ${size} \
+ "${EROOT}/usr/share/pixmaps/grc-icon-${size}.png" gnuradio-grc \
+ || die "icon resource installation failed"
+ done
+ xdg-icon-resource forceupdate
+ fi
+}
+
+pkg_postrm()
+{
+ local GRC_ICON_SIZES="32 48 64 128 256"
+ python_mod_cleanup gnuradio
+
+ if use grc ; then
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ for size in ${GRC_ICON_SIZES} ; do
+ xdg-icon-resource uninstall --noupdate --context mimetypes --size ${size} \
+ application-gnuradio-grc || ewarn "icon uninstall failed"
+ xdg-icon-resource uninstall --noupdate --context apps --size ${size} \
+ gnuradio-grc || ewarn "icon uninstall failed"
+
+ done
+ xdg-icon-resource forceupdate
+ fi
+}