summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2006-02-16 10:28:31 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2006-02-16 10:28:31 +0000
commit39924192823764dfefbb1baadea3e0a3f0a8d842 (patch)
tree9ea7b779b716e800e091c7db78d4239714c66f7c /net-wireless/hostapd
parentPunt old version (diff)
downloadgentoo-2-39924192823764dfefbb1baadea3e0a3f0a8d842.tar.gz
gentoo-2-39924192823764dfefbb1baadea3e0a3f0a8d842.tar.bz2
gentoo-2-39924192823764dfefbb1baadea3e0a3f0a8d842.zip
Fix building with USE=-ssl. Thanks to langthang in bug #122987.
(Portage version: 2.0.54)
Diffstat (limited to 'net-wireless/hostapd')
-rw-r--r--net-wireless/hostapd/ChangeLog6
-rw-r--r--net-wireless/hostapd/hostapd-0.5.0-r1.ebuild7
-rw-r--r--net-wireless/hostapd/hostapd-0.5.0.ebuild9
-rw-r--r--net-wireless/hostapd/hostapd-0.5.1.ebuild7
4 files changed, 21 insertions, 8 deletions
diff --git a/net-wireless/hostapd/ChangeLog b/net-wireless/hostapd/ChangeLog
index d51537142b5c..3664cd46c9f3 100644
--- a/net-wireless/hostapd/ChangeLog
+++ b/net-wireless/hostapd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-wireless/hostapd
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.55 2006/02/14 12:09:44 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.56 2006/02/16 10:28:31 brix Exp $
+
+ 16 Feb 2006; Henrik Brix Andersen <brix@gentoo.org> hostapd-0.5.0.ebuild,
+ hostapd-0.5.0-r1.ebuild, hostapd-0.5.1.ebuild:
+ Fix building with USE=-ssl. Thanks to langthang in bug #122987.
*hostapd-0.4.8 (14 Feb 2006)
diff --git a/net-wireless/hostapd/hostapd-0.5.0-r1.ebuild b/net-wireless/hostapd/hostapd-0.5.0-r1.ebuild
index e9863c37616a..8d0c7c3a2698 100644
--- a/net-wireless/hostapd/hostapd-0.5.0-r1.ebuild
+++ b/net-wireless/hostapd/hostapd-0.5.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.5.0-r1.ebuild,v 1.1 2006/01/09 16:55:36 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.5.0-r1.ebuild,v 1.2 2006/02/16 10:28:31 brix Exp $
inherit toolchain-funcs
@@ -67,7 +67,10 @@ src_unpack() {
src_compile() {
emake || die "emake failed"
- use ssl && emake nt_password_hash || die "emake nt_password_hash failed"
+
+ if use ssl; then
+ emake nt_password_hash || die "emake nt_password_hash failed"
+ fi
}
src_install() {
diff --git a/net-wireless/hostapd/hostapd-0.5.0.ebuild b/net-wireless/hostapd/hostapd-0.5.0.ebuild
index 5091fe43425e..62bcdf3789c3 100644
--- a/net-wireless/hostapd/hostapd-0.5.0.ebuild
+++ b/net-wireless/hostapd/hostapd-0.5.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.5.0.ebuild,v 1.1 2005/12/20 11:09:30 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.5.0.ebuild,v 1.2 2006/02/16 10:28:31 brix Exp $
inherit toolchain-funcs
@@ -67,7 +67,10 @@ src_unpack() {
src_compile() {
emake || die "emake failed"
- use ssl && emake nt_password_hash || die "emake nt_password_hash failed"
+
+ if use ssl; then
+ emake nt_password_hash || die "emake nt_password_hash failed"
+ fi
}
src_install() {
diff --git a/net-wireless/hostapd/hostapd-0.5.1.ebuild b/net-wireless/hostapd/hostapd-0.5.1.ebuild
index 05d76cfa0c91..0932def53603 100644
--- a/net-wireless/hostapd/hostapd-0.5.1.ebuild
+++ b/net-wireless/hostapd/hostapd-0.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.5.1.ebuild,v 1.1 2006/01/30 22:28:39 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.5.1.ebuild,v 1.2 2006/02/16 10:28:31 brix Exp $
inherit toolchain-funcs
@@ -67,7 +67,10 @@ src_unpack() {
src_compile() {
emake || die "emake failed"
- use ssl && emake nt_password_hash || die "emake nt_password_hash failed"
+
+ if use ssl; then
+ emake nt_password_hash || die "emake nt_password_hash failed"
+ fi
}
src_install() {