summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-06-01 13:56:56 +0000
committerPeter Volkov <pva@gentoo.org>2009-06-01 13:56:56 +0000
commitd8e8fea834d76c25675f9b501523e8f139782ebf (patch)
treead2f1d868f0cbcfdadad06e5e240b038de3f4d65 /net-wireless/madwifi-ng
parentAdd ~sparc for testing, part of Bug #272046. (diff)
downloadgentoo-2-d8e8fea834d76c25675f9b501523e8f139782ebf.tar.gz
gentoo-2-d8e8fea834d76c25675f9b501523e8f139782ebf.tar.bz2
gentoo-2-d8e8fea834d76c25675f9b501523e8f139782ebf.zip
Remove old and vulnerable versions, bug #271697, thank Robert Buchholz for report.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'net-wireless/madwifi-ng')
-rw-r--r--net-wireless/madwifi-ng/ChangeLog9
-rw-r--r--net-wireless/madwifi-ng/files/madwifi-2.6.22.patch105
-rw-r--r--net-wireless/madwifi-ng/madwifi-ng-0.9.3.1.ebuild86
-rw-r--r--net-wireless/madwifi-ng/madwifi-ng-0.9.3.2.ebuild84
4 files changed, 7 insertions, 277 deletions
diff --git a/net-wireless/madwifi-ng/ChangeLog b/net-wireless/madwifi-ng/ChangeLog
index 35ccae1cf058..0ef66d62bcd0 100644
--- a/net-wireless/madwifi-ng/ChangeLog
+++ b/net-wireless/madwifi-ng/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-wireless/madwifi-ng
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/madwifi-ng/ChangeLog,v 1.65 2009/01/31 16:15:06 pva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/madwifi-ng/ChangeLog,v 1.66 2009/06/01 13:56:56 pva Exp $
+
+ 01 Jun 2009; Peter Volkov <pva@gentoo.org> -madwifi-ng-0.9.3.1.ebuild,
+ -madwifi-ng-0.9.3.2.ebuild, -files/madwifi-2.6.22.patch:
+ Remove old and vulnerable versions, bug #271697, thank Robert Buchholz for
+ report.
31 Jan 2009; Peter Volkov <pva@gentoo.org>
+files/madwifi-ng-0.9.4-request_module-build.patch,
diff --git a/net-wireless/madwifi-ng/files/madwifi-2.6.22.patch b/net-wireless/madwifi-ng/files/madwifi-2.6.22.patch
deleted file mode 100644
index 3918f6810ac7..000000000000
--- a/net-wireless/madwifi-ng/files/madwifi-2.6.22.patch
+++ /dev/null
@@ -1,105 +0,0 @@
---- madwifi-0.9.3.1/ath/if_ath_pci.c.orig 2007-07-10 01:01:07.000000000 -0700
-+++ madwifi-0.9.3.1/ath/if_ath_pci.c 2007-07-10 01:01:54.000000000 -0700
-@@ -207,7 +207,7 @@
-
- pci_set_drvdata(pdev, dev);
-
-- if (request_irq(dev->irq, ath_intr, SA_SHIRQ, dev->name, dev)) {
-+ if (request_irq(dev->irq, ath_intr, IRQF_SHARED, dev->name, dev)) {
- printk(KERN_WARNING "%s: request_irq failed\n", dev->name);
- goto bad3;
- }
---- madwifi-0.9.3.1/net80211/ieee80211_input.c.orig 2007-07-10 00:51:24.000000000 -0700
-+++ madwifi-0.9.3.1/net80211/ieee80211_input.c 2007-07-10 00:51:29.000000000 -0700
-@@ -1048,11 +1048,11 @@
- * incoming fragments
- * XXX 4-address/QoS frames?
- */
-- else if (skb->end - skb->head < ni->ni_vap->iv_dev->mtu +
-+ else if (skb_end_pointer(skb) - skb->head < ni->ni_vap->iv_dev->mtu +
- hdrlen) {
- ni->ni_rxfrag = skb_copy_expand(skb, 0,
- (ni->ni_vap->iv_dev->mtu + hdrlen) -
-- (skb->end - skb->head), GFP_ATOMIC);
-+ (skb_end_pointer(skb) - skb->head), GFP_ATOMIC);
- dev_kfree_skb(skb);
- }
- }
-@@ -1066,7 +1066,7 @@
- * we've verified that before
- */
- /* Copy current fragment at end of previous one */
-- memcpy(ni->ni_rxfrag->tail,
-+ memcpy(skb_tail_pointer(ni->ni_rxfrag),
- skb->data + hdrlen, skb->len - hdrlen);
- /* Update tail and length */
- skb_put(ni->ni_rxfrag, skb->len - hdrlen);
-@@ -1136,8 +1136,8 @@
- }
- if (skb1 != NULL) {
- skb1->dev = dev;
-- skb1->mac.raw = skb1->data;
-- skb1->nh.raw = skb1->data + sizeof(struct ether_header);
-+ skb_reset_mac_header(skb1);
-+ skb_set_network_header(skb1, sizeof(struct ether_header));
- skb1->protocol = __constant_htons(ETH_P_802_2);
- /* XXX insert vlan tag before queue it? */
- dev_queue_xmit(skb1);
-@@ -2259,7 +2259,7 @@
- if (skb1 == NULL)
- return;
- skb1->dev = dev;
-- skb1->mac.raw = skb1->data;
-+ skb_reset_mac_header(skb1);
- skb1->ip_summed = CHECKSUM_NONE;
- skb1->pkt_type = PACKET_OTHERHOST;
- skb1->protocol = __constant_htons(0x0019); /* ETH_P_80211_RAW */
-@@ -2533,8 +2533,9 @@
- l2uf->xid[2] = 0x00;
-
- skb->dev = dev;
-- skb->protocol = eth_type_trans(skb, dev);
-- skb->mac.raw = skb->data;
-+ skb->pkt_type = PACKET_BROADCAST;
-+ skb->protocol = htons(ETH_P_802_2);
-+ skb_reset_mac_header(skb);
- ieee80211_deliver_data(ni, skb);
- return;
- }
-@@ -3713,14 +3714,14 @@
- {
- struct ethhdr *eth;
-
-- skb->mac.raw=skb->data;
-+ skb_reset_mac_header(skb);
- skb_pull(skb, ETH_HLEN);
- /*
- * NB: mac.ethernet is replaced in 2.6.9 by eth_hdr but
- * since that's an inline and not a define there's
- * no easy way to do this cleanly.
- */
-- eth = (struct ethhdr *)skb->mac.raw;
-+ eth = (struct ethhdr *)skb_mac_header(skb);
-
- if (*eth->h_dest & 1)
- if (memcmp(eth->h_dest, dev->broadcast, ETH_ALEN) == 0)
---- madwifi-0.9.3.1/net80211/ieee80211_monitor.c.orig 2007-07-10 00:52:51.000000000 -0700
-+++ madwifi-0.9.3.1/net80211/ieee80211_monitor.c 2007-07-10 00:54:29.000000000 -0700
-@@ -373,7 +373,7 @@
- if (vap->iv_monitor_txf_len && tx) {
- /* truncate transmit feedback packets */
- skb_trim(skb1, vap->iv_monitor_txf_len);
-- skb1->nh.raw = skb1->data;
-+ skb_reset_network_header(skb1);
- }
- switch (vap->iv_dev->type) {
- case ARPHRD_IEEE80211:
-@@ -555,7 +555,7 @@
- skb_trim(skb1, skb1->len - IEEE80211_CRC_LEN);
- }
- skb1->dev = dev; /* NB: deliver to wlanX */
-- skb1->mac.raw = skb1->data;
-+ skb_reset_mac_header(skb1);
- skb1->ip_summed = CHECKSUM_NONE;
- skb1->pkt_type = pkttype;
- skb1->protocol = __constant_htons(0x0019); /* ETH_P_80211_RAW */
diff --git a/net-wireless/madwifi-ng/madwifi-ng-0.9.3.1.ebuild b/net-wireless/madwifi-ng/madwifi-ng-0.9.3.1.ebuild
deleted file mode 100644
index f935e133dd4f..000000000000
--- a/net-wireless/madwifi-ng/madwifi-ng-0.9.3.1.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/madwifi-ng/madwifi-ng-0.9.3.1.ebuild,v 1.9 2008/11/15 16:19:47 pva Exp $
-
-inherit linux-mod
-
-MY_P=${PN/-ng/}-${PV}
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Next Generation driver for Atheros based IEEE 802.11a/b/g wireless LAN cards"
-HOMEPAGE="http://www.madwifi-project.org/"
-SRC_URI="mirror://sourceforge/madwifi/madwifi-${PV}.tar.bz2"
-
-LICENSE="atheros-hal
- || ( BSD GPL-2 )"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="injection"
-
-DEPEND="app-arch/sharutils"
-RDEPEND="!net-wireless/madwifi-old
- net-wireless/wireless-tools
- ~net-wireless/madwifi-ng-tools-${PV}"
-
-CONFIG_CHECK="CRYPTO WIRELESS_EXT SYSCTL"
-ERROR_CRYPTO="${P} requires Cryptographic API support (CONFIG_CRYPTO)."
-ERROR_WIRELESS_EXT="${P} requires CONFIG_WIRELESS_EXT selected by Wireless LAN drivers (non-hamradio) & Wireless Extensions"
-ERROR_SYSCTL="${P} requires Sysctl support (CONFIG_SYSCTL)."
-BUILD_TARGETS="all"
-MODULESD_ATH_PCI_DOCS="README"
-
-pkg_setup() {
- linux-mod_pkg_setup
-
- MODULE_NAMES="ath_hal(net:"${S}"/ath_hal)
- wlan(net:"${S}"/net80211)
- wlan_acl(net:"${S}"/net80211)
- wlan_ccmp(net:"${S}"/net80211)
- wlan_tkip(net:"${S}"/net80211)
- wlan_wep(net:"${S}"/net80211)
- wlan_xauth(net:"${S}"/net80211)
- wlan_scan_sta(net:"${S}"/net80211)
- wlan_scan_ap(net:"${S}"/net80211)
- ath_rate_amrr(net:"${S}"/ath_rate/amrr)
- ath_rate_onoe(net:"${S}"/ath_rate/onoe)
- ath_rate_sample(net:"${S}"/ath_rate/sample)
- ath_pci(net:"${S}"/ath)"
-
- BUILD_PARAMS="KERNELPATH=${KV_OUT_DIR}"
-}
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- epatch "${FILESDIR}/${PN}-0.9.3-uudecode-gcda-fix.patch"
- if use injection; then epatch "${FILESDIR}/${PN}-r1886.patch"; fi
- for dir in ath ath_hal net80211 ath_rate ath_rate/amrr ath_rate/onoe ath_rate/sample; do
- convert_to_m "${S}"/${dir}/Makefile
- done
-
- kernel_is ge 2 6 22 && epatch "${FILESDIR}"/madwifi-2.6.22.patch
-}
-
-src_install() {
- linux-mod_src_install
-
- dodoc README THANKS docs/users-guide.pdf docs/WEP-HOWTO.txt
-}
-
-pkg_postinst() {
- local moddir="${ROOT}/lib/modules/${KV_FULL}/net/"
-
- linux-mod_pkg_postinst
-
- einfo
- einfo "Interfaces (athX) are now automatically created upon loading the ath_pci"
- einfo "module."
- einfo
- einfo "The type of the created interface can be controlled through the 'autocreate'"
- einfo "module parameter."
- einfo
- einfo "As of net-wireless/madwifi-ng-0.9.3 rate control module selection is done at"
- einfo "module load time via the 'ratectl' module parameter. USE flags amrr and onoe"
- einfo "no longer serve any purpose."
-}
diff --git a/net-wireless/madwifi-ng/madwifi-ng-0.9.3.2.ebuild b/net-wireless/madwifi-ng/madwifi-ng-0.9.3.2.ebuild
deleted file mode 100644
index 1f03fbc86d37..000000000000
--- a/net-wireless/madwifi-ng/madwifi-ng-0.9.3.2.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/madwifi-ng/madwifi-ng-0.9.3.2.ebuild,v 1.8 2008/11/15 16:19:47 pva Exp $
-
-inherit linux-mod
-
-MY_P=${PN/-ng/}-${PV}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="Next Generation driver for Atheros based IEEE 802.11a/b/g wireless LAN cards"
-HOMEPAGE="http://www.madwifi-project.org/"
-SRC_URI="mirror://sourceforge/madwifi/madwifi-${PV}.tar.bz2"
-
-LICENSE="atheros-hal
- || ( BSD GPL-2 )"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="injection"
-
-DEPEND="app-arch/sharutils"
-RDEPEND="!net-wireless/madwifi-old
- net-wireless/wireless-tools
- ~net-wireless/madwifi-ng-tools-${PV}"
-
-CONFIG_CHECK="CRYPTO WIRELESS_EXT SYSCTL"
-ERROR_CRYPTO="${P} requires Cryptographic API support (CONFIG_CRYPTO)."
-ERROR_WIRELESS_EXT="${P} requires CONFIG_WIRELESS_EXT selected by Wireless LAN drivers (non-hamradio) & Wireless Extensions"
-ERROR_SYSCTL="${P} requires Sysctl support (CONFIG_SYSCTL)."
-BUILD_TARGETS="all"
-MODULESD_ATH_PCI_DOCS="README"
-
-pkg_setup() {
- linux-mod_pkg_setup
-
- MODULE_NAMES="ath_hal(net:"${S}"/ath_hal)
- wlan(net:"${S}"/net80211)
- wlan_acl(net:"${S}"/net80211)
- wlan_ccmp(net:"${S}"/net80211)
- wlan_tkip(net:"${S}"/net80211)
- wlan_wep(net:"${S}"/net80211)
- wlan_xauth(net:"${S}"/net80211)
- wlan_scan_sta(net:"${S}"/net80211)
- wlan_scan_ap(net:"${S}"/net80211)
- ath_rate_amrr(net:"${S}"/ath_rate/amrr)
- ath_rate_onoe(net:"${S}"/ath_rate/onoe)
- ath_rate_sample(net:"${S}"/ath_rate/sample)
- ath_pci(net:"${S}"/ath)"
-
- BUILD_PARAMS="KERNELPATH=${KV_OUT_DIR}"
-}
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- epatch "${FILESDIR}/${PN}-0.9.3-uudecode-gcda-fix.patch"
- if use injection; then epatch "${FILESDIR}/${PN}-r1886.patch"; fi
- for dir in ath ath_hal net80211 ath_rate ath_rate/amrr ath_rate/onoe ath_rate/sample; do
- convert_to_m "${S}"/${dir}/Makefile
- done
-}
-
-src_install() {
- linux-mod_src_install
-
- dodoc README THANKS docs/users-guide.pdf docs/WEP-HOWTO.txt
-}
-
-pkg_postinst() {
- local moddir="${ROOT}/lib/modules/${KV_FULL}/net/"
-
- linux-mod_pkg_postinst
-
- einfo
- einfo "Interfaces (athX) are now automatically created upon loading the ath_pci"
- einfo "module."
- einfo
- einfo "The type of the created interface can be controlled through the 'autocreate'"
- einfo "module parameter."
- einfo
- einfo "As of net-wireless/madwifi-ng-0.9.3 rate control module selection is done at"
- einfo "module load time via the 'ratectl' module parameter. USE flags amrr and onoe"
- einfo "no longer serve any purpose."
-}