summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2015-05-03 19:10:49 +0000
committerRick Farina <zerochaos@gentoo.org>2015-05-03 19:10:49 +0000
commit24ffdab3f8aee6bfdd29a9aa6fa5f7b3e81998e6 (patch)
tree26705291976e536c27627cad6a4f0fcf4d9e3a42 /net-wireless
parentVersion bump (diff)
downloadgentoo-2-24ffdab3f8aee6bfdd29a9aa6fa5f7b3e81998e6.tar.gz
gentoo-2-24ffdab3f8aee6bfdd29a9aa6fa5f7b3e81998e6.tar.bz2
gentoo-2-24ffdab3f8aee6bfdd29a9aa6fa5f7b3e81998e6.zip
update to distutils-r1
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/ubertooth/ChangeLog5
-rw-r--r--net-wireless/ubertooth/ubertooth-9999.ebuild61
2 files changed, 30 insertions, 36 deletions
diff --git a/net-wireless/ubertooth/ChangeLog b/net-wireless/ubertooth/ChangeLog
index 623b918d3d98..279d5640aa4a 100644
--- a/net-wireless/ubertooth/ChangeLog
+++ b/net-wireless/ubertooth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-wireless/ubertooth
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/ubertooth/ChangeLog,v 1.29 2015/05/03 04:45:41 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/ubertooth/ChangeLog,v 1.30 2015/05/03 19:10:49 zerochaos Exp $
+
+ 03 May 2015; Rick Farina <zerochaos@gentoo.org> ubertooth-9999.ebuild:
+ update to distutils-r1
03 May 2015; Rick Farina <zerochaos@gentoo.org> ubertooth-9999.ebuild:
changed from python dfu to C dfu implementation
diff --git a/net-wireless/ubertooth/ubertooth-9999.ebuild b/net-wireless/ubertooth/ubertooth-9999.ebuild
index b823609adc4a..e6a582525536 100644
--- a/net-wireless/ubertooth/ubertooth-9999.ebuild
+++ b/net-wireless/ubertooth/ubertooth-9999.ebuild
@@ -1,31 +1,29 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/ubertooth/ubertooth-9999.ebuild,v 1.28 2015/05/03 04:45:41 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/ubertooth/ubertooth-9999.ebuild,v 1.29 2015/05/03 19:10:49 zerochaos Exp $
EAPI="5"
-PYTHON_DEPEND="python? 2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_OPTIONAL=1
-inherit multilib distutils cmake-utils udev
+inherit multilib distutils-r1 cmake-utils udev
HOMEPAGE="http://ubertooth.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+bluez +specan +pcap +python +ubertooth1-firmware +udev"
-REQUIRED_USE=" specan? ( python )
- python? ( specan )"
+IUSE="+bluez +specan +pcap +ubertooth1-firmware +udev"
+REQUIRED_USE=" specan? ( ${PYTHON_REQUIRED_USE} )"
DEPEND="bluez? ( net-wireless/bluez:= )
>=net-libs/libbtbb-${PV}:=
pcap? ( net-libs/libbtbb[pcap] )
+ specan? ( ${PYTHON_DEPS} )
virtual/libusb:1="
RDEPEND="${DEPEND}
specan? ( >=dev-qt/qtgui-4.7.2:4
- >=dev-python/pyside-1.0.2
- >=dev-python/numpy-1.3
- >=dev-python/pyusb-1.0.0_alpha1 )
+ >=dev-python/pyside-1.0.2[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.3[${PYTHON_USEDEP}] )
udev? ( virtual/udev )"
MY_PV=${PV/\./-}
@@ -38,7 +36,6 @@ if [[ ${PV} == "9999" ]] ; then
else
S="${WORKDIR}/${PN}-${MY_PV}/host"
SRC_URI="https://github.com/greatscottgadgets/${PN}/releases/download/${MY_PV}/${PN}-${MY_PV}.tar.xz"
- #re-add arm keyword after making a lib-only target
KEYWORDS="~amd64 ~arm ~x86"
fi
DESCRIPTION="An open source wireless development platform suitable for Bluetooth experimentation"
@@ -46,20 +43,13 @@ DESCRIPTION="An open source wireless development platform suitable for Bluetooth
#readd firmware building, but do it right
#USE="-fortran -mudflap -nls -openmp -multilib" crossdev --without-headers --genv 'EXTRA_ECONF="--with-mode=thumb --with-cpu=cortex-m3 --with-float=soft"' -s4 -t arm-cortexm3-eabi
-pkg_setup() {
- if use python; then
- python_pkg_setup;
- DISTUTILS_SETUP_FILES=()
- if use specan; then
- DISTUTILS_SETUP_FILES+=("${S}/python/specan_ui|setup.py")
- PYTHON_MODNAME+=" specan"
- fi
- fi
-}
-
src_prepare() {
cmake-utils_src_prepare
- use python && distutils_src_prepare
+ if use specan; then
+ pushd python/specan_ui || die
+ distutils-r1_src_prepare
+ popd
+ fi
}
src_configure() {
@@ -81,31 +71,32 @@ src_configure() {
src_compile() {
cmake-utils_src_compile
- use python && distutils_src_compile
+ if use specan; then
+ pushd python/specan_ui || die
+ distutils-r1_src_compile
+ popd
+ fi
}
src_install() {
cmake-utils_src_install
insinto /usr/share/${PN}
- cd "${WORKDIR}/${PN}-${MY_PV}" || die
+ pushd "${WORKDIR}/${PN}-${MY_PV}" || die
if [[ ${PV} == "9999" ]] ; then
ewarn "Firmware isn't available for git releases, we assume you are already"
ewarn "on the latest and/or can build your own."
else
use ubertooth1-firmware && newins ubertooth-one-firmware-bin/bluetooth_rxtx.dfu ${PN}-one-${PV}-bluetooth_rxtx.dfu
fi
+ popd
- use python && distutils_src_install
+ if use specan; then
+ pushd python/specan_ui || die
+ distutils-r1_src_install
+ popd
+ fi
elog "Everyone can read from the ubertooth, but to talk to it"
elog "your user needs to be in the usb group."
}
-
-pkg_postinst() {
- use python && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use python && distutils_pkg_postrm
-}