summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-08-10 08:48:24 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-08-10 08:48:24 +0000
commit8ef41ed27d018681b1bef4e92de7ff83674dfd84 (patch)
tree1a4dbfc6b043427aa12f176915822a5dcaac0059 /net-wireless
parentBuild with gstreamer enabled again. (diff)
downloadgentoo-2-8ef41ed27d018681b1bef4e92de7ff83674dfd84.tar.gz
gentoo-2-8ef41ed27d018681b1bef4e92de7ff83674dfd84.tar.bz2
gentoo-2-8ef41ed27d018681b1bef4e92de7ff83674dfd84.zip
Dummy revision bump to let upstream ./configure logic read udevdir from udev.pc pkg-config file wrt #430414 by Egor Y. Egorov
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/bluez/ChangeLog8
-rw-r--r--net-wireless/bluez/bluez-4.101-r2.ebuild173
2 files changed, 180 insertions, 1 deletions
diff --git a/net-wireless/bluez/ChangeLog b/net-wireless/bluez/ChangeLog
index fea1eba9cbc8..5a294b8d0f2f 100644
--- a/net-wireless/bluez/ChangeLog
+++ b/net-wireless/bluez/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/bluez
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/ChangeLog,v 1.140 2012/07/23 15:40:24 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/ChangeLog,v 1.141 2012/08/10 08:48:24 ssuominen Exp $
+
+*bluez-4.101-r2 (10 Aug 2012)
+
+ 10 Aug 2012; Samuli Suominen <ssuominen@gentoo.org> +bluez-4.101-r2.ebuild:
+ Dummy revision bump to let upstream ./configure logic read udevdir from
+ udev.pc pkg-config file wrt #430414 by Egor Y. Egorov
23 Jul 2012; <swift@gentoo.org> bluez-4.98-r2.ebuild, bluez-4.99.ebuild,
bluez-4.101-r1.ebuild:
diff --git a/net-wireless/bluez/bluez-4.101-r2.ebuild b/net-wireless/bluez/bluez-4.101-r2.ebuild
new file mode 100644
index 000000000000..0f5716e8be91
--- /dev/null
+++ b/net-wireless/bluez/bluez-4.101-r2.ebuild
@@ -0,0 +1,173 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/bluez-4.101-r2.ebuild,v 1.1 2012/08/10 08:48:24 ssuominen Exp $
+
+EAPI="4"
+PYTHON_DEPEND="test-programs? 2"
+
+inherit multilib eutils systemd python user
+
+DESCRIPTION="Bluetooth Tools and System Daemons for Linux"
+HOMEPAGE="http://www.bluez.org/"
+
+# Because of oui.txt changing from time to time without noticement, we need to supply it
+# ourselves instead of using http://standards.ieee.org/regauth/oui/oui.txt directly.
+# See bugs #345263 and #349473 for reference.
+OUIDATE="20120623"
+SRC_URI="mirror://kernel/linux/bluetooth/${P}.tar.xz
+ http://dev.gentoo.org/~pacho/bluez/oui-${OUIDATE}.txt.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="alsa +consolekit cups debug gstreamer selinux pcmcia test-programs usb readline"
+
+CDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=sys-apps/dbus-1.4
+ >=sys-fs/udev-169
+ alsa? (
+ media-libs/alsa-lib[alsa_pcm_plugins_extplug(+),alsa_pcm_plugins_ioplug(+)]
+ media-libs/libsndfile
+ )
+ cups? ( net-print/cups )
+ gstreamer? (
+ >=media-libs/gstreamer-0.10:0.10
+ >=media-libs/gst-plugins-base-0.10:0.10
+ )
+ selinux? ( sec-policy/selinux-bluetooth )
+ usb? ( virtual/libusb:0 )
+ readline? ( sys-libs/readline )
+"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ sys-devel/flex
+ test-programs? ( >=dev-libs/check-0.9.6 )
+"
+RDEPEND="${CDEPEND}
+ !net-wireless/bluez-libs
+ !net-wireless/bluez-utils
+ consolekit? (
+ || ( sys-auth/consolekit
+ >=sys-apps/systemd-37 )
+ )
+ test-programs? (
+ dev-python/dbus-python
+ dev-python/pygobject:2
+ )
+"
+
+DOCS=( AUTHORS ChangeLog README )
+
+pkg_setup() {
+ if ! use consolekit; then
+ enewgroup plugdev
+ fi
+
+ if use test-programs; then
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ if ! use consolekit; then
+ # No consolekit for at_console etc, so we grant plugdev the rights
+ epatch "${FILESDIR}/bluez-plugdev.patch"
+ fi
+
+ if use cups; then
+ sed -i \
+ -e "s:cupsdir = \$(libdir)/cups:cupsdir = `cups-config --serverbin`:" \
+ Makefile.tools Makefile.in || die
+ fi
+}
+
+src_configure() {
+ use readline || export ac_cv_header_readline_readline_h=no
+
+ econf \
+ --enable-hid2hci \
+ --enable-audio \
+ --enable-bccmd \
+ --enable-datafiles \
+ --enable-dfutool \
+ --enable-input \
+ --enable-network \
+ --enable-serial \
+ --enable-service \
+ --enable-tools \
+ --disable-hal \
+ --localstatedir=/var \
+ --with-systemdunitdir="$(systemd_get_unitdir)" \
+ $(use_enable alsa) \
+ $(use_enable cups) \
+ $(use_enable debug) \
+ $(use_enable gstreamer) \
+ $(use_enable pcmcia) \
+ $(use_enable test-programs test) \
+ $(use_enable usb) \
+ --enable-health \
+ --enable-maemo6 \
+ --enable-pnat \
+ --enable-wiimote
+}
+
+src_install() {
+ default
+
+ if use test-programs ; then
+ cd "${S}/test"
+ dobin simple-agent simple-service monitor-bluetooth
+ newbin list-devices list-bluetooth-devices
+ rm test-textfile.{c,o} || die # bug #356529
+ for b in hsmicro hsplay test-* ; do
+ newbin "${b}" "bluez-${b}"
+ done
+ insinto /usr/share/doc/${PF}/test-services
+ doins service-*
+
+ python_convert_shebangs -r 2 "${ED}"
+ cd "${S}"
+ fi
+
+ insinto /etc/bluetooth
+ doins \
+ input/input.conf \
+ audio/audio.conf \
+ network/network.conf \
+ serial/serial.conf
+
+ newinitd "${FILESDIR}/bluetooth-init.d-r2" bluetooth
+ newinitd "${FILESDIR}/rfcomm-init.d" rfcomm
+ newconfd "${FILESDIR}/rfcomm-conf.d" rfcomm
+
+ # Install oui.txt as requested in bug #283791 and approved by upstream
+ insinto /var/lib/misc
+ newins "${WORKDIR}/oui-${OUIDATE}.txt" oui.txt
+
+ prune_libtool_files --all
+}
+
+pkg_postinst() {
+ udevadm control --reload-rules
+
+ if ! has_version "net-dialup/ppp"; then
+ elog "To use dial up networking you must install net-dialup/ppp."
+ fi
+
+ if use consolekit; then
+ elog "If you want to use rfcomm as a normal user, you need to add the user"
+ elog "to the uucp group."
+ else
+ elog "Since you have the consolekit use flag disabled, you will only be able to run"
+ elog "bluetooth clients as root. If you want to be able to run bluetooth clientes as "
+ elog "a regular user, you need to enable the consolekit use flag for this package or"
+ elog "to add the user to the plugdev group."
+ fi
+
+ if [ "$(rc-config list default | grep bluetooth)" = "" ] ; then
+ elog "You will need to add bluetooth service to default runlevel"
+ elog "for getting your devices detected. For that please run:"
+ elog "'rc-update add bluetooth default'"
+ fi
+}