summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-11-05 02:31:53 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-11-05 02:31:53 +0000
commit8a3a2face50d68e8b8dc2e5b9039d99687c3a4e6 (patch)
tree004e7e56780bad40d3075611a2d160ee664915a3 /net-www/links
parentadded junit (diff)
downloadgentoo-2-8a3a2face50d68e8b8dc2e5b9039d99687c3a4e6.tar.gz
gentoo-2-8a3a2face50d68e8b8dc2e5b9039d99687c3a4e6.tar.bz2
gentoo-2-8a3a2face50d68e8b8dc2e5b9039d99687c3a4e6.zip
version bump
Diffstat (limited to 'net-www/links')
-rw-r--r--net-www/links/ChangeLog9
-rw-r--r--net-www/links/files/digest-links-2.1_pre61
-rw-r--r--net-www/links/links-2.1_pre6.ebuild107
3 files changed, 116 insertions, 1 deletions
diff --git a/net-www/links/ChangeLog b/net-www/links/ChangeLog
index 418babca0c69..a1e31d39185c 100644
--- a/net-www/links/ChangeLog
+++ b/net-www/links/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-www/links
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/links/ChangeLog,v 1.16 2002/10/24 15:37:30 naz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/links/ChangeLog,v 1.17 2002/11/05 02:31:53 seemant Exp $
+
+*links-2.1_pre6 (04 Nov 2002)
+
+ 04 Nov 2002; Seemant Kulleen <seemant@gentoo.org> links-2.1_pre6.ebuild
+ files/digest-links-2.1_pre6 :
+
+ Version bump thanks to: autobot@midsouth.rr.com (AutoBot) in bug #10226.
*links-2.1_pre3 (30 Sep 2002)
diff --git a/net-www/links/files/digest-links-2.1_pre6 b/net-www/links/files/digest-links-2.1_pre6
new file mode 100644
index 000000000000..30258d154d62
--- /dev/null
+++ b/net-www/links/files/digest-links-2.1_pre6
@@ -0,0 +1 @@
+MD5 435edbc41323bf50ddfd74c88b920c87 links-2.1pre6.tar.bz2 3532819
diff --git a/net-www/links/links-2.1_pre6.ebuild b/net-www/links/links-2.1_pre6.ebuild
new file mode 100644
index 000000000000..eb795fc0209c
--- /dev/null
+++ b/net-www/links/links-2.1_pre6.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/links/links-2.1_pre6.ebuild,v 1.1 2002/11/05 02:31:53 seemant Exp $
+
+IUSE="ssl java png X gpm tiff fbcon svga jpeg"
+
+DESCRIPTION="links is a fast lightweight text tand graphic web-browser"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~clock/twibright/links/"
+
+# To handle pre-version ...
+MYP="${P/_/}"
+S="${WORKDIR}/${MYP}"
+SRC_URI="${HOMEPAGE}/download/${MYP}.tar.bz2"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+# Note: if X or fbcon usegflag are enabled, links will be built in graphic
+# mode. libpng is required to compile links in graphic mode
+# (not required in text mode), so let's add libpng for X? and fbcon?
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6c )
+ gpm? ( sys-libs/gpm )
+ java? ( >=sys-devel/flex-2.5.4a )
+ png? ( >=media-libs/libpng-1.2.1 )
+ jpeg? ( >=media-libs/jpeg-6b )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ svga? ( >=media-libs/svgalib-1.4.3 >=media-libs/libpng-1.2.1 )
+ X? ( virtual/x11 >=media-libs/libpng-1.2.1 )
+ fbcon? ( >=media-libs/libpng-1.2.1 )"
+
+PROVIDE="virtual/textbrowser"
+
+src_compile (){
+
+ local myconf
+ myconf="--program-suffix=2"
+
+ use X \
+ && myconf="${myconf} --enable-graphics --with-x" \
+ || myconf="${myconf} --without-x"
+
+ use png \
+ && myconf="${myconf} --with-libpng" \
+ || myconf="${myconf} --without-libpng"
+
+ use jpeg \
+ && myconf="${myconf} --with-libjpeg" \
+ || myconf="${myconf} --without-libjpeg"
+
+ use tiff \
+ && myconf="${myconf} --with-libtiff" \
+ || myconf="${myconf} --without-libtiff"
+
+ use svga \
+ && myconf="${myconf} --enable-graphics --with-svgalib" \
+ || myconf="${myconf} --without-svgalib"
+
+ use fbcon \
+ && myconf="${myconf} --enable-graphics --with-fb" \
+ || myconf="${myconf} --without-fb"
+
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+
+ use java \
+ && myconf="${myconf} --enable-javascript" \
+ || myconf="${myconf} --disable-javascript"
+
+ # Note: --enable-static breaks.
+
+ # Note: ./configure only support 'gpm' features auto-detection, so if
+ # 'sys-libs/gpm' is compiled on your system, you'll compile links
+ # with gpm support ...
+
+ econf ${myconf}
+ emake || die "make failed"
+}
+
+src_install (){
+ einstall
+
+ if [ ! -f /usr/bin/links ]
+ then
+ dosym links2 /usr/bin/links
+ fi
+
+ # Only install links icon if X driver was compiled in ...
+ use X && { insinto /usr/share/pixmaps ; doins graphics/links.xpm ; }
+
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README SITES TODO
+ dohtml doc/links_cal/*
+}
+
+
+pkg_postinst() {
+
+ if use svga
+ then
+ einfo "You had the svga USE flag enabled, but for security reasons"
+ einfo "the links2 binary is NOT setuid by default. In order to"
+ einfo "enable links2 to work in SVGA, please change the permissions"
+ einfo "of /usr/bin/links2 to enable suid."
+ fi
+}