summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-06-12 00:07:43 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-06-12 00:07:43 +0000
commitf189d45af0d4138945e83bfd552d50fdfeb22fc3 (patch)
tree9cf9d88672baa8e931e64792c22dc1d17703aa42 /net-www/links
parentversion bump (diff)
downloadgentoo-2-f189d45af0d4138945e83bfd552d50fdfeb22fc3.tar.gz
gentoo-2-f189d45af0d4138945e83bfd552d50fdfeb22fc3.tar.bz2
gentoo-2-f189d45af0d4138945e83bfd552d50fdfeb22fc3.zip
version bump
Diffstat (limited to 'net-www/links')
-rw-r--r--net-www/links/ChangeLog8
-rw-r--r--net-www/links/Manifest5
-rw-r--r--net-www/links/files/digest-links-2.1_pre111
-rw-r--r--net-www/links/links-2.1_pre11.ebuild107
4 files changed, 118 insertions, 3 deletions
diff --git a/net-www/links/ChangeLog b/net-www/links/ChangeLog
index 7865c19b4255..e15f0b103d9a 100644
--- a/net-www/links/ChangeLog
+++ b/net-www/links/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/links
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/links/ChangeLog,v 1.26 2003/03/25 23:57:25 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/links/ChangeLog,v 1.27 2003/06/12 00:07:38 seemant Exp $
+
+*links-2.1_pre11 (11 Jun 2003)
+
+ 11 Jun 2003; Seemant Kulleen <seemant@gentoo.org> links-2.1_pre11.ebuild:
+ version bump thanks to: Ingo -LaSombra- Hoffmann <las0mbra@ig.com.br> in bug
+ #22557
*links-2.1_pre9 (04 Mar 2003)
diff --git a/net-www/links/Manifest b/net-www/links/Manifest
index cad6e49f2646..39e003ac5476 100644
--- a/net-www/links/Manifest
+++ b/net-www/links/Manifest
@@ -1,6 +1,7 @@
MD5 9bb3f208f5fd02bb5992913f271c4887 links-0.96-r2.ebuild 1200
-MD5 4ef939c81b46c7df7c2760c12dc172a3 links-2.1_pre11.ebuild 2893
-MD5 8e25797fe739ecfa1cd84c70f2b663f9 ChangeLog 5421
+MD5 4ef939c81b46c7df7c2760c12dc172a3 links-2.1_pre9.ebuild 2893
+MD5 70f2c3dcb2ca701af1ff7b49a3f4a84d links-2.1_pre11.ebuild 2903
+MD5 9b69c98153ddc3ba285c91eaec0e17c4 ChangeLog 5622
MD5 52bed2c64a669feed86577cb52f8cbb5 files/links-0.96-r2-gentoo.patch 1400
MD5 e8eedeca8d9b94ce7cc0e5f919500740 files/digest-links-2.1_pre9 67
MD5 71861032c7ce183e3427e4e205748323 files/digest-links-2.1_pre11 68
diff --git a/net-www/links/files/digest-links-2.1_pre11 b/net-www/links/files/digest-links-2.1_pre11
new file mode 100644
index 000000000000..97a6808a1732
--- /dev/null
+++ b/net-www/links/files/digest-links-2.1_pre11
@@ -0,0 +1 @@
+MD5 8544fbf8e18ce1ecd3f7337365fdfc8b links-2.1pre11.tar.bz2 3737197
diff --git a/net-www/links/links-2.1_pre11.ebuild b/net-www/links/links-2.1_pre11.ebuild
new file mode 100644
index 000000000000..185d59403874
--- /dev/null
+++ b/net-www/links/links-2.1_pre11.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/links/links-2.1_pre11.ebuild,v 1.1 2003/06/12 00:07:38 seemant Exp $
+
+IUSE="ssl java png X gpm tiff fbcon svga jpeg"
+
+DESCRIPTION="links is a fast lightweight text tand graphic web-browser"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~clock/twibright/links/"
+
+# To handle pre-version ...
+MYP="${P/_/}"
+S="${WORKDIR}/${MYP}"
+SRC_URI="${HOMEPAGE}/download/${MYP}.tar.bz2"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa"
+
+# Note: if X or fbcon usegflag are enabled, links will be built in graphic
+# mode. libpng is required to compile links in graphic mode
+# (not required in text mode), so let's add libpng for X? and fbcon?
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6c )
+ gpm? ( sys-libs/gpm )
+ java? ( >=sys-devel/flex-2.5.4a )
+ png? ( >=media-libs/libpng-1.2.1 )
+ jpeg? ( >=media-libs/jpeg-6b )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ svga? ( >=media-libs/svgalib-1.4.3 >=media-libs/libpng-1.2.1 )
+ X? ( virtual/x11 >=media-libs/libpng-1.2.1 )
+ fbcon? ( >=media-libs/libpng-1.2.1 )"
+
+PROVIDE="virtual/textbrowser"
+
+src_compile (){
+
+ local myconf
+ myconf="--program-suffix=2"
+
+ use X \
+ && myconf="${myconf} --enable-graphics --with-x" \
+ || myconf="${myconf} --without-x"
+
+ use png \
+ && myconf="${myconf} --with-libpng" \
+ || myconf="${myconf} --without-libpng"
+
+ use jpeg \
+ && myconf="${myconf} --with-libjpeg" \
+ || myconf="${myconf} --without-libjpeg"
+
+ use tiff \
+ && myconf="${myconf} --with-libtiff" \
+ || myconf="${myconf} --without-libtiff"
+
+ use svga \
+ && myconf="${myconf} --enable-graphics --with-svgalib" \
+ || myconf="${myconf} --without-svgalib"
+
+ use fbcon \
+ && myconf="${myconf} --enable-graphics --with-fb" \
+ || myconf="${myconf} --without-fb"
+
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+
+ use java \
+ && myconf="${myconf} --enable-javascript" \
+ || myconf="${myconf} --disable-javascript"
+
+ # Note: --enable-static breaks.
+
+ # Note: ./configure only support 'gpm' features auto-detection, so if
+ # 'sys-libs/gpm' is compiled on your system, you'll compile links
+ # with gpm support ...
+
+ econf ${myconf}
+ emake || die "make failed"
+}
+
+src_install (){
+ einstall
+
+ if [ ! -f /usr/bin/links ]
+ then
+ dosym links2 /usr/bin/links
+ fi
+
+ # Only install links icon if X driver was compiled in ...
+ use X && { insinto /usr/share/pixmaps ; doins graphics/links.xpm ; }
+
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README SITES TODO
+ dohtml doc/links_cal/*
+}
+
+
+pkg_postinst() {
+
+ if use svga
+ then
+ einfo "You had the svga USE flag enabled, but for security reasons"
+ einfo "the links2 binary is NOT setuid by default. In order to"
+ einfo "enable links2 to work in SVGA, please change the permissions"
+ einfo "of /usr/bin/links2 to enable suid."
+ fi
+}