summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-03-16 06:09:20 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-03-16 06:09:20 +0000
commitb8c077f8a6e440c01226b94e8fb88c911ea08d1d (patch)
tree4cdb821b1b20f8b9942054e2ba9934ab00129c89 /net-www/mozilla-firefox
parentAdd some missing m4s to fix autoconf problems. (diff)
downloadgentoo-2-b8c077f8a6e440c01226b94e8fb88c911ea08d1d.tar.gz
gentoo-2-b8c077f8a6e440c01226b94e8fb88c911ea08d1d.tar.bz2
gentoo-2-b8c077f8a6e440c01226b94e8fb88c911ea08d1d.zip
Use proper toolchain commands.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-www/mozilla-firefox')
-rw-r--r--net-www/mozilla-firefox/ChangeLog6
-rw-r--r--net-www/mozilla-firefox/mozilla-firefox-1.0.1.ebuild7
2 files changed, 10 insertions, 3 deletions
diff --git a/net-www/mozilla-firefox/ChangeLog b/net-www/mozilla-firefox/ChangeLog
index 101bb269e74d..58b609c6051a 100644
--- a/net-www/mozilla-firefox/ChangeLog
+++ b/net-www/mozilla-firefox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/mozilla-firefox
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/ChangeLog,v 1.103 2005/03/02 19:53:10 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/ChangeLog,v 1.104 2005/03/16 06:09:20 eradicator Exp $
+
+ 16 Mar 2005; Jeremy Huddleston <eradicator@gentoo.org>
+ mozilla-firefox-1.0.1.ebuild:
+ Use proper toolchain commands.
02 Mar 2005; Guy Martin <gmsoft@gentoo.org> mozilla-firefox-1.0.1.ebuild:
Stable on hppa.
diff --git a/net-www/mozilla-firefox/mozilla-firefox-1.0.1.ebuild b/net-www/mozilla-firefox/mozilla-firefox-1.0.1.ebuild
index 6b46d6c71d5d..246725434726 100644
--- a/net-www/mozilla-firefox/mozilla-firefox-1.0.1.ebuild
+++ b/net-www/mozilla-firefox/mozilla-firefox-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/mozilla-firefox-1.0.1.ebuild,v 1.10 2005/03/12 19:44:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/mozilla-firefox-1.0.1.ebuild,v 1.11 2005/03/16 06:09:20 eradicator Exp $
inherit makeedit flag-o-matic gcc nsplugins eutils mozconfig mozilla-launcher multilib
@@ -96,13 +96,16 @@ src_compile() {
####################################
# ./configure picks up the mozconfig stuff
+ export LD="$(tc-getLD)"
+ export CC="$(tc-getCC)"
+ export CXX="$(tc-getCXX)"
econf
# This removes extraneous CFLAGS from the Makefiles to reduce RAM
# requirements while compiling
edit_makefiles
- emake MOZ_PHOENIX=1 || die
+ emake MOZ_PHOENIX=1 CXX="$(tc-getCXX)" CC="$(tc-getCC)" LD="$(tc-getLD)" || die
}
src_install() {