summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2002-10-15 13:24:31 +0000
committerHanno Böck <hanno@gentoo.org>2002-10-15 13:24:31 +0000
commit83a49db0ffe68d80239290e53cebaf9943e0e606 (patch)
tree3573c6a5f16d3f8aa30325caa06f6173486cd293 /net-www
parentfixes segfault with ogg (and possibly other streams) (diff)
downloadgentoo-2-83a49db0ffe68d80239290e53cebaf9943e0e606.tar.gz
gentoo-2-83a49db0ffe68d80239290e53cebaf9943e0e606.tar.bz2
gentoo-2-83a49db0ffe68d80239290e53cebaf9943e0e606.zip
fix for the mozsvg / -enable-svg
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mozilla/mozilla-1.0-r3.ebuild3
-rw-r--r--net-www/mozilla/mozilla-1.0.1-r1.ebuild3
-rw-r--r--net-www/mozilla/mozilla-1.1-r1.ebuild3
3 files changed, 6 insertions, 3 deletions
diff --git a/net-www/mozilla/mozilla-1.0-r3.ebuild b/net-www/mozilla/mozilla-1.0-r3.ebuild
index a9be4d494d62..f08a12061195 100644
--- a/net-www/mozilla/mozilla-1.0-r3.ebuild
+++ b/net-www/mozilla/mozilla-1.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.0-r3.ebuild,v 1.16 2002/10/12 19:50:32 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.0-r3.ebuild,v 1.17 2002/10/15 13:24:31 hanno Exp $
IUSE="moznomail java mozp3p mozaccess gtk2 mozinterfaceinfo ssl ldap mozxmlterm mozctl gnome mozsvg"
@@ -180,6 +180,7 @@ src_compile() {
fi
if [ -n "`use mozsvg`" ] ; then
+ export MOZ_INTERNAL_LIBART_LGPL="1"
myconf="${myconf} --enable-svg"
else
myconf="${myconf} --disable-svg"
diff --git a/net-www/mozilla/mozilla-1.0.1-r1.ebuild b/net-www/mozilla/mozilla-1.0.1-r1.ebuild
index a5a9baa6ba40..93eb5c449d02 100644
--- a/net-www/mozilla/mozilla-1.0.1-r1.ebuild
+++ b/net-www/mozilla/mozilla-1.0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.0.1-r1.ebuild,v 1.8 2002/10/13 13:00:34 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.0.1-r1.ebuild,v 1.9 2002/10/15 13:24:31 hanno Exp $
IUSE="mozxmlterm moznomail java mozp3p crypt ipv6 gtk2 mozinterfaceinfo ssl ldap mozaccess mozctl gnome mozsvg"
@@ -177,6 +177,7 @@ src_compile() {
fi
if [ -n "`use mozsvg`" ] ; then
+ export MOZ_INTERNAL_LIBART_LGPL="1"
myconf="${myconf} --enable-svg"
else
myconf="${myconf} --disable-svg"
diff --git a/net-www/mozilla/mozilla-1.1-r1.ebuild b/net-www/mozilla/mozilla-1.1-r1.ebuild
index b81262afeeeb..ada62359afa9 100644
--- a/net-www/mozilla/mozilla-1.1-r1.ebuild
+++ b/net-www/mozilla/mozilla-1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.1-r1.ebuild,v 1.7 2002/10/12 19:50:32 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.1-r1.ebuild,v 1.8 2002/10/15 13:24:31 hanno Exp $
IUSE="moznomail java mozp3p crypt ldap gtk2 mozinterfaceinfo ssl mozaccess mozxmlterm mozctl gnome mozsvg"
@@ -161,6 +161,7 @@ src_compile() {
fi
if [ -n "`use mozsvg`" ] ; then
+ export MOZ_INTERNAL_LIBART_LGPL="1"
myconf="${myconf} --enable-svg"
else
myconf="${myconf} --disable-svg"