summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2007-01-25 20:49:50 +0000
committerLuca Longinotti <chtekk@gentoo.org>2007-01-25 20:49:50 +0000
commit86fc72e9f2b188915b645d7bb307da6aeab6080c (patch)
treec3704de320ee3fafe1f7b6a40322a30c33162886 /net-www
parentStable on MIPS. (diff)
downloadgentoo-2-86fc72e9f2b188915b645d7bb307da6aeab6080c.tar.gz
gentoo-2-86fc72e9f2b188915b645d7bb307da6aeab6080c.tar.bz2
gentoo-2-86fc72e9f2b188915b645d7bb307da6aeab6080c.zip
Cleanup.
(Portage version: 2.1.2-r4)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mod_ftpd/ChangeLog5
-rw-r--r--net-www/mod_ftpd/mod_ftpd-0.13.1.ebuild23
2 files changed, 17 insertions, 11 deletions
diff --git a/net-www/mod_ftpd/ChangeLog b/net-www/mod_ftpd/ChangeLog
index 3a98b6382427..d78ecb5d4437 100644
--- a/net-www/mod_ftpd/ChangeLog
+++ b/net-www/mod_ftpd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-www/mod_ftpd
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ftpd/ChangeLog,v 1.11 2007/01/25 16:43:19 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ftpd/ChangeLog,v 1.12 2007/01/25 20:49:50 chtekk Exp $
+
+ 25 Jan 2007; Luca Longinotti <chtekk@gentoo.org> mod_ftpd-0.13.1.ebuild:
+ Cleanup.
*mod_ftpd-0.13.1 (25 Jan 2007)
diff --git a/net-www/mod_ftpd/mod_ftpd-0.13.1.ebuild b/net-www/mod_ftpd/mod_ftpd-0.13.1.ebuild
index 12ced2b6cd74..e30f5bdf8530 100644
--- a/net-www/mod_ftpd/mod_ftpd-0.13.1.ebuild
+++ b/net-www/mod_ftpd/mod_ftpd-0.13.1.ebuild
@@ -1,19 +1,20 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ftpd/mod_ftpd-0.13.1.ebuild,v 1.1 2007/01/25 16:43:19 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ftpd/mod_ftpd-0.13.1.ebuild,v 1.2 2007/01/25 20:49:50 chtekk Exp $
-inherit eutils apache-module
+inherit apache-module
-DESCRIPTION="Apache2 protocol module which provides an FTP server"
+KEYWORDS="~ppc ~x86"
+
+DESCRIPTION="Apache2 module which provides an FTP server."
HOMEPAGE="http://www.outoforder.cc/projects/apache/mod_ftpd/"
SRC_URI="http://www.outoforder.cc/downloads/${PN}/${P}.tar.bz2"
-
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~ppc ~x86"
IUSE="dbi gdbm"
-DEPEND="gdbm? ( >=sys-libs/gdbm-1.8.0-r5 )"
+DEPEND="dbi? ( dev-db/libdbi )
+ gdbm? ( sys-libs/gdbm )"
RDEPEND="${DEPEND}"
APACHE2_EXECFILES="providers/*/.libs/*.so"
@@ -27,10 +28,12 @@ need_apache2
src_compile() {
local providers="default fail"
- use gdbm && providers="dbm ${providers}"
use dbi && providers="dbi ${providers}"
+ use gdbm && providers="dbm ${providers}"
- econf --with-apxs=${APXS2} \
- --enable-providers="${providers}" || die "econf failed!"
- emake || die "emake failed!"
+ econf \
+ --with-apxs=${APXS2} \
+ --enable-providers="${providers}" \
+ || die "econf failed"
+ emake || die "emake failed"
}