summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-07-02 10:19:20 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-07-02 10:19:20 +0000
commitde945412d77e7022f89155eb37348f139f49c989 (patch)
treea871cf60fe7faa38f355601432a3fa561e291b19 /net-www
parent(Remember to save before committing). (diff)
downloadgentoo-2-de945412d77e7022f89155eb37348f139f49c989.tar.gz
gentoo-2-de945412d77e7022f89155eb37348f139f49c989.tar.bz2
gentoo-2-de945412d77e7022f89155eb37348f139f49c989.zip
Revision bump to fix the pam.d file.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/pwauth/ChangeLog8
-rw-r--r--net-www/pwauth/files/digest-pwauth-2.3.1-r43
-rw-r--r--net-www/pwauth/files/pwauth.pam-include.16
-rw-r--r--net-www/pwauth/pwauth-2.3.1-r4.ebuild77
4 files changed, 93 insertions, 1 deletions
diff --git a/net-www/pwauth/ChangeLog b/net-www/pwauth/ChangeLog
index 1bd6d9040519..abb2b61ed01a 100644
--- a/net-www/pwauth/ChangeLog
+++ b/net-www/pwauth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/pwauth
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/pwauth/ChangeLog,v 1.9 2007/01/08 15:33:56 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/pwauth/ChangeLog,v 1.10 2007/07/02 10:19:20 flameeyes Exp $
+
+*pwauth-2.3.1-r4 (02 Jul 2007)
+
+ 02 Jul 2007; Diego Pettenò <flameeyes@gentoo.org>
+ +files/pwauth.pam-include.1, +pwauth-2.3.1-r4.ebuild:
+ Revision bump to fix the pam.d file.
08 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> pwauth-2.3.1-r2.ebuild,
pwauth-2.3.1-r3.ebuild:
diff --git a/net-www/pwauth/files/digest-pwauth-2.3.1-r4 b/net-www/pwauth/files/digest-pwauth-2.3.1-r4
new file mode 100644
index 000000000000..1d7783888469
--- /dev/null
+++ b/net-www/pwauth/files/digest-pwauth-2.3.1-r4
@@ -0,0 +1,3 @@
+MD5 9fbb03fe024b51a02fd7a15ae04a35cb pwauth-2.3.1.tar.gz 20329
+RMD160 60ed7aeca033054fbc28f397e822120de53d617b pwauth-2.3.1.tar.gz 20329
+SHA256 8d0162836998a040351d16163b03dabd7824b23d5d4fc1207fec5e0245f091ac pwauth-2.3.1.tar.gz 20329
diff --git a/net-www/pwauth/files/pwauth.pam-include.1 b/net-www/pwauth/files/pwauth.pam-include.1
new file mode 100644
index 000000000000..7f4f041b28ac
--- /dev/null
+++ b/net-www/pwauth/files/pwauth.pam-include.1
@@ -0,0 +1,6 @@
+#%PAM-1.0
+auth required pam_nologin.so
+auth include system-auth
+account include system-auth
+password include system-auth
+session include system-auth
diff --git a/net-www/pwauth/pwauth-2.3.1-r4.ebuild b/net-www/pwauth/pwauth-2.3.1-r4.ebuild
new file mode 100644
index 000000000000..96656cfe8adc
--- /dev/null
+++ b/net-www/pwauth/pwauth-2.3.1-r4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/pwauth/pwauth-2.3.1-r4.ebuild,v 1.1 2007/07/02 10:19:20 flameeyes Exp $
+
+inherit eutils toolchain-funcs pam
+
+DESCRIPTION="A Unix Web Authenticator"
+HOMEPAGE="http://www.unixpapa.com/pwauth/"
+SRC_URI="http://www.unixpapa.com/software/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="faillog pam ignore-case domain-aware"
+SLOT="0"
+
+DEPEND="pam? ( virtual/pam )"
+
+pkg_setup() {
+ local OPTS
+
+ einfo "You can configure various build time options with ENV variables:"
+ einfo
+ einfo " PWAUTH_FAILLOG Path to logfile for login failures"
+ einfo " (default: /var/log/pwauth.log)"
+ einfo " PWAUTH_SERVERUIDS Comma seperated list of UIDs allowed to run pwauth"
+ einfo " (default: 81)"
+ einfo " PWAUTH_MINUID Minimum UID for which authentication will succeed"
+ einfo " (default: 1000)"
+ einfo
+
+ PWAUTH_FAILLOG="${PWAUTH_FAILLOG:-/var/log/pwauth.log}"
+ PWAUTH_SERVERUIDS="${PWAUTH_SERVERUIDS:-81}"
+ PWAUTH_MINUID="${PWAUTH_MINUID:-1000}"
+
+ OPTS="${OPTS} -DSERVER_UIDS=${PWAUTH_SERVERUIDS}"
+ OPTS="${OPTS} -DMIN_UNIX_UID=${PWAUTH_MINUID}"
+
+ if useq faillog; then
+ OPTS="${OPTS} -DFAILLOG_PWAUTH"
+ OPTS="${OPTS} -DPATH_FAILLOG=\"\\\"${PWAUTH_FAILLOG}\\\"\""
+ fi
+
+ if useq pam; then
+ OPTS="${OPTS} -DPAM"
+ LDFLAGS="-lpam"
+ else
+ OPTS="${OPTS} -DSHADOW_SUN"
+ LDFLAGS="-lcrypt"
+ fi
+
+ if useq ignore-case; then
+ OPTS="${OPTS} -DIGNORE_CASE"
+ fi
+
+ if useq domain-aware; then
+ OPTS="${OPTS} -DOMAIN_AWARE"
+ fi
+
+ CC=$(tc-getCC)
+ CFLAGS="${CFLAGS} ${OPTS}"
+}
+
+src_unpack() {
+ unpack ${A} || die "unpack failed"
+ cd ${S} || die "cd to $s failed"
+
+ epatch "${FILESDIR}"/pwauth-gentoo.patch
+}
+
+src_install() {
+ dosbin pwauth unixgroup
+ fperms 4755 /usr/sbin/pwauth
+
+ useq pam && newpamd ${FILESDIR}/pwauth.pam-include.1 pwauth
+
+ dodoc CHANGES FORM_AUTH INSTALL README
+}