summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-09-04 10:17:25 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-09-04 10:17:25 +0000
commit3fe8e3385f32f7f0ca04f7e899358ab38496ec15 (patch)
treefe15fd515e9d5cd8720e07c90265ad40bd0a0ebd /net-zope
parentVersion bump, thank yaleks. Respect LDFLAGS. (diff)
downloadgentoo-2-3fe8e3385f32f7f0ca04f7e899358ab38496ec15.tar.gz
gentoo-2-3fe8e3385f32f7f0ca04f7e899358ab38496ec15.tar.bz2
gentoo-2-3fe8e3385f32f7f0ca04f7e899358ab38496ec15.zip
Version bump to 2.10.9
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/zope/ChangeLog7
-rw-r--r--net-zope/zope/zope-2.10.9.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/net-zope/zope/ChangeLog b/net-zope/zope/ChangeLog
index 10780f152aee..0394e76c629b 100644
--- a/net-zope/zope/ChangeLog
+++ b/net-zope/zope/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-zope/zope
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.158 2009/08/26 14:49:31 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.159 2009/09/04 10:17:25 tupone Exp $
+
+*zope-2.10.9 (04 Sep 2009)
+
+ 04 Sep 2009; Alfredo Tupone <tupone@gentoo.org> +zope-2.10.9.ebuild:
+ Version bump to 2.10.9
25 Aug 2009; Raúl Porcel <armin76@gentoo.org> zope-2.9.10-r1.ebuild,
zope-2.10.7-r1.ebuild:
diff --git a/net-zope/zope/zope-2.10.9.ebuild b/net-zope/zope/zope-2.10.9.ebuild
new file mode 100644
index 000000000000..b732a486e898
--- /dev/null
+++ b/net-zope/zope/zope-2.10.9.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.10.9.ebuild,v 1.1 2009/09/04 10:17:25 tupone Exp $
+EAPI=2
+
+inherit eutils multilib
+
+DESCRIPTION="Zope is a web application platform used for building high-performance, dynamic web sites"
+HOMEPAGE="http://www.zope.org"
+SRC_URI="http://www.zope.org/Products/Zope/${PV}/Zope-${PV}-final.tgz"
+
+LICENSE="ZPL"
+SLOT="${PV}"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND="=dev-lang/python-2.4*"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/Zope-${PV}-final"
+ZUID=zope
+ZGID=zope
+ZS_DIR=${ROOT%/}/usr/$(get_libdir)
+ZSERVDIR=${ZS_DIR}/${P}
+
+# Narrow the scope of ownership/permissions.
+# Security plan:
+# * ZUID is the superuser for all zope instances.
+# * ZGID is for a single instance's administration.
+# * Other' should not have any access to ${ZSERVDIR},
+# because they can work through the Zope web interface.
+# This should protect our code/data better.
+#
+# UPDATE: ${ZSERVDIR} is a lib directory and should be world readable
+# like e.g /usr/lib/python we do not store any user data there,
+# currently removed all custom permission stuff, for ${ZSERVDIR}
+src_configure() {
+ ./configure --prefix="${D}${ZSERVDIR}" --with-python=/usr/bin/python2.4 || die "Failed to execute ./configure ..."
+}
+
+src_install() {
+ dodoc README.txt
+ dodoc doc/*.txt
+ docinto PLATFORMS ; dodoc doc/PLATFORMS/*
+ docinto ZEO ; dodoc doc/ZEO/*
+
+ make install prefix="${D}${ZSERVDIR}" || die "Failed to install into ${D}${ZSERVDIR}"
+ rm -rf "${D}${ZSERVDIR}"/doc
+ dosym ../../share/doc/${PF} ${ZSERVDIR}/doc
+
+ # copy the init script skeleton to skel directory of our installation
+ insinto "${ZSERVDIR}"/skel
+ doins "${FILESDIR}"/zope.initd
+}
+
+pkg_postinst() {
+ # create the zope user and group for backward compatibility
+ enewgroup ${ZGID} 261
+ usermod -g ${ZGID} ${ZUID} 2>&1 >/dev/null || \
+ enewuser ${ZUID} 261 -1 /var/$(get_libdir)/zope ${ZGID}
+
+ einfo "Be warned that you need at least one zope instance to run zope."
+ einfo "Please emerge zope-config for further instance management."
+}
+
+pkg_prerm() {
+ #Remove old compiled code
+ rm ${ZSERVDIR}/bin/copyzopeskel.pyc
+
+ #need to remove this symlink because portage keeps links to
+ #existing targets
+ rm ${ZSERVDIR}/bin/python
+}