summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRadoslaw Stachowiak <radek@gentoo.org>2006-01-07 20:17:12 +0000
committerRadoslaw Stachowiak <radek@gentoo.org>2006-01-07 20:17:12 +0000
commit6754eb89f397745c4d4788f614ca52d3d582c741 (patch)
tree898d8e10a25c95c83ec4625b6c3e9f70ff929a8f /net-zope
parentVersion bump, bug #117397 (diff)
downloadgentoo-2-6754eb89f397745c4d4788f614ca52d3d582c741.tar.gz
gentoo-2-6754eb89f397745c4d4788f614ca52d3d582c741.tar.bz2
gentoo-2-6754eb89f397745c4d4788f614ca52d3d582c741.zip
version bump, finally with python 2.4 support
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/zope/ChangeLog7
-rw-r--r--net-zope/zope/Manifest2
-rw-r--r--net-zope/zope/files/digest-zope-2.9.01
-rw-r--r--net-zope/zope/zope-2.9.0.ebuild80
4 files changed, 89 insertions, 1 deletions
diff --git a/net-zope/zope/ChangeLog b/net-zope/zope/ChangeLog
index f1a644d4b4de..2f9d61af492c 100644
--- a/net-zope/zope/ChangeLog
+++ b/net-zope/zope/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-zope/zope
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.94 2006/01/02 17:51:04 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.95 2006/01/07 20:17:12 radek Exp $
+
+*zope-2.9.0 (07 Jan 2006)
+
+ 07 Jan 2006; Radoslaw Stachowiak <radek@gentoo.org> +zope-2.9.0.ebuild:
+ version bump, finally with python 2.4 support
02 Jan 2006; Michael Hanselmann <hansmi@gentoo.org> zope-2.8.4.ebuild:
Stable on ppc.
diff --git a/net-zope/zope/Manifest b/net-zope/zope/Manifest
index 5ef22055e0c9..8795a826fcf5 100644
--- a/net-zope/zope/Manifest
+++ b/net-zope/zope/Manifest
@@ -8,6 +8,7 @@ MD5 5d8e83203542dfc8d07354dcdd682134 files/digest-zope-2.7.7 66
MD5 dd38699498b0cab29b7eb5df48c4674a files/digest-zope-2.7.8 66
MD5 f26477bbd15c975a265ea05f285e728e files/digest-zope-2.8.3 66
MD5 d1db47dc244cba7522bfb1babe93f3f0 files/digest-zope-2.8.4 66
+MD5 6a7b4cbd9d48c293b592dc78f879993c files/digest-zope-2.9.0 60
MD5 af9f7a9e66ce59bf1a8a901402f6ed5e files/digest-zope-3.1.0 60
MD5 037cf91a5b4d60efe166f90210c837ed files/i18n-1.0.0.patch 8080
MD5 610f19a06033d3b55b76c7fd2d1d464d files/zope.initd 1317
@@ -17,4 +18,5 @@ MD5 17d1dd2b8f9f76cad73f610b1a484137 zope-2.7.7.ebuild 3325
MD5 14da5e25bd868d8693fc918e7ede07aa zope-2.7.8.ebuild 3325
MD5 0ce3afe5cd3f944a3fa984afa74a43af zope-2.8.3.ebuild 3512
MD5 766f6734ba9201fceb214d0dd90ac286 zope-2.8.4.ebuild 3510
+MD5 5c7985d34c7459e2c92bcd209153a922 zope-2.9.0.ebuild 2302
MD5 294c0f19cff69103751c1a8eadb92019 zope-3.1.0.ebuild 3239
diff --git a/net-zope/zope/files/digest-zope-2.9.0 b/net-zope/zope/files/digest-zope-2.9.0
new file mode 100644
index 000000000000..2eaf31f8c452
--- /dev/null
+++ b/net-zope/zope/files/digest-zope-2.9.0
@@ -0,0 +1 @@
+MD5 db36ef8c3f43574c88a4388fef80d661 Zope-2.9.0.tgz 7943193
diff --git a/net-zope/zope/zope-2.9.0.ebuild b/net-zope/zope/zope-2.9.0.ebuild
new file mode 100644
index 000000000000..b5d210c48d9d
--- /dev/null
+++ b/net-zope/zope/zope-2.9.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.9.0.ebuild,v 1.1 2006/01/07 20:17:12 radek Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Zope is a web application platform used for building high-performance, dynamic web sites."
+HOMEPAGE="http://www.zope.org"
+SRC_URI="http://www.zope.org/Products/Zope/${PV}/Zope-${PV}.tgz"
+LICENSE="ZPL"
+SLOT="${PV}"
+
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="=dev-lang/python-2.4*"
+
+DEPEND="${RDEPEND}
+virtual/libc
+>=sys-apps/sed-4.0.5"
+
+S="${WORKDIR}/Zope-${PV}"
+ZUID=zope
+ZGID=zope
+ZS_DIR=${ROOT%/}/usr/$(get_libdir)
+ZSERVDIR=${ZS_DIR}/${P}
+
+# Narrow the scope of ownership/permissions.
+# Security plan:
+# * ZUID is the superuser for all zope instances.
+# * ZGID is for a single instance's administration.
+# * Other' should not have any access to ${ZSERVDIR},
+# because they can work through the Zope web interface.
+# This should protect our code/data better.
+#
+# UPDATE: ${ZSERVDIR} is a lib directory and should be world readable
+# like e.g /usr/lib/python we do not store any user data there,
+# currently removed all custom permission stuff, for ${ZSERVDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ ./configure --prefix=. --force --with-python=/usr/bin/python2.4 || die "Failed to execute ./configure ..."
+ emake || die "Failed to compile."
+}
+
+src_install() {
+ dodoc README.txt
+ dodoc Zope/doc/*.txt
+ docinto PLATFORMS ; dodoc Zope/doc/PLATFORMS/*
+ docinto ZEO ; dodoc Zope/doc/ZEO/*
+
+ make install prefix=${D}${ZSERVDIR}
+ rm -rf ${D}${ZSERVDIR}/doc
+ dosym ../../share/doc/${PF} ${ZSERVDIR}/doc
+
+ # copy the init script skeleton to skel directory of our installation
+ cp ${FILESDIR}/zope.initd ${D}/${ZSERVDIR}/skel/zope.initd
+}
+
+pkg_postinst() {
+ # create the zope user and group for backward compatibility
+ enewgroup ${ZGID} 261
+ usermod -g ${ZGID} ${ZUID} 2>&1 >/dev/null || \
+ enewuser ${ZUID} 261 -1 /var/$(get_libdir)/zope ${ZGID}
+
+ einfo "Be warned that you need at least one zope instance to run zope."
+ einfo "Please emerge zope-config for futher instance management."
+}
+
+pkg_prerm() {
+
+ #need to remove this symlink because portage keeps links to
+ #existing targets
+ rm ${ZSERVDIR}/bin/python
+}
+