summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRadoslaw Stachowiak <radek@gentoo.org>2004-10-27 11:30:54 +0000
committerRadoslaw Stachowiak <radek@gentoo.org>2004-10-27 11:30:54 +0000
commitfa59c1a613acb1f34bca3e110e12a0cb29731e6d (patch)
tree8854d57526b98e96a43a95f70bcebe59f9277a2e /net-zope
parentNew revision which adds some missing links. Closes #60881. (Manifest recommit) (diff)
downloadgentoo-2-fa59c1a613acb1f34bca3e110e12a0cb29731e6d.tar.gz
gentoo-2-fa59c1a613acb1f34bca3e110e12a0cb29731e6d.tar.bz2
gentoo-2-fa59c1a613acb1f34bca3e110e12a0cb29731e6d.zip
version bump. new ebuild.
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/zopex3/ChangeLog8
-rw-r--r--net-zope/zopex3/Manifest2
-rw-r--r--net-zope/zopex3/files/digest-zopex3-3.0.0_rc31
-rw-r--r--net-zope/zopex3/zopex3-3.0.0_rc3.ebuild112
4 files changed, 122 insertions, 1 deletions
diff --git a/net-zope/zopex3/ChangeLog b/net-zope/zopex3/ChangeLog
index 6eabbb58a3f4..c11b6403eafc 100644
--- a/net-zope/zopex3/ChangeLog
+++ b/net-zope/zopex3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/zopex3
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zopex3/ChangeLog,v 1.5 2004/10/18 18:28:28 radek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zopex3/ChangeLog,v 1.6 2004/10/27 11:30:54 radek Exp $
+
+*zopex3-3.0.0_rc3 (27 Oct 2004)
+
+ 27 Oct 2004; Radoslaw Stachowiak <radek@gentoo.org>
+ +zopex3-3.0.0_rc3.ebuild:
+ Version bump.
18 Oct 2004; Radoslaw Stachowiak <radek@gentoo.org>
-zopex3-3.0.0_rc1.ebuild:
diff --git a/net-zope/zopex3/Manifest b/net-zope/zopex3/Manifest
index 5174c3a0e301..441c845a4644 100644
--- a/net-zope/zopex3/Manifest
+++ b/net-zope/zopex3/Manifest
@@ -1,5 +1,7 @@
+MD5 4fc688520d486024d69fee143534c67a zopex3-3.0.0_rc3.ebuild 2731
MD5 4fc688520d486024d69fee143534c67a zopex3-3.0.0_rc2.ebuild 2731
MD5 1d6bb3e0c8255a1c693d2171a322f202 ChangeLog 884
MD5 7890d88c5c6d189fbe6b187a3ebb6532 metadata.xml 161
MD5 1751a8f455e743a44fa65f7d8bd826e2 files/digest-zopex3-3.0.0_rc2 64
+MD5 0c1c59bc4cefc0e65f185f728d9d3daf files/digest-zopex3-3.0.0_rc3 64
MD5 dc6beeaa42a91779d1d707dcd32cc6cb files/zope.initd 1316
diff --git a/net-zope/zopex3/files/digest-zopex3-3.0.0_rc3 b/net-zope/zopex3/files/digest-zopex3-3.0.0_rc3
new file mode 100644
index 000000000000..0233c473ea94
--- /dev/null
+++ b/net-zope/zopex3/files/digest-zopex3-3.0.0_rc3
@@ -0,0 +1 @@
+MD5 bc1f2bea8c500fb4cbcafed05fe29afe ZopeX3-3.0.0c3.tgz 3178566
diff --git a/net-zope/zopex3/zopex3-3.0.0_rc3.ebuild b/net-zope/zopex3/zopex3-3.0.0_rc3.ebuild
new file mode 100644
index 000000000000..ebeee37757d1
--- /dev/null
+++ b/net-zope/zopex3/zopex3-3.0.0_rc3.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zopex3/zopex3-3.0.0_rc3.ebuild,v 1.1 2004/10/27 11:30:54 radek Exp $
+
+inherit eutils
+
+MYPV="${PV/_r/}"
+MYPN="ZopeX3"
+
+DESCRIPTION="Zope is a web application platform used for building high-performance, dynamic web sites."
+HOMEPAGE="http://www.zope.org"
+SRC_URI="http://www.zope.org/Products/${MYPN}/${MYPV}/${MYPN}-${MYPV}.tgz"
+LICENSE="ZPL"
+SLOT="${PV}"
+IUSE=""
+
+KEYWORDS="~x86 ~ppc"
+
+RDEPEND="=dev-lang/python-2.3*"
+python='python2.3'
+
+DEPEND="${RDEPEND}
+virtual/libc
+>=sys-apps/sed-4.0.5"
+
+S="${WORKDIR}/${MYPN}-${MYPV}"
+ZS_DIR=${ROOT%/}/usr/lib
+ZSERVDIR=${ZS_DIR}/${PN}-${PV}
+ZSKELDIR=${ZSERVDIR}/zopeskel
+ZINSTDIR=/var/lib/zope/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ ./configure --prefix=${D}${ZSERVDIR} || die "Failed to configure."
+ emake || die "Failed to compile."
+}
+
+src_install() {
+
+ dodoc README.txt
+ dodoc ZopeX3/doc/*.txt
+ docinto schema
+ dodoc ZopeX3/doc/schema/*
+ docinto security
+ dodoc ZopeX3/doc/security/*
+ docinto skins
+ dodoc ZopeX3/doc/skins/*
+ docinto style
+ dodoc ZopeX3/doc/style/*
+ docinto zcml
+ dodoc ZopeX3/doc/zcml/*
+
+ make install prefix=${D}${ZSERVDIR}
+
+ dosym ../../share/doc/${PF} ${ZSERVDIR}/doc
+
+ # copy the init script skeleton to zopeskel directory of our installation
+ cp ${FILESDIR}/zope.initd ${D}${ZSKELDIR}/zope.initd
+}
+
+pkg_postinst() {
+
+ einfo "Be warned that this release is able to create default instance for You."
+ einfo "Please use 'ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config' for instance creation"
+}
+
+pkg_prerm() {
+
+ find ${ZSERVDIR}/lib/python -name \*.py[co] -exec rm -f {} \;
+}
+
+pkg_postrm() {
+
+ rmdir /usr/lib/${ZSERVDIR} 2>/dev/null
+}
+
+pkg_config() {
+
+ if [ -f /etc/init.d/${PN} -o -d ${ZINSTDIR} ]
+ then
+ ewarn "Default instance already exists, aborting.."
+ ewarn "Please delete first /etc/init.d/${PN} and ${ZINSTDIR}"
+ die "Failed to create default instance."
+ fi
+
+ ${ZSERVDIR}/bin/mkzopeinstance -d ${ZINSTDIR} -u admin:admin
+ mkdir -p ${ZINSTDIR}
+
+ # remove unnecessary zope.initd
+ rm -f ${ZINSTDIR}/zope.initd
+
+ # log symlink
+ rm -rf ${ZINSTDIR}/log
+ mkdir -p /var/log/zope/${PN}
+ ln -s /var/log/zope/${PN} ${ZINSTDIR}/log
+
+ # draconian permissions :)
+ chmod go-rwx -R ${ZINSTDIR}
+
+ cp ${ZSKELDIR}/zope.initd /etc/init.d/${PN}
+ chmod 755 /etc/init.d/${PN}
+ sed -i -e "s|INSTANCE_HOME|${ZINSTDIR}|" /etc/init.d/${PN}
+
+ einfo "Default instance created at ${ZINSTDIR}"
+ einfo "Created default user 'admin' with password 'admin'."
+ einfo "Be warned that this instance is prepared to run as root only."
+ einfo "To start instance (ports 8080,8021,) use: /etc/init.d/${PN} start"
+}