summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2014-01-25 20:20:10 +0000
committerMikle Kolyada <zlogene@gentoo.org>2014-01-25 20:20:10 +0000
commit8d125653a75eb132d8995efd19aa47dd41512e03 (patch)
tree6f28710f3c68d9b01771d3b0fb404dee5ae50a8a /perl-core/Math-BigInt
parentremove broken version (diff)
downloadgentoo-2-8d125653a75eb132d8995efd19aa47dd41512e03.tar.gz
gentoo-2-8d125653a75eb132d8995efd19aa47dd41512e03.tar.bz2
gentoo-2-8d125653a75eb132d8995efd19aa47dd41512e03.zip
fix overload warning (bug #427040)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xC42EB5D6)
Diffstat (limited to 'perl-core/Math-BigInt')
-rw-r--r--perl-core/Math-BigInt/ChangeLog8
-rw-r--r--perl-core/Math-BigInt/Math-BigInt-1.997.0.ebuild6
-rw-r--r--perl-core/Math-BigInt/files/Math-BigInt-1.997.0-overload.patch21
3 files changed, 31 insertions, 4 deletions
diff --git a/perl-core/Math-BigInt/ChangeLog b/perl-core/Math-BigInt/ChangeLog
index f8c375397454..f01f6af3be49 100644
--- a/perl-core/Math-BigInt/ChangeLog
+++ b/perl-core/Math-BigInt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for perl-core/Math-BigInt
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/Math-BigInt/ChangeLog,v 1.84 2013/08/25 12:25:17 zlogene Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Math-BigInt/ChangeLog,v 1.85 2014/01/25 20:20:09 zlogene Exp $
+
+ 25 Jan 2014; Mikle Kolyada <zlogene@gentoo.org>
+ +files/Math-BigInt-1.997.0-overload.patch, Math-BigInt-1.997.0.ebuild:
+ fix overload warning (bug #427040)
25 Aug 2013; Mikle Kolyada <zlogene@gentoo.org> -Math-BigInt-1.89.ebuild,
-Math-BigInt-1.99.ebuild, -Math-BigInt-1.991.ebuild,
diff --git a/perl-core/Math-BigInt/Math-BigInt-1.997.0.ebuild b/perl-core/Math-BigInt/Math-BigInt-1.997.0.ebuild
index 70838e7a81df..c5f65ceffcde 100644
--- a/perl-core/Math-BigInt/Math-BigInt-1.997.0.ebuild
+++ b/perl-core/Math-BigInt/Math-BigInt-1.997.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/Math-BigInt/Math-BigInt-1.997.0.ebuild,v 1.12 2013/03/02 16:18:36 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Math-BigInt/Math-BigInt-1.997.0.ebuild,v 1.13 2014/01/25 20:20:09 zlogene Exp $
EAPI=4
@@ -21,4 +21,6 @@ PDEPEND=">=virtual/perl-Math-BigInt-FastCalc-0.270.0
>=perl-core/bignum-0.220.0
>=perl-core/Math-BigRat-0.260.200"
+PATCHES=( "${FILESDIR}/${P}-overload.patch" )
+
SRC_TEST="do"
diff --git a/perl-core/Math-BigInt/files/Math-BigInt-1.997.0-overload.patch b/perl-core/Math-BigInt/files/Math-BigInt-1.997.0-overload.patch
new file mode 100644
index 000000000000..d62e86995bfa
--- /dev/null
+++ b/perl-core/Math-BigInt/files/Math-BigInt-1.997.0-overload.patch
@@ -0,0 +1,21 @@
+diff -u Math-BigInt-1.997/lib/Math/BigInt.pm Math-BigInt-1.997-r1/lib/Math/BigInt.pm
+--- Math-BigInt-1.997/lib/Math/BigInt.pm 2011-09-03 02:26:41.000000000 -0400
++++ Math-BigInt-1.997-r1/lib/Math/BigInt.pm 2012-07-17 20:32:26.630203065 -0400
+@@ -40,6 +40,9 @@
+ # Thus inheritance of overload operators becomes possible and transparent for
+ # our subclasses without the need to repeat the entire overload section there.
+
++# https://github.com/ilmari/perl/commit/5e0688b6067afdfb59fdfa9923e658ed40c9f246
++# We register ops that are not registerable yet, so suppress warnings
++{ no warnings;
+ use overload
+ '=' => sub { $_[0]->copy(); },
+
+@@ -151,6 +154,7 @@
+ '""' => sub { $_[0]->bstr(); },
+ '0+' => sub { $_[0]->numify(); }
+ ;
++} # no warnings scope
+
+ ##############################################################################
+ # global constants, flags and accessory