summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2006-01-22 21:43:49 +0000
committerMichael Cummings <mcummings@gentoo.org>2006-01-22 21:43:49 +0000
commit0036c5591b12e783fd07288d1a6dca093ad0e56a (patch)
tree1ba9893118ee8fa5c4fb8a48edfd2b54e8afea3b /perl-core
parentunmask net-dialup/rp-pppoe-3.6 (diff)
downloadgentoo-2-0036c5591b12e783fd07288d1a6dca093ad0e56a.tar.gz
gentoo-2-0036c5591b12e783fd07288d1a6dca093ad0e56a.tar.bz2
gentoo-2-0036c5591b12e783fd07288d1a6dca093ad0e56a.zip
Yaml patch, noticed inconsistancy after 5.8.8 upgrade and perl-cleaner run
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'perl-core')
-rw-r--r--perl-core/Math-BigInt/ChangeLog8
-rw-r--r--perl-core/Math-BigInt/Manifest13
-rw-r--r--perl-core/Math-BigInt/Math-BigInt-1.77-r1.ebuild23
-rw-r--r--perl-core/Math-BigInt/files/digest-Math-BigInt-1.77-r11
-rw-r--r--perl-core/Math-BigInt/files/yaml-node-makefile.patch10
5 files changed, 44 insertions, 11 deletions
diff --git a/perl-core/Math-BigInt/ChangeLog b/perl-core/Math-BigInt/ChangeLog
index 942ffde7b22b..4cbf6880c9b4 100644
--- a/perl-core/Math-BigInt/ChangeLog
+++ b/perl-core/Math-BigInt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for perl-core/Math-BigInt
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/Math-BigInt/ChangeLog,v 1.7 2006/01/13 22:44:00 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Math-BigInt/ChangeLog,v 1.8 2006/01/22 21:43:49 mcummings Exp $
+
+*Math-BigInt-1.77-r1 (22 Jan 2006)
+
+ 22 Jan 2006; Michael Cummings <mcummings@gentoo.org>
+ +files/yaml-node-makefile.patch, +Math-BigInt-1.77-r1.ebuild:
+ Yaml patch, noticed inconsistancy after 5.8.8 upgrade and perl-cleaner run
13 Jan 2006; Michael Cummings <mcummings@gentoo.org>
Math-BigInt-1.77.ebuild:
diff --git a/perl-core/Math-BigInt/Manifest b/perl-core/Math-BigInt/Manifest
index fba868b91723..69f748ab320f 100644
--- a/perl-core/Math-BigInt/Manifest
+++ b/perl-core/Math-BigInt/Manifest
@@ -1,20 +1,13 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 a58c3f4473d11e69711defde04f2e342 ChangeLog 2779
MD5 f3a8f7c20e12a96f00dd349c49fe4525 Math-BigInt-1.69.ebuild 587
MD5 61705195ceb28c886ecb4d0ed1429d64 Math-BigInt-1.70.ebuild 592
MD5 9bb8e8e960e528c28c0a86277b0a6c2a Math-BigInt-1.73.ebuild 609
+MD5 cde97bb6ac5b88b4bc57d577e0c91f0a Math-BigInt-1.77-r1.ebuild 619
MD5 bb9aa83cd1d22925901475d06b0dae73 Math-BigInt-1.77.ebuild 620
MD5 b461900d92f57d4e040ce12dfe67f876 files/digest-Math-BigInt-1.69 68
MD5 d6a633b9a6acedb716053a67339c2a00 files/digest-Math-BigInt-1.70 68
MD5 109b3f67b6c2ed044cbd5921a74aa244 files/digest-Math-BigInt-1.73 68
MD5 6bc4996509cd0bee8aa18599440f4572 files/digest-Math-BigInt-1.77 68
+MD5 6bc4996509cd0bee8aa18599440f4572 files/digest-Math-BigInt-1.77-r1 68
+MD5 f79d878023540437599fc07d3dedd45b files/yaml-node-makefile.patch 340
MD5 e2d8f1bf77722def1dd432e26455c818 metadata.xml 305
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDy3F22+ySkm8kpY0RAsgYAKCWUJX95B7ujXwJBwdVvdimzl3BbQCeOI5a
-87fEoOPicBK/LgHPnu3gdAQ=
-=67V4
------END PGP SIGNATURE-----
diff --git a/perl-core/Math-BigInt/Math-BigInt-1.77-r1.ebuild b/perl-core/Math-BigInt/Math-BigInt-1.77-r1.ebuild
new file mode 100644
index 000000000000..23ec78535b96
--- /dev/null
+++ b/perl-core/Math-BigInt/Math-BigInt-1.77-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Math-BigInt/Math-BigInt-1.77-r1.ebuild,v 1.1 2006/01/22 21:43:49 mcummings Exp $
+
+inherit perl-module eutils
+
+DESCRIPTION="Arbitrary size floating point math package"
+HOMEPAGE="http://www.cpan.org/modules/by-authors/id/T/TE/TELS/math/${P}.readme"
+SRC_URI="mirror://cpan/authors/id/T/TE/TELS/math/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=perl-core/Scalar-List-Utils-1.14"
+
+SRC_TEST="do"
+
+src_unpack() {
+ unpack ${A}
+ has_version 'dev-perl/yaml' && epatch ${FILESDIR}/yaml-node-makefile.patch
+}
diff --git a/perl-core/Math-BigInt/files/digest-Math-BigInt-1.77-r1 b/perl-core/Math-BigInt/files/digest-Math-BigInt-1.77-r1
new file mode 100644
index 000000000000..130a7af93e97
--- /dev/null
+++ b/perl-core/Math-BigInt/files/digest-Math-BigInt-1.77-r1
@@ -0,0 +1 @@
+MD5 fcdff3ada4badb1ed00ff4cfc7752de2 Math-BigInt-1.77.tar.gz 169422
diff --git a/perl-core/Math-BigInt/files/yaml-node-makefile.patch b/perl-core/Math-BigInt/files/yaml-node-makefile.patch
new file mode 100644
index 000000000000..fd279575d433
--- /dev/null
+++ b/perl-core/Math-BigInt/files/yaml-node-makefile.patch
@@ -0,0 +1,10 @@
+--- Math-BigInt-1.77/Makefile.PL 2005-03-20 07:00:49.000000000 -0500
++++ Math-BigInt-1.77.new/Makefile.PL 2006-01-22 16:37:01.000000000 -0500
+@@ -9,6 +9,7 @@ sub MY::metafile {
+ return $self->SUPER::metafile_target(@_);
+ };
+
++ use YAML::Node;
+ my $node = new YAML::Node {};
+
+ $node->{name} = $self->{DISTNAME};