summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-06-12 10:42:45 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-06-12 10:42:45 +0000
commitec28ca1a17bf4d0228c1004a2c22bb888b718f63 (patch)
tree518da8e74e3736a1b4829bc45cb671372aa37411 /sci-astronomy/celestia/files
parentCorrect dependencies wrt #371215 by Piotr Szymaniak <lazy_bum@o2.pl>. Fix typ... (diff)
downloadgentoo-2-ec28ca1a17bf4d0228c1004a2c22bb888b718f63.tar.gz
gentoo-2-ec28ca1a17bf4d0228c1004a2c22bb888b718f63.tar.bz2
gentoo-2-ec28ca1a17bf4d0228c1004a2c22bb888b718f63.zip
Version bump wrt #370499 by Nils Larsson <ni1s@nerdshack.com>. Fixes building with gcc-4.6 (bug #366073)
(Portage version: 2.2.0_alpha36/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/celestia/files')
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.1-as-needed.patch19
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.1-gcc46.patch13
2 files changed, 32 insertions, 0 deletions
diff --git a/sci-astronomy/celestia/files/celestia-1.6.1-as-needed.patch b/sci-astronomy/celestia/files/celestia-1.6.1-as-needed.patch
new file mode 100644
index 000000000000..5b9d2ddfc03c
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.6.1-as-needed.patch
@@ -0,0 +1,19 @@
+Fixes building with as-needed
+
+Patch written by Nils Larsson <ni1s@nerdshack.com>
+--- src/celestia/Makefile.am
++++ src/celestia/Makefile.am
+@@ -10,11 +10,13@@
+ celestiaKDELIBS = $(LIB_QT) $(LIB_KDECORE) $(LIB_KDEUI) $(LIB_KFILE) \
+ $(LIBSOCKET) kde/libkdegui.a
+ celestia_LDFLAGS = $(all_libraries) $(KDE_RPATH)
++LIBS += $(LIB_QT) $(LIB_KDECORE) $(LIB_KDEUI) $(LIB_KFILE)
+ endif
+
+ if ENABLE_GTK
+ SUBDIRS += gtk
+ celestiaGTKLIBS = $(GTK_LIBS) gtk/libgtkgui.a
++LIBS += $(GTK_LIBS)
+ endif
+
+ COMMONSOURCES = \
diff --git a/sci-astronomy/celestia/files/celestia-1.6.1-gcc46.patch b/sci-astronomy/celestia/files/celestia-1.6.1-gcc46.patch
new file mode 100644
index 000000000000..ddf4036f2d66
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.6.1-gcc46.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/show_bug.cgi?id=366073
+
+Patch written by Nils Larsson <ni1s@nerdshack.com>
+--- src/celengine/frametree.h
++++ src/celengine/frametree.h
+@@ -14,6 +14,7 @@
+ #define _CELENGINE_FRAMETREE_H_
+
+ #include <vector>
++#include <cstddef>
+
+ class Star;
+ class Body;