summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-11-06 12:00:17 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-11-06 12:00:17 +0000
commit220cfa6b5e01f7dabc65f0ca5508f6357000a740 (patch)
treeb0bcd30f069b92f00af1d055025e25fd0c6b6aff /sci-astronomy/celestia
parentStable for HPPA (bug #224743). (diff)
downloadgentoo-2-220cfa6b5e01f7dabc65f0ca5508f6357000a740.tar.gz
gentoo-2-220cfa6b5e01f7dabc65f0ca5508f6357000a740.tar.bz2
gentoo-2-220cfa6b5e01f7dabc65f0ca5508f6357000a740.zip
Added a unicode flag to encode iso-8859-1 doc files into utf8, closing bug #245280
(Portage version: 2.2_rc11/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'sci-astronomy/celestia')
-rw-r--r--sci-astronomy/celestia/ChangeLog7
-rw-r--r--sci-astronomy/celestia/celestia-1.5.1.ebuild12
2 files changed, 16 insertions, 3 deletions
diff --git a/sci-astronomy/celestia/ChangeLog b/sci-astronomy/celestia/ChangeLog
index 6630c86e3166..8957c538bd28 100644
--- a/sci-astronomy/celestia/ChangeLog
+++ b/sci-astronomy/celestia/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/celestia
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.43 2008/11/06 00:07:30 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.44 2008/11/06 12:00:17 bicatali Exp $
+
+ 06 Nov 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ celestia-1.5.1.ebuild:
+ Added a unicode flag to encode iso-8859-1 doc files into utf8, closing
+ bug #245280.
05 Nov 2008; Markus Dittrich <markusle@gentoo.org>
+files/celestia-1.5.1-kde-3.5.patch, celestia-1.5.1.ebuild:
diff --git a/sci-astronomy/celestia/celestia-1.5.1.ebuild b/sci-astronomy/celestia/celestia-1.5.1.ebuild
index fd4a15e87fd7..077baa0c0698 100644
--- a/sci-astronomy/celestia/celestia-1.5.1.ebuild
+++ b/sci-astronomy/celestia/celestia-1.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.5.1.ebuild,v 1.3 2008/11/06 00:07:30 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.5.1.ebuild,v 1.4 2008/11/06 12:00:17 bicatali Exp $
inherit eutils flag-o-matic gnome2 kde-functions autotools
@@ -15,7 +15,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="arts cairo gnome gtk kde lua nls pch theora threads"
+IUSE="arts cairo gnome gtk kde lua nls pch theora threads unicode"
RDEPEND="virtual/glu
media-libs/jpeg
@@ -104,6 +104,14 @@ src_unpack() {
-e '/AM_GCONF_SOURCE_2/d' \
configure.in || die "sed failed"
fi
+ if use unicode; then
+ pushd locale > /dev/null
+ for i in guide_{de,es,fr,it,nl,sv}.cel start_de.cel demo_nl.cel; do
+ iconv -f iso-8859-1 ${i} -t utf8 > ${i}.utf8
+ mv ${i}.utf8 ${i}
+ done
+ popd > /dev/null
+ fi
eautoreconf
}