summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-11-02 09:12:23 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-11-02 09:12:23 +0000
commitb631dab7cd402dbb9c8c2e6e7e2bd02bb9b009ab (patch)
tree7ccd770927fc85a7ee19382b9b3aa77d0c7faf70 /sci-astronomy/ds9
parentquote variables (diff)
downloadgentoo-2-b631dab7cd402dbb9c8c2e6e7e2bd02bb9b009ab.tar.gz
gentoo-2-b631dab7cd402dbb9c8c2e6e7e2bd02bb9b009ab.tar.bz2
gentoo-2-b631dab7cd402dbb9c8c2e6e7e2bd02bb9b009ab.zip
fixed for compiler (bug #197396, thanks Joshua Rich)
(Portage version: 2.1.3.14)
Diffstat (limited to 'sci-astronomy/ds9')
-rw-r--r--sci-astronomy/ds9/ChangeLog5
-rw-r--r--sci-astronomy/ds9/ds9-4.13.ebuild10
2 files changed, 11 insertions, 4 deletions
diff --git a/sci-astronomy/ds9/ChangeLog b/sci-astronomy/ds9/ChangeLog
index 482f02b06413..4d2ccdc90050 100644
--- a/sci-astronomy/ds9/ChangeLog
+++ b/sci-astronomy/ds9/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-astronomy/ds9
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ChangeLog,v 1.3 2007/08/17 09:54:01 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ChangeLog,v 1.4 2007/11/02 09:12:23 bicatali Exp $
+
+ 02 Nov 2007; Sébastien Fabbro <bicatali@gentoo.org> ds9-4.13.ebuild:
+ fixed for compiler (bug #197396, thanks Joshua Rich)
17 Aug 2007; Sébastien Fabbro <bicatali@gentoo.org> ds9-4.13.ebuild:
added virtual/xemacs as possible provider of etags
diff --git a/sci-astronomy/ds9/ds9-4.13.ebuild b/sci-astronomy/ds9/ds9-4.13.ebuild
index 0d9afdbfd564..f21163a4e7e9 100644
--- a/sci-astronomy/ds9/ds9-4.13.ebuild
+++ b/sci-astronomy/ds9/ds9-4.13.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ds9-4.13.ebuild,v 1.4 2007/08/17 09:54:01 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ds9-4.13.ebuild,v 1.5 2007/11/02 09:12:23 bicatali Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils toolchain-funcs
DESCRIPTION="Data visualization application for astronomical FITS images"
HOMEPAGE="http://hea-www.harvard.edu/RD/ds9"
@@ -43,7 +43,11 @@ src_compile() {
# This is a long and fragile compilation
# which recompiles tcl/tk, tkimg, blt, funtools,
# and a lot of other packages
- emake -j1 OPTS="${CXXFLAGS}" || die "emake failed"
+ emake -j1 \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ OPTS="${CXXFLAGS}" \
+ || die "emake failed"
}
src_install () {