summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-11-22 19:48:22 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-11-22 19:48:22 +0000
commit965c8574561201fd14a4e94cadd60652e971e550 (patch)
treef89802e5e623841e566b24757d0e8c5bf81d110a /sci-astronomy/wcslib
parentVersion bump, drop old (diff)
downloadgentoo-2-965c8574561201fd14a4e94cadd60652e971e550.tar.gz
gentoo-2-965c8574561201fd14a4e94cadd60652e971e550.tar.bz2
gentoo-2-965c8574561201fd14a4e94cadd60652e971e550.zip
Version bump
(Portage version: 2.2.7-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-astronomy/wcslib')
-rw-r--r--sci-astronomy/wcslib/ChangeLog7
-rw-r--r--sci-astronomy/wcslib/wcslib-4.19.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/sci-astronomy/wcslib/ChangeLog b/sci-astronomy/wcslib/ChangeLog
index f83410068bec..061d6377d614 100644
--- a/sci-astronomy/wcslib/ChangeLog
+++ b/sci-astronomy/wcslib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/wcslib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v 1.36 2013/07/08 17:24:22 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v 1.37 2013/11/22 19:48:22 bicatali Exp $
+
+*wcslib-4.19 (22 Nov 2013)
+
+ 22 Nov 2013; Sébastien Fabbro <bicatali@gentoo.org> +wcslib-4.19.ebuild:
+ Version bump
08 Jul 2013; Sébastien Fabbro <bicatali@gentoo.org> -wcslib-4.16.ebuild:
Version bump
diff --git a/sci-astronomy/wcslib/wcslib-4.19.ebuild b/sci-astronomy/wcslib/wcslib-4.19.ebuild
new file mode 100644
index 000000000000..69e4692693c1
--- /dev/null
+++ b/sci-astronomy/wcslib/wcslib-4.19.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/wcslib-4.19.ebuild,v 1.1 2013/11/22 19:48:22 bicatali Exp $
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+
+inherit eutils fortran-2 multilib
+
+DESCRIPTION="Astronomical World Coordinate System transformations library"
+HOMEPAGE="http://www.atnf.csiro.au/people/mcalabre/WCS/"
+SRC_URI="ftp://ftp.atnf.csiro.au/pub/software/${PN}/${P}.tar.bz2"
+
+SLOT="0/4"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc fortran fits pgplot static-libs"
+
+RDEPEND="
+ fits? ( sci-libs/cfitsio )
+ pgplot? ( sci-libs/pgplot )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i -e 's/COPYING\*//' GNUmakefile || die
+}
+
+src_configure() {
+ local myconf=()
+ # hacks because cfitsio and pgplot directories are hard-coded
+ if use fits; then
+ myconf+=(
+ --with-cfitsioinc="${EROOT}/usr/include"
+ --with-cfitsiolib="${EROOT}/usr/$(get_libdir)"
+ )
+ else
+ myconf+=( --without-cfitsio )
+ fi
+ if use pgplot; then
+ myconf+=(
+ --with-pgplotinc="${EROOT}/usr/include"
+ --with-pgplotlib="${EROOT}/usr/$(get_libdir)"
+ )
+ else
+ myconf+=( --without-pgplot )
+ fi
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable static-libs static) \
+ $(use_enable fortran) \
+ ${myconf[@]}
+}
+
+src_compile() {
+ # nasty makefile, debugging means full rewrite
+ emake -j1
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install () {
+ default
+ # static libs are same as shared (compiled with PIC)
+ # so they are not compiled twice
+ use static-libs || rm "${ED}"/usr/$(get_libdir)/lib*.a
+ use doc || rm -r "${ED}"/usr/share/doc/${PF}/html \
+ "${ED}"/usr/share/doc/${PF}/*.pdf
+}