summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-06-12 16:29:33 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-06-12 16:29:33 +0000
commit185078e96b2721201c247a882aba7dacc538c0d9 (patch)
treec94bde19cbd7acbb22c6becd18e9af8d0318e9a3 /sci-astronomy
parentnet-misc/cbugzilla-0.2.0 bump (diff)
downloadgentoo-2-185078e96b2721201c247a882aba7dacc538c0d9.tar.gz
gentoo-2-185078e96b2721201c247a882aba7dacc538c0d9.tar.bz2
gentoo-2-185078e96b2721201c247a882aba7dacc538c0d9.zip
Switch to EAPI5
(Portage version: 2.2.01.21938-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/pyephem/ChangeLog7
-rw-r--r--sci-astronomy/pyephem/pyephem-3.7.5.1.ebuild50
2 files changed, 27 insertions, 30 deletions
diff --git a/sci-astronomy/pyephem/ChangeLog b/sci-astronomy/pyephem/ChangeLog
index dc8bdb687f8d..b9535f3ae1b8 100644
--- a/sci-astronomy/pyephem/ChangeLog
+++ b/sci-astronomy/pyephem/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-astronomy/pyephem
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/ChangeLog,v 1.19 2012/11/19 07:38:41 xarthisius Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/ChangeLog,v 1.20 2013/06/12 16:29:33 bicatali Exp $
+
+ 12 Jun 2013; Sébastien Fabbro <bicatali@gentoo.org> pyephem-3.7.5.1.ebuild:
+ Switch to EAPI5
19 Nov 2012; Kacper Kowalik <xarthisius@gentoo.org> pyephem-3.7.5.1.ebuild:
Drop inherit of eutils.eclass, introduce new dependencies for tests, simplify
diff --git a/sci-astronomy/pyephem/pyephem-3.7.5.1.ebuild b/sci-astronomy/pyephem/pyephem-3.7.5.1.ebuild
index 09c1da6e07de..657b83109f9b 100644
--- a/sci-astronomy/pyephem/pyephem-3.7.5.1.ebuild
+++ b/sci-astronomy/pyephem/pyephem-3.7.5.1.ebuild
@@ -1,14 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/pyephem-3.7.5.1.ebuild,v 1.4 2012/11/19 07:38:41 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/pyephem-3.7.5.1.ebuild,v 1.5 2013/06/12 16:29:33 bicatali Exp $
-EAPI=4
+EAPI=5
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.* *-jython 2.7-pypy-*"
+PYTHON_COMPAT=( python2_{5,6,7} )
-inherit distutils
+inherit distutils-r1
DESCRIPTION="Astronomical routines for the python programming language"
HOMEPAGE="http://rhodesmill.org/pyephem/"
@@ -17,46 +15,42 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
+IUSE="doc test"
-DEPEND="doc? ( dev-python/sphinx )
- test? ( || ( dev-lang/python:2.7 dev-python/unittest2 ) )"
+DEPEND="
+ doc? ( dev-python/sphinx )
+ test? ( virtual/python-unittest2[${PYTHON_USEDEP}] )"
RDEPEND=""
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
src_prepare() {
# don't install rst files
sed -i -e "s:'doc/\*\.rst',::" setup.py || die
- distutils_src_prepare
+ distutils-r1_src_prepare
}
src_compile() {
- distutils_src_compile
+ distutils-r1_src_compile
if use doc; then
PYTHONPATH=. emake -C src/ephem/doc html
fi
}
-src_test() {
- testing() {
- if [[ ${PYTHON_ABI} == "2.7" ]]; then
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib*)" \
- "$(PYTHON)" -m unittest discover -s src/ephem
- else
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib*)" \
- unit2-${PYTHON_ABI} discover -s src/ephem
- fi
- }
- python_execute_function testing
+python_test() {
+ if [[ ${PYTHON_ABI} == "2.7" ]]; then
+ PYTHONPATH="$(ls -d ${BUILD_DIR}/lib*)" \
+ ${EPYTHON} -m unittest discover -s src/ephem
+ else
+ PYTHONPATH="$(ls -d ${BUILD_DIR}/lib*)" \
+ unit2 discover -s src/ephem
+ fi
}
src_install() {
- distutils_src_install
+ distutils-r1_src_install
use doc && dohtml -r src/ephem/doc/_build/html/*
delete_tests() {
- rm -rf "${ED}$(python_get_sitedir)/ephem/tests"
+ rm -r "${D}$(python_get_sitedir)/ephem/tests" || die
}
- python_execute_function -q delete_tests
+ python_foreach_impl delete_tests
}