summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-11-14 18:57:29 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-11-14 18:57:29 +0000
commit20389604200523b31c9631e61a5906684763d915 (patch)
tree5da8720a88a3e4697d293d69bf9ede38a10a2dcb /sci-astronomy
parentVersion bump (diff)
downloadgentoo-2-20389604200523b31c9631e61a5906684763d915.tar.gz
gentoo-2-20389604200523b31c9631e61a5906684763d915.tar.bz2
gentoo-2-20389604200523b31c9631e61a5906684763d915.zip
Version bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/wcstools/ChangeLog7
-rw-r--r--sci-astronomy/wcstools/wcstools-3.8.7.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/sci-astronomy/wcstools/ChangeLog b/sci-astronomy/wcstools/ChangeLog
index b320c2ee9d8f..e371ffba84bd 100644
--- a/sci-astronomy/wcstools/ChangeLog
+++ b/sci-astronomy/wcstools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/wcstools
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcstools/ChangeLog,v 1.25 2012/08/21 11:50:52 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcstools/ChangeLog,v 1.26 2012/11/14 18:57:29 bicatali Exp $
+
+*wcstools-3.8.7 (14 Nov 2012)
+
+ 14 Nov 2012; Sébastien Fabbro <bicatali@gentoo.org> +wcstools-3.8.7.ebuild:
+ Version bump
*wcstools-3.8.6 (21 Aug 2012)
diff --git a/sci-astronomy/wcstools/wcstools-3.8.7.ebuild b/sci-astronomy/wcstools/wcstools-3.8.7.ebuild
new file mode 100644
index 000000000000..7687240dfa11
--- /dev/null
+++ b/sci-astronomy/wcstools/wcstools-3.8.7.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcstools/wcstools-3.8.7.ebuild,v 1.1 2012/11/14 18:57:29 bicatali Exp $
+
+EAPI=4
+
+inherit autotools eutils multilib
+
+DESCRIPTION="World Coordinate System library for astronomical FITS images"
+HOMEPAGE="http://tdc-www.harvard.edu/software/wcstools"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DOCS=( Readme Programs NEWS libned/NED_client )
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-3.8.3-autotools.patch \
+ "${FILESDIR}"/${PN}-3.8.4-implicits.patch
+
+ # avoid colliding with fixdos, getdate and remap from other packages
+ sed -i \
+ -e 's/getdate/wcsgetdate/' \
+ -e 's/crlf/wcscrlf/' \
+ -e 's/remap/wcsremap/' \
+ -e "s/3.... Programs/${PV} Programs/" \
+ wcstools || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_test() {
+ einfo "Testing various wcstools programs"
+ ./newfits -a 10 -j 248 41 -p 0.15 test.fits || die "test newfits failed"
+ ./sethead test.fits A=1 B=1 || die "test sethead failed"
+ [[ "$(./gethead test.fits RA)" == "16:32:00.0000" ]] \
+ || die "test gethead failed"
+ rm test.fits
+}
+
+src_install() {
+ default
+ use static-libs || rm -rf "${ED}"/usr/$(get_libdir)/*.la
+ doman man/man1/*
+ newdoc libwcs/Readme Readme.libwcs
+ newdoc libwcs/NEWS NEWS.libwcs
+}
+
+pkg_postinst() {
+ elog "The following execs have been renamed to avoid colliding"
+ elog "with other packages:"
+ elog " getdate -> wcsgetdate"
+ elog " crlf -> wcscrlf"
+ elog " remap -> wcsremap"
+}