summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-06-26 21:49:49 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-06-26 21:49:49 +0000
commit40ba44b2bfb917575bf708c93be1c79ef3c5459b (patch)
treeb00f487f1ce4416cd9be71a6f1a6a7e47b2f3f34 /sci-astronomy
parentamd64 stable, security bug ##273905 (diff)
downloadgentoo-2-40ba44b2bfb917575bf708c93be1c79ef3c5459b.tar.gz
gentoo-2-40ba44b2bfb917575bf708c93be1c79ef3c5459b.tar.bz2
gentoo-2-40ba44b2bfb917575bf708c93be1c79ef3c5459b.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/wcslib/ChangeLog10
-rw-r--r--sci-astronomy/wcslib/wcslib-4.3.3.ebuild (renamed from sci-astronomy/wcslib/wcslib-4.3.ebuild)28
2 files changed, 30 insertions, 8 deletions
diff --git a/sci-astronomy/wcslib/ChangeLog b/sci-astronomy/wcslib/ChangeLog
index a0ee95a3cdaa..b33a328cc5b6 100644
--- a/sci-astronomy/wcslib/ChangeLog
+++ b/sci-astronomy/wcslib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/wcslib
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v 1.3 2008/12/08 11:58:10 bicatali Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v 1.4 2009/06/26 21:49:49 bicatali Exp $
+
+*wcslib-4.3.3 (26 Jun 2009)
+
+ 26 Jun 2009; Sébastien Fabbro <bicatali@gentoo.org> -wcslib-4.3.ebuild,
+ +wcslib-4.3.3.ebuild:
+ Version bump
*wcslib-4.3-r1 (08 Dec 2008)
diff --git a/sci-astronomy/wcslib/wcslib-4.3.ebuild b/sci-astronomy/wcslib/wcslib-4.3.3.ebuild
index 360b2601b7c1..1770231eacd5 100644
--- a/sci-astronomy/wcslib/wcslib-4.3.ebuild
+++ b/sci-astronomy/wcslib/wcslib-4.3.3.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/wcslib-4.3.ebuild,v 1.2 2008/11/05 21:56:07 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/wcslib-4.3.3.ebuild,v 1.1 2009/06/26 21:49:49 bicatali Exp $
-inherit fortran eutils
+EAPI=2
+inherit eutils
DESCRIPTION="Astronomical World Coordinate System transformations library"
HOMEPAGE="http://www.atnf.csiro.au/people/mcalabre/WCS/"
@@ -13,10 +14,24 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="sci-libs/pgplot
+RDEPEND="sci-libs/pgplot
sci-libs/cfitsio"
+DEPEND="${RDEPEND}"
-FORTRAN="gfortran ifc g77"
+src_prepare() {
+ sed -i \
+ -e 's/$(SHRLD)/$(SHRLD) $(LDFLAGS)/' \
+ C/GNUmakefile || die
+}
+
+src_compile() {
+ # -j1 forced. build system too crappy to be worth debugging
+ emake -j1 || die "emake failed"
+}
+
+rc_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
src_install () {
# make install from makefile is buggy
@@ -30,7 +45,8 @@ src_install () {
dosym libpgsbox-${PV}.a /usr/$(get_libdir)/libpgsbox.a
insinto /usr/include/${P}
- doins pgsbox/*.h C/*.h Fortran/*inc || die "headers install failed"
+ doins wcsconfig.h wcsconfig_f77.h || die
+ doins pgsbox/*.h C/*.h Fortran/*inc || die
dosym ${P} /usr/include/${PN}
dodoc README