summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMalcolm Lashley <malc@gentoo.org>2006-10-22 20:52:25 +0000
committerMalcolm Lashley <malc@gentoo.org>2006-10-22 20:52:25 +0000
commit653ec49a2613f5aa8e5567a3fe308f55f9b9c928 (patch)
tree0b6fde7da59de630ead997dcc6d6a7261656028d /sci-astronomy
parentFix typo. (diff)
downloadgentoo-2-653ec49a2613f5aa8e5567a3fe308f55f9b9c928.tar.gz
gentoo-2-653ec49a2613f5aa8e5567a3fe308f55f9b9c928.tar.bz2
gentoo-2-653ec49a2613f5aa8e5567a3fe308f55f9b9c928.zip
Make it work on 64bit archs again... bug #151306
(Portage version: 2.1.2_pre3-r6)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/stellarium/ChangeLog6
-rw-r--r--sci-astronomy/stellarium/files/stellarium-0.8.2-amd64.patch11
-rw-r--r--sci-astronomy/stellarium/stellarium-0.8.2.ebuild9
3 files changed, 24 insertions, 2 deletions
diff --git a/sci-astronomy/stellarium/ChangeLog b/sci-astronomy/stellarium/ChangeLog
index 749bfaba210d..770f350fe0f5 100644
--- a/sci-astronomy/stellarium/ChangeLog
+++ b/sci-astronomy/stellarium/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-astronomy/stellarium
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stellarium/ChangeLog,v 1.24 2006/10/06 21:47:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stellarium/ChangeLog,v 1.25 2006/10/22 20:52:25 malc Exp $
+
+ 22 Oct 2006; <malc@gentoo.org> +files/stellarium-0.8.2-amd64.patch,
+ stellarium-0.8.2.ebuild:
+ amd64 fixlet - bug #151306
*stellarium-0.8.2 (06 Oct 2006)
diff --git a/sci-astronomy/stellarium/files/stellarium-0.8.2-amd64.patch b/sci-astronomy/stellarium/files/stellarium-0.8.2-amd64.patch
new file mode 100644
index 000000000000..f59ab5e13e2b
--- /dev/null
+++ b/sci-astronomy/stellarium/files/stellarium-0.8.2-amd64.patch
@@ -0,0 +1,11 @@
+--- src/translator.cpp 2006-10-05 09:12:12.000000000 +0100
++++ src/translator.cpp 2006-10-22 21:34:22.000000000 +0100
+@@ -71,7 +71,7 @@
+ }
+
+ //change systemLangName to ISO 639 / ISO 3166.
+- unsigned int pos = Translator::systemLangName.find(':', 0);
++ std::string::size_type pos = Translator::systemLangName.find(':', 0);
+ if(pos != Translator::systemLangName.npos)
+ Translator::systemLangName.resize(pos);
+ pos = Translator::systemLangName.find('.', 0);
diff --git a/sci-astronomy/stellarium/stellarium-0.8.2.ebuild b/sci-astronomy/stellarium/stellarium-0.8.2.ebuild
index cf051169f42c..e03b7994097e 100644
--- a/sci-astronomy/stellarium/stellarium-0.8.2.ebuild
+++ b/sci-astronomy/stellarium/stellarium-0.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stellarium/stellarium-0.8.2.ebuild,v 1.1 2006/10/06 21:47:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stellarium/stellarium-0.8.2.ebuild,v 1.2 2006/10/22 20:52:25 malc Exp $
inherit eutils flag-o-matic
@@ -24,6 +24,13 @@ DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
|| ( x11-libs/libXt virtual/x11 )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-amd64.patch"
+}
+
+
src_compile() {
append-flags -fno-strict-aliasing
econf \