summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-01-29 02:15:18 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-01-29 02:15:18 +0000
commitd354a1bded1491a6cdb15904bd1b9774505c7880 (patch)
treefbdec8c5d5a4b63fca48772f075669d1391cc5a6 /sci-astronomy
parentLinux patches 2.6.32.5, 2.6.32.6 and 2.6.32.7. Removal of redundant patches (diff)
downloadgentoo-2-d354a1bded1491a6cdb15904bd1b9774505c7880.tar.gz
gentoo-2-d354a1bded1491a6cdb15904bd1b9774505c7880.tar.bz2
gentoo-2-d354a1bded1491a6cdb15904bd1b9774505c7880.zip
Version bump
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/funtools/ChangeLog10
-rw-r--r--sci-astronomy/funtools/funtools-1.4.4.ebuild57
2 files changed, 65 insertions, 2 deletions
diff --git a/sci-astronomy/funtools/ChangeLog b/sci-astronomy/funtools/ChangeLog
index 8a669424f8ac..af2f56ff57fd 100644
--- a/sci-astronomy/funtools/ChangeLog
+++ b/sci-astronomy/funtools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/funtools
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/funtools/ChangeLog,v 1.4 2009/01/09 22:44:37 josejx Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/funtools/ChangeLog,v 1.5 2010/01/29 02:15:18 bicatali Exp $
+
+*funtools-1.4.4 (29 Jan 2010)
+
+ 29 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ +funtools-1.4.4.ebuild:
+ Version bump
09 Jan 2009; Joseph Jezak <josejx@gentoo.org> funtools-1.4.0.ebuild:
Marked ~ppc for bug #253299.
diff --git a/sci-astronomy/funtools/funtools-1.4.4.ebuild b/sci-astronomy/funtools/funtools-1.4.4.ebuild
new file mode 100644
index 000000000000..b11114caadbb
--- /dev/null
+++ b/sci-astronomy/funtools/funtools-1.4.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/funtools/funtools-1.4.4.ebuild,v 1.1 2010/01/29 02:15:18 bicatali Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="FITS library and utlities for astronomical images"
+HOMEPAGE="http://www.cfa.harvard.edu/~john/funtools/"
+SRC_URI="http://cfa-www.harvard.edu/~john/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND="sys-libs/zlib
+ sci-astronomy/wcstools
+ sci-visualization/gnuplot"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e "s:\${LINK}:\${LINK} ${LDFLAGS}:" \
+ mklib || die "sed for ldflags failed"
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --enable-dl \
+ --enable-mainlib \
+ --with-wcslib="$(pkg-config --libs wcstools)" \
+ --with-zlib=-lz \
+ --with-tcl=-ltcl \
+ WCS_INC="$(pkg-config --cflags wcstools)"
+}
+
+src_compile() {
+ emake || die "emake failed"
+ emake shtclfun || die "emake tcl functions failed"
+}
+
+src_install () {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ # install missing includes
+ insinto /usr/include/funtools/fitsy
+ doins fitsy/*.h || die
+ if use doc; then
+ cd doc
+ insinto /usr/share/doc/${PF}
+ doins *.pdf || die
+ insinto /usr/share/doc/${PF}/html
+ doins *.html *.c || die
+ fi
+}