summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-08-11 17:57:46 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-08-11 17:57:46 +0000
commitf1c521365eb4cacfdb4209105220882cf5d36432 (patch)
treedce98135d6a495aedc0f72c6062bf08c8ff6765d /sci-astronomy
parentUse bzip2 compressed distfile in order to save some 20% of space. (diff)
downloadgentoo-2-f1c521365eb4cacfdb4209105220882cf5d36432.tar.gz
gentoo-2-f1c521365eb4cacfdb4209105220882cf5d36432.tar.bz2
gentoo-2-f1c521365eb4cacfdb4209105220882cf5d36432.zip
Cleaned an obsolete function, added a patch for test, and avoid FORTIFY_SOURCE (but only fixes the C part, not the FORTRAN one)
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/wcslib/ChangeLog7
-rw-r--r--sci-astronomy/wcslib/files/wcslib-4.3.3-tests.patch11
-rw-r--r--sci-astronomy/wcslib/wcslib-4.3.3-r1.ebuild18
3 files changed, 29 insertions, 7 deletions
diff --git a/sci-astronomy/wcslib/ChangeLog b/sci-astronomy/wcslib/ChangeLog
index 83ca0aa9b5d9..41f947c1a267 100644
--- a/sci-astronomy/wcslib/ChangeLog
+++ b/sci-astronomy/wcslib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/wcslib
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v 1.5 2009/07/16 18:46:27 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v 1.6 2009/08/11 17:57:46 bicatali Exp $
+
+ 11 Aug 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ wcslib-4.3.3-r1.ebuild, +files/wcslib-4.3.3-tests.patch:
+ Cleaned an obsolete function, added a patch for test, and avoid
+ FORTIFY_SOURCE (but only fixes the C part, not the FORTRAN one)
*wcslib-4.3.3-r1 (16 Jul 2009)
diff --git a/sci-astronomy/wcslib/files/wcslib-4.3.3-tests.patch b/sci-astronomy/wcslib/files/wcslib-4.3.3-tests.patch
new file mode 100644
index 000000000000..02ea580c7e1a
--- /dev/null
+++ b/sci-astronomy/wcslib/files/wcslib-4.3.3-tests.patch
@@ -0,0 +1,11 @@
+--- C/GNUmakefile.orig 2009-08-11 17:13:16.000000000 +0100
++++ C/GNUmakefile 2009-08-11 17:13:43.000000000 +0100
+@@ -137,7 +137,7 @@
+ -@ echo ''
+ -@ $(TIMER)
+ @ if [ '$<' = tcel2 ] ; then \
+- echo N | $< ; \
++ echo N | ./$< ; \
+ elif [ '$<' = tunits ] ; then \
+ ./$< < test/units_test ; \
+ elif [ '$<' != twcshdr ] ; then \
diff --git a/sci-astronomy/wcslib/wcslib-4.3.3-r1.ebuild b/sci-astronomy/wcslib/wcslib-4.3.3-r1.ebuild
index d98ca7c65c17..0705259c57c0 100644
--- a/sci-astronomy/wcslib/wcslib-4.3.3-r1.ebuild
+++ b/sci-astronomy/wcslib/wcslib-4.3.3-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/wcslib-4.3.3-r1.ebuild,v 1.1 2009/07/16 18:46:27 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/wcslib-4.3.3-r1.ebuild,v 1.2 2009/08/11 17:57:46 bicatali Exp $
EAPI=2
-inherit eutils versionator
+inherit eutils versionator virtualx flag-o-matic
DESCRIPTION="Astronomical World Coordinate System transformations library"
HOMEPAGE="http://www.atnf.csiro.au/people/mcalabre/WCS/"
@@ -16,28 +16,34 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="sci-libs/pgplot
sci-libs/cfitsio"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ test? (
+ media-fonts/font-misc-misc
+ media-fonts/font-cursor-misc )"
src_prepare() {
sed -i \
-e 's/$(SHRLD)/$(SHRLD) $(LDFLAGS)/' \
C/GNUmakefile || die
- WCSV=$(get_version_component_range 1-2)
epatch "${FILESDIR}"/${P}-flibs.patch
+ epatch "${FILESDIR}"/${P}-tests.patch
+ append-flags -U_FORTIFY_SOURCE
}
src_compile() {
# -j1 forced. build system too crappy to be worth debugging
+ # does not really fix anything
emake -j1 || die "emake failed"
}
-rc_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+src_test() {
+ Xemake -j1 check || die "emake test failed"
}
src_install () {
# make install from makefile is buggy
dobin utils/{HPXcvt,fitshdr,wcsgrid} || die "dobin failed"
+ WCSV=$(get_version_component_range 1-2)
dolib.a C/libwcs-${WCSV}.a pgsbox/libpgsbox-${WCSV}.a || die
dolib.so C/libwcs.so.${WCSV} || die
dosym libwcs.so.${WCSV} /usr/$(get_libdir)/libwcs.so