summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-08-14 16:47:20 +0000
committerJustin Lecher <jlec@gentoo.org>2012-08-14 16:47:20 +0000
commit47ce39c7d4d186e1146ac9914814c70242a28354 (patch)
tree7e414263a822b3a85393d4f2bd5494b87cccaeba /sci-biology/arb/arb-5.2.ebuild
parentRaise glib dependency per bug #420331 (diff)
downloadgentoo-2-47ce39c7d4d186e1146ac9914814c70242a28354.tar.gz
gentoo-2-47ce39c7d4d186e1146ac9914814c70242a28354.tar.bz2
gentoo-2-47ce39c7d4d186e1146ac9914814c70242a28354.zip
sci-biology/arb: Version BUmp; add fix for gcc-4.7, #431228
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/arb/arb-5.2.ebuild')
-rw-r--r--sci-biology/arb/arb-5.2.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/sci-biology/arb/arb-5.2.ebuild b/sci-biology/arb/arb-5.2.ebuild
index 55ea8e8a81e7..b843c06f88af 100644
--- a/sci-biology/arb/arb-5.2.ebuild
+++ b/sci-biology/arb/arb-5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/arb/arb-5.2.ebuild,v 1.4 2012/03/04 09:55:06 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/arb/arb-5.2.ebuild,v 1.5 2012/08/14 16:47:19 jlec Exp $
EAPI=4
@@ -46,12 +46,15 @@ src_prepare() {
"${WORKDIR}"/${P}-linker.patch \
"${FILESDIR}"/5.1-libs.patch \
"${FILESDIR}"/5.1-bfr-overflow.patch \
- "${FILESDIR}"/${PV}-libpng15.patch
- sed -i \
+ "${FILESDIR}"/${PV}-libpng15.patch \
+ "${FILESDIR}"/${P}-gcc-47.patch
+ sed \
-e 's/all: checks/all:/' \
-e "s/GCC:=.*/GCC=$(tc-getCC) ${CFLAGS}/" \
-e "s/GPP:=.*/GPP=$(tc-getCXX) ${CXXFLAGS}/" \
- "${S}/Makefile" || die
+ -e 's:-O4::g' \
+ -e 's:-pipe::g' \
+ -i "${S}/Makefile" || die
cp config.makefile.template config.makefile
sed -i -e '/^[ \t]*read/ d' -e 's/SHELL_ANS=0/SHELL_ANS=1/' "${S}/arb_install.sh" || die
use amd64 && sed -i -e 's/ARB_64 := 0/ARB_64 := 1/' config.makefile